a2a5439b90af1083f65b05bdb1d883bdd913c739
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 25
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Summary: Monitor account initialization for the root image.
29 Group: Applications/System
30
31 %description
32 Monitor is a collection of secondary scripts for configuring the node polling
33 system, syncing the PLC db with the monitoring database, notifying users,
34 interacting with PCU hardware, applying penalties to sites that violate
35 acceptable use.
36
37 ######################################## CLIENT
38
39 %package client
40 Summary: Monitor hooks for a PLC node
41 Group: Applications/System
42 Requires: curl
43 Requires: coreutils
44
45 %description client
46 The client scripts handle account creation inside of a node.  This will
47 include configuration setup for the monitoring agent running on the node.  It
48 will also include any cron or init scripts needed to perform this kind of
49 maintenance.
50 ######################################## Server Deps
51 %package server-deps
52 Summary: Monitor hooks for the PLC server.
53 Group: Applications/System
54
55 Requires: python
56 Requires: python-setuptools-devel
57 Requires: python-peak-util-extremes
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: nc
66 Requires: rt3
67
68 Requires: plewww-plekit
69
70 #Requires: zabbix-client
71 #Requires: zabbix-gui
72 #Requires: zabbix-server
73
74 %description server-deps
75 The server side include all python modules and scripts needed to fully
76
77 ######################################## Server
78 %package server
79 Summary: Monitor hooks for the PLC server.
80 Group: Applications/System
81
82 Requires: python
83
84 Requires: monitor-server-deps
85 Requires: monitor-pcucontrol
86 Requires: PLCWWW >= 4.2
87 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
88
89 %description server
90 The server side include all python modules and scripts needed to fully
91 operation, track, and interact with any third-party monitoring software, such
92 as Zabbix DB.
93
94 ######################################## PCU Control
95
96 %package pcucontrol
97 summary: pcu controls for monitor and plcapi
98 group: applications/system
99 requires: python
100 requires: OpenIPMI-tools
101
102 %description pcucontrol
103 both monitor and the plcapi use a set of common commands to reboot machines
104 using their external or internal pcus.  this package is a library of several
105 supported models.
106
107 ####################################### RunlevelAgent
108 %package runlevelagent
109 summary: the RunlevelAgent that reports node runlevels
110 group: applications/system
111 requires: python
112
113 %description runlevelagent
114 The RunlevelAgent starts as early as possible during boot-up and production
115 mode to actively report the observed runlevel to PLC and update the
116 'last_contact' field.
117
118 %prep
119 %setup -q
120
121 %build
122 # NOTE: the build uses g++ cmdamt/
123 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
124 cd pcucontrol/models/intelamt
125 export TMPDIR=$PWD/tmp
126 make
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 #################### CLIENT 
132 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
133 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
135
136
137 #################### SERVER
138 install -d $RPM_BUILD_ROOT/usr/share/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
140 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
143 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
144 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
145 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
146
147 # pack monitor's dependencies in RPM to make it easier to deploy.
148 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
149 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
150 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
151 easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
152 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
153
154 # plc.d scripts
155 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
156 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
157 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
158
159 # cron job for automated polling
160 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
161
162 # apache configuration
163 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
164
165 # we'll install monitor and pcucontrol in site-packages
166 # install rest to /usr/share/monitor
167 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
168     --exclude monitor/ \
169     --exclude pcucontol/ \
170     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
171
172 # install monitor python package
173 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
174
175 # and pcucontrol
176 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
177
178 # install third-party module to site-packages
179 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
180
181 # TODO: 
182 echo " * TODO: Setting up Monitor account in local MyPLC"
183
184 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
185 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
186
187 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
188 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
189
190 #################### RunlevelAgent
191 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
192 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
193
194 mkdir -p $RPM_BUILD_ROOT/var/log
195 touch $RPM_BUILD_ROOT/var/log/server-deps.log
196
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %files server-deps
202 /var/log/server-deps.log
203
204 %files server
205 %defattr(-,root,root)
206 #%config /usr/share/%{name}/monitorconfig.py
207 #%config /etc/monitor.conf
208 /usr/share/%{name}
209 /var/lib/%{name}
210 #/var/www/cgi-bin/monitor
211 %{_sysconfdir}/cron.d/monitor-server.cron
212 %{python_sitearch}/threadpool.py
213 %{python_sitearch}/threadpool.pyc
214 %{python_sitearch}/threadpool.pyo
215 %{python_sitearch}/monitor
216 %{python_sitearch}/Turbo*
217 %{python_sitearch}/SQLAlchemy*
218 %{python_sitearch}/Elixir*
219 %{python_sitearch}/easy-install.pth
220 %{python_sitearch}/tg-admin
221 %{_sysconfdir}/plc.d/monitor
222 %{_sysconfdir}/plc.d/monitor.functions
223 %{_sysconfdir}/plc.d/zabbix
224 %{_sysconfdir}/httpd/conf.d
225
226 %files client
227 %defattr(-,root,root)
228 #%{_initrddir}/monitor
229 #%{_sysconfdir}/cron.d/monitor
230 /usr/bin/timeout.pl
231
232 %files pcucontrol
233 %{python_sitearch}/pcucontrol
234
235 %files runlevelagent
236 /usr/bin/RunlevelAgent.py
237 /usr/bin/RunlevelAgent.pyo
238 /usr/bin/RunlevelAgent.pyc
239 /%{_initrddir}/monitor-runlevelagent
240
241 %post server-deps
242
243 # crazy openssl libs for racadm binary
244 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
245 mkdir %{_datadir}/%{name}/.ssh
246 chmod 700 %{_datadir}/%{name}/.ssh
247
248 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
249     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
250 fi
251
252 # NOTE: enable monitor by default, since we're installing it.
253 if ! plc-config --category plc_monitor --variable enabled ; then 
254         plc-config --category plc_monitor --variable enabled --value true \
255                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
256 fi
257 if ! plc-config --category plc_monitor --variable from_email ; then
258         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
259                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
260 fi
261 if ! plc-config --category plc_monitor --variable cc_email ; then
262         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
263                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
264 fi
265 if ! plc-config --category plc_monitor --variable rt_queue ; then
266         plc-config --category plc_monitor --variable rt_queue --value support \
267                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
268 fi
269
270 # zabbix:
271 if ! plc-config --category plc_zabbix --variable enabled ; then
272         plc-config --category plc_zabbix --variable enabled --value false \
273                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
274 fi
275 if ! plc-config --category plc_zabbix --variable host ; then
276         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
277                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
278 fi
279 if ! plc-config --category plc_zabbix --variable ip ; then
280         plc-config --category plc_zabbix --variable ip --value "" \ 
281                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
282 fi
283
284 %post server
285 # TODO: this will be nice when we have a web-based service running., such as
286 #               an API server or so on.
287 # TODO: create real monitorconfig.py from monitorconfig-default.py
288 # TODO: create symlink in /var/lib/monitor for chroot environments
289 # TODO: update the content of automate_pl03.sh 
290 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
291
292 # NOTE: generate the python defines from zabbix include files.
293 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
294
295 # apply patches to zabbix
296 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
297
298 #chkconfig --add monitor-server
299 #chkconfig monitor-server on
300
301 %post client
302 chkconfig --add monitor
303 chkconfig monitor on
304
305 %post runlevelagent
306 chkconfig --add monitor-runlevelagent
307 chkconfig monitor-runlevelagent on
308 if [ "$PL_BOOTCD" != "1" ] ; then
309         service monitor-runlevelagent restart
310 fi
311
312
313 %changelog
314 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
315 - add option for site status to include both node & pcu status
316 - improve ticket handling
317 - template gadget.xml for a site-specific google-gadget summary
318
319 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
320 - - add install_date
321
322 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
323 - - remove monitor-client.cron
324 - - remove unused monitor-client init script
325 - - fix UP/DOWN summary on nodes page.
326 - - make node page display all nodes by default
327 - - add boot_server field
328 - - add myops_ssh_key to the keychain
329 - - use ext_consortium_id to distinguish pending sites.
330
331 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
332 - show/hide advance query form.
333
334 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
335 - fixed pause_penalty bug.
336 - fixed IPAL pcucontrol bug
337 - fixed bootman tunnel setup bug (occurred in rare cases)
338 - deprecated pcuview
339 - added BootmanSequenceRecords to separate config data from source code
340 - added get/setBootmanSequence(s) to xmlrpc API
341
342 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
343 - Major Features:
344 - added bm log collection and optional integration with BootManager's log Upload()
345 - added iptables_status
346 - expanded advanced query
347 - added differentiated bootmanager_restore actions so that actionsummary displays
348 - counts for each kind of bootmanager action
349 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
350 - added plain-text options for query page by adding tg_format=plain to URL
351 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
352 - fixed a bug in determining whether comon's dir was running on a node
353
354 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
355 - Major increment -
356 - adds multiple features and web changes
357 - adds new fields to db
358 - improved layout
359 - general improvements otherwise
360
361 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
362 - bug fixes.
363 - improved templates and views
364 - cleaned controller code for web
365 - added IPMI requirement to pcucontrol package.
366
367 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
368 - added bootmanager log links
369 - addressed root cause of IntegrityErrors ; big deal
370 - adjusted templates to accomodate fix for IntegrityErrors
371 - added session.flush() to bootman.py to write out ActionsRecords
372 - fixed policy to either pause penalties or apply them ; not both.
373
374 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
375 -- Added Rpyc from 1.0 branch.
376 -- add pcuhistory
377 -- add setup-agent for password protected keys.
378 -- other minor improvements.
379
380 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
381 - automate install
382 - auto-close tickets
383
384 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
385 - update web
386 - update policy
387 - added statistics dir
388
389 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
390 - remove plccache from controllers, all lookups from db.
391 - reformat emailTxt messags
392 - updated bootstates in bootman.py
393
394 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
395 - tag of latest changes.
396 - need to test end to end.
397
398 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
399 - big merge from the 2.0 branch
400
401 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
402 - minor improvements in rendering with sortable tables
403
404 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
405
406 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
407 - first draft with sortable tables + checkpoint
408
409 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
410 - use plekit tables from plewww.
411 - depend on plewww-plekit
412
413 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
414 - make docs a noop
415 - fix for package name dependency
416 - correct docs
417
418 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
419 - add improved docs to the latest build and tag.
420
421 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
422 - add documentation hooks for adding in-line docs like NM and PLCAPI
423
424 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
425 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
426 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
427 - 'safeboot', 'failboot', 'reinstall', etc.
428
429 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
430 - same as 2.0-12 tag.
431
432 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
433 - merge from 2.0, remove more zabbix code, simplify install, etc.
434
435 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
436 - major merge from 2.0 branch.
437 - ready to be updated with 4.3 and web changes.
438
439 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
440 - preparing to make a 2.0 branch for monitor.
441
442 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
443 - new changes are significantly different, that I'm upping the number for clarity.
444
445 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
446 - These are all changes in the latest Monitor code.  I will branch this version
447 - next, before making additional large changes.
448
449 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
450 - Checkpointing current version for 4.2-rc21 - many many changes
451
452 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
453 - This is a major tag of every thing.  probably needs a very different release
454 - number.
455
456 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
457 - Incremental improvements
458
459 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
460 - tagging everything for OneLab tech-transfer.
461
462
463 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
464
465
466 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
467
468
469 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
470 - This should be ready for 4.2rc2
471
472
473 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
474 - initial addition.
475
476 %define module_current_branch 2.0