ac97879d0cff2bbbae7284b3fd1eef84d62e7f03
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 0
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53
54 Requires: nagios
55 Requires: nagios-common
56 Requires: nagios-devel
57 Requires: nagios-plugins-all
58 Requires: ndoutils
59 Requires: ndoutils-mysql
60
61
62 %description nagios
63 Scripts and setup necessary to integrate and monitor PLC with Nagios.
64 Best suited to F12 or above.
65
66 ######################################## CLIENT
67
68 %package client
69 Summary: Monitor hooks for a PLC node
70 Group: Applications/System
71 Requires: curl
72 Requires: coreutils
73
74 %description client
75 The client scripts handle account creation inside of a node.  This will
76 include configuration setup for the monitoring agent running on the node.  It
77 will also include any cron or init scripts needed to perform this kind of
78 maintenance.
79 ######################################## Server Deps
80 %package server-deps
81 Summary: Monitor hooks for the PLC server.
82 Group: Applications/System
83
84 Requires: python
85 Requires: python-setuptools-devel
86 Requires: python-peak-util-extremes
87
88 Requires: compat-libstdc++-296
89 Requires: openssh-clients
90 Requires: perl-libwww-perl
91 Requires: perl-IO-Socket-SSL 
92 Requires: MySQL-python
93 Requires: nmap
94 Requires: nc
95 Requires: rt3
96
97 Requires: plewww-plekit
98
99 #Requires: zabbix-client
100 #Requires: zabbix-gui
101 #Requires: zabbix-server
102
103 %description server-deps
104 The server side include all python modules and scripts needed to fully
105
106 ######################################## Server
107 %package server
108 Summary: Monitor hooks for the PLC server.
109 Group: Applications/System
110
111 Requires: python
112
113 Requires: monitor-server-deps
114 Requires: PLCWWW >= 4.2
115 Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
116 Requires: pcucontrol
117
118 %description server
119 The server side include all python modules and scripts needed to fully
120 operation, track, and interact with any third-party monitoring software, such
121 as Zabbix DB.
122
123 ####################################### RunlevelAgent
124 %package runlevelagent
125 summary: the RunlevelAgent that reports node runlevels
126 group: applications/system
127 requires: python
128
129 %description runlevelagent
130 The RunlevelAgent starts as early as possible during boot-up and production
131 mode to actively report the observed runlevel to PLC and update the
132 'last_contact' field.
133
134 %prep
135 %setup -q
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 #################### CLIENT 
140 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
141 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
142 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
143
144
145 #################### SERVER
146 install -d $RPM_BUILD_ROOT/usr/share/%{name}
147 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
148 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
149 install -d $RPM_BUILD_ROOT/var/lib/%{name}
150 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
151 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
152 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
153 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
154
155 # plc.d scripts
156 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
157 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
158 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
159 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
160
161 # cron job for automated polling
162 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
163
164 # apache configuration
165 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
166
167 # we'll install monitor in site-packages install rest to
168 # /usr/share/monitor
169 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
170     --exclude monitor/ \
171     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
172
173 # install monitor python package
174 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
175
176 # install third-party module to site-packages
177 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
178
179 # TODO: 
180 echo " * TODO: Setting up Monitor account in local MyPLC"
181
182 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
183 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
184
185 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
186 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
187
188 #################### RunlevelAgent
189 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
190 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
191
192 mkdir -p $RPM_BUILD_ROOT/var/log
193 touch $RPM_BUILD_ROOT/var/log/server-deps.log
194
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %files server-deps
200 /var/log/server-deps.log
201
202 %files nagios
203 %defattr(-,root,root)
204 %{_sysconfdir}/plc.d/monitor-nagios
205 /usr/share/%{name}/nagios 
206
207 %files server
208 %defattr(-,root,root)
209 #%config /usr/share/%{name}/monitorconfig.py
210 #%config /etc/monitor.conf
211 /var/lib/%{name}
212 /usr/share/%{name}/MANIFEST.in
213 /usr/share/%{name}/Makefile
214 /usr/share/%{name}/Monitor.spec
215 /usr/share/%{name}/README.txt
216 /usr/share/%{name}/RunlevelAgent.py*
217 /usr/share/%{name}/automate-default.sh
218 /usr/share/%{name}/monitor-default.conf
219 /usr/share/%{name}/monitor-runlevelagent.init
220 /usr/share/%{name}/monitor-server.cron
221 /usr/share/%{name}/monitor-server.init
222 /usr/share/%{name}/monitor.functions
223 /usr/share/%{name}/setup.py*
224 /usr/share/%{name}/threadpool.py*
225 /usr/share/%{name}/zabbix.spec
226
227 /usr/share/%{name}/bootcd
228 /usr/share/%{name}/commands
229 /usr/share/%{name}/config.d
230 /usr/share/%{name}/cron.d
231 /usr/share/%{name}/docs
232 /usr/share/%{name}/keys
233 /usr/share/%{name}/log
234 /usr/share/%{name}/statistics
235 /usr/share/%{name}/tests
236 /usr/share/%{name}/tools
237 /usr/share/%{name}/upgrade
238 /usr/share/%{name}/web
239 /usr/share/%{name}/zabbix
240
241 #/var/www/cgi-bin/monitor
242 %{_sysconfdir}/cron.d/monitor-server.cron
243 %{_sysconfdir}/plc.d/monitor
244 %{_sysconfdir}/plc.d/monitor.functions
245 %{_sysconfdir}/plc.d/zabbix
246 %{_sysconfdir}/httpd/conf.d
247 %{python_sitearch}
248
249
250 %files client
251 %defattr(-,root,root)
252 #%{_initrddir}/monitor
253 #%{_sysconfdir}/cron.d/monitor
254 /usr/bin/timeout.pl
255
256 %files runlevelagent
257 /usr/bin/RunlevelAgent.py*
258 /%{_initrddir}/monitor-runlevelagent
259
260
261 %post server-deps
262 #
263 # TODO: depend on distribution packages where feasible.
264 #
265 #  it would be better to be able to depend on the distribution's
266 # packages for these additional python modules, but packages provided
267 # by fedora 8 (our current deployment) doesn't match the version
268 # requirements.
269 export TMPDIR=/var/tmp/
270 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
271 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
272 easy_install -UZ Elixir
273
274 # crazy openssl libs for racadm binary
275 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
276 mkdir %{_datadir}/%{name}/.ssh
277 chmod 700 %{_datadir}/%{name}/.ssh
278
279 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
280     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
281 fi
282
283 # NOTE: enable monitor by default, since we're installing it.
284 if ! plc-config --category plc_monitor --variable enabled ; then 
285         plc-config --category plc_monitor --variable enabled --value true \
286                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
287 fi
288 if ! plc-config --category plc_monitor --variable from_email ; then
289         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
290                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
291 fi
292 if ! plc-config --category plc_monitor --variable cc_email ; then
293         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
294                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
295 fi
296 if ! plc-config --category plc_monitor --variable rt_queue ; then
297         plc-config --category plc_monitor --variable rt_queue --value support \
298                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
299 fi
300
301 # zabbix:
302 if ! plc-config --category plc_zabbix --variable enabled ; then
303         plc-config --category plc_zabbix --variable enabled --value false \
304                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
305 fi
306 if ! plc-config --category plc_zabbix --variable host ; then
307         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
308                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
309 fi
310 if ! plc-config --category plc_zabbix --variable ip ; then
311         plc-config --category plc_zabbix --variable ip --value "" \ 
312                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
313 fi
314
315 %post nagios
316 # TODO: do as much as possible to get the host setup and running.
317 chkconfig --add monitor-nagios
318 chkconfig monitor-nagios on
319 chkconfig mysqld on
320
321 %post server
322 # TODO: this will be nice when we have a web-based service running., such as
323 #               an API server or so on.
324 # TODO: create real monitorconfig.py from monitorconfig-default.py
325 # TODO: create symlink in /var/lib/monitor for chroot environments
326 # TODO: update the content of automate_pl03.sh 
327 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
328
329 # NOTE: generate the python defines from zabbix include files.
330 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
331
332 # apply patches to zabbix
333 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
334
335 #chkconfig --add monitor-server
336 #chkconfig monitor-server on
337
338 %post client
339 chkconfig --add monitor
340 chkconfig monitor on
341
342 %post runlevelagent
343 chkconfig --add monitor-runlevelagent
344 chkconfig monitor-runlevelagent on
345 if [ "$PL_BOOTCD" != "1" ] ; then
346         service monitor-runlevelagent restart
347 fi
348
349
350 %changelog
351 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
352 - Add CSV link on Advanced query
353 - Preparing to branch
354
355 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
356 - * copy selections to clipbord on Advanced Query page
357 - * RPM Pattern as regexp
358 - * scan ipmi port
359
360 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
361 - handle hostname changes
362
363 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
364 - from this version, suitable for 5.0
365 - requires bootcd with the new 5.0 naming style 3-part nodefamily
366
367 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
368 - added fix for node delete/add causing conflicts in MyOps db.
369 - added statistics scripts
370
371 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
372 - * fix paths for automate script
373
374 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
375 - - separate pcucontrol as an svn module
376 - - restore easy_instal back into post install stage of server-deps
377 - - template imporovements for web interface
378
379 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
380 - do not need buildrequires. a new tag to fix centos builds
381
382 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
383 - fix rpm build issues
384
385 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
386 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
387
388 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
389 - add option for site status to include both node & pcu status
390 - improve ticket handling
391 - template gadget.xml for a site-specific google-gadget summary
392
393 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
394 - - add install_date
395
396 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
397 - - remove monitor-client.cron
398 - - remove unused monitor-client init script
399 - - fix UP/DOWN summary on nodes page.
400 - - make node page display all nodes by default
401 - - add boot_server field
402 - - add myops_ssh_key to the keychain
403 - - use ext_consortium_id to distinguish pending sites.
404
405 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
406 - show/hide advance query form.
407
408 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
409 - fixed pause_penalty bug.
410 - fixed IPAL pcucontrol bug
411 - fixed bootman tunnel setup bug (occurred in rare cases)
412 - deprecated pcuview
413 - added BootmanSequenceRecords to separate config data from source code
414 - added get/setBootmanSequence(s) to xmlrpc API
415
416 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
417 - Major Features:
418 - added bm log collection and optional integration with BootManager's log Upload()
419 - added iptables_status
420 - expanded advanced query
421 - added differentiated bootmanager_restore actions so that actionsummary displays
422 - counts for each kind of bootmanager action
423 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
424 - added plain-text options for query page by adding tg_format=plain to URL
425 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
426 - fixed a bug in determining whether comon's dir was running on a node
427
428 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
429 - Major increment -
430 - adds multiple features and web changes
431 - adds new fields to db
432 - improved layout
433 - general improvements otherwise
434
435 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
436 - bug fixes.
437 - improved templates and views
438 - cleaned controller code for web
439 - added IPMI requirement to pcucontrol package.
440
441 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
442 - added bootmanager log links
443 - addressed root cause of IntegrityErrors ; big deal
444 - adjusted templates to accomodate fix for IntegrityErrors
445 - added session.flush() to bootman.py to write out ActionsRecords
446 - fixed policy to either pause penalties or apply them ; not both.
447
448 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
449 -- Added Rpyc from 1.0 branch.
450 -- add pcuhistory
451 -- add setup-agent for password protected keys.
452 -- other minor improvements.
453
454 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
455 - automate install
456 - auto-close tickets
457
458 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
459 - update web
460 - update policy
461 - added statistics dir
462
463 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
464 - remove plccache from controllers, all lookups from db.
465 - reformat emailTxt messags
466 - updated bootstates in bootman.py
467
468 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
469 - tag of latest changes.
470 - need to test end to end.
471
472 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
473 - big merge from the 2.0 branch
474
475 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
476 - minor improvements in rendering with sortable tables
477
478 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
479
480 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
481 - first draft with sortable tables + checkpoint
482
483 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
484 - use plekit tables from plewww.
485 - depend on plewww-plekit
486
487 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
488 - make docs a noop
489 - fix for package name dependency
490 - correct docs
491
492 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
493 - add improved docs to the latest build and tag.
494
495 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
496 - add documentation hooks for adding in-line docs like NM and PLCAPI
497
498 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
499 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
500 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
501 - 'safeboot', 'failboot', 'reinstall', etc.
502
503 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
504 - same as 2.0-12 tag.
505
506 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
507 - merge from 2.0, remove more zabbix code, simplify install, etc.
508
509 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
510 - major merge from 2.0 branch.
511 - ready to be updated with 4.3 and web changes.
512
513 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
514 - preparing to make a 2.0 branch for monitor.
515
516 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
517 - new changes are significantly different, that I'm upping the number for clarity.
518
519 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
520 - These are all changes in the latest Monitor code.  I will branch this version
521 - next, before making additional large changes.
522
523 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
524 - Checkpointing current version for 4.2-rc21 - many many changes
525
526 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
527 - This is a major tag of every thing.  probably needs a very different release
528 - number.
529
530 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
531 - Incremental improvements
532
533 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
534 - tagging everything for OneLab tech-transfer.
535
536
537 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
538
539
540 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
541
542
543 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
544 - This should be ready for 4.2rc2
545
546
547 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
548 - initial addition.
549
550 %define module_current_branch 3.0