merge recent v2 changes; migrating to v3
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 2.0
9 %define taglevel 12
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56
57 Requires: openssh-clients
58 Requires: perl-libwww-perl
59 Requires: perl-IO-Socket-SSL 
60 Requires: MySQL-python
61 Requires: nmap
62 Requires: rt3
63
64 #Requires: python-sqlalchemy
65 #Requires: python-elixir
66 #Requires: zabbix-client
67 #Requires: zabbix-gui
68 #Requires: zabbix-server
69
70 %description server-deps
71 The server side include all python modules and scripts needed to fully
72
73 ######################################## Server
74 %package server
75 Summary: Monitor hooks for the PLC server.
76 Group: Applications/System
77
78 Requires: python
79
80 Requires: monitor-server-deps
81 Requires: monitor-pcucontrol
82 Requires: PLCWWW >= 4.2
83 Requires: bootcd-planetlab-i386 >= 4.2
84
85 %description server
86 The server side include all python modules and scripts needed to fully
87 operation, track, and interact with any third-party monitoring software, such
88 as Zabbix DB.
89
90 ######################################## PCU Control
91
92 %package pcucontrol
93 summary: pcu controls for monitor and plcapi
94 group: applications/system
95 Requires: python
96 Requires: OpenIPMI-tools
97 Requires: openssh-clients
98 Requires: perl-libwww-perl
99 Requires: perl-IO-Socket-SSL 
100 Requires: curl
101
102 %description pcucontrol
103 both monitor and the plcapi use a set of common commands to reboot machines
104 using their external or internal pcus.  this package is a library of several
105 supported models.
106
107 ####################################### RunlevelAgent
108 %package runlevelagent
109 summary: the RunlevelAgent that reports node runlevels
110 group: applications/system
111 requires: python
112
113 %description runlevelagent
114 The RunlevelAgent starts as early as possible during boot-up and production
115 mode to actively report the observed runlevel to PLC and update the
116 'last_contact' field.
117
118 %prep
119 %setup -q
120
121 %build
122 # NOTE: the build uses g++ cmdamt/
123 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
124 cd pcucontrol/models/intelamt
125 export TMPDIR=$PWD/tmp
126 make
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 #################### CLIENT 
132 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
133 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134
135 #################### SERVER
136 install -d $RPM_BUILD_ROOT/usr/share/%{name}
137 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
138 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
139 install -d $RPM_BUILD_ROOT/var/lib/%{name}
140 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
141 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
142
143 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
144
145 echo " * Installing core scripts"
146 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
147           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
148
149 echo " * Installing web pages"
150 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
151
152 echo " * Installing cron job for automated polling"
153 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
154 echo " * TODO: Setting up Monitor account in local MyPLC"
155 # TODO: 
156
157 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
158 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
159 # TODO: need a much better way to do this.
160 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
161 #for file in __init__.py database.py config.py ; do 
162 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
163 #done
164 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
165 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
166
167 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
168 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
169
170 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
171 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
172
173 #################### RunlevelAgent
174 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
175 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
176
177 mkdir -p $RPM_BUILD_ROOT/var/log
178 touch $RPM_BUILD_ROOT/var/log/server-deps.log
179
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files server-deps
185 /var/log/server-deps.log
186
187 %files server
188 %defattr(-,root,root)
189 #%config /usr/share/%{name}/monitorconfig.py
190 #%config /etc/monitor.conf
191 /usr/share/%{name}
192 /var/lib/%{name}
193 /var/www/cgi-bin/monitor
194 %{_sysconfdir}/cron.d/monitor-server.cron
195 %{python_sitearch}/threadpool.py
196 %{python_sitearch}/threadpool.pyc
197 %{python_sitearch}/threadpool.pyo
198 %{python_sitearch}/monitor
199 %{_sysconfdir}/plc.d/monitor
200
201 %files client
202 %defattr(-,root,root)
203 %{_initrddir}/monitor
204 %{_sysconfdir}/cron.d/monitor
205
206 %files pcucontrol
207 %{python_sitearch}/pcucontrol
208
209 %files runlevelagent
210 /usr/bin/RunlevelAgent.py
211 /usr/bin/RunlevelAgent.pyo
212 /usr/bin/RunlevelAgent.pyc
213 /%{_initrddir}/monitor-runlevelagent
214
215 %post server-deps
216 easy_install -UZ Elixir
217 easy_install -UZ ElementTree
218 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
219 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
220
221 # NOTE: add the default xml stuff if it's not already in the default xml config.
222 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
223     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
224 fi
225
226
227 %post server
228 # TODO: this will be nice when we have a web-based service running., such as
229 #               an API server or so on.
230 # TODO: create real monitorconfig.py from monitorconfig-default.py
231 # TODO: create monitorconfig.php using phpconfig.py 
232 # TODO: create symlink in /var/lib/monitor for chroot environments
233 # TODO: update the content of automate_pl03.sh 
234 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
235
236 # NOTE: generate the python defines from zabbix include files.
237 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
238
239 # apply patches to zabbix
240 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
241
242 #chkconfig --add monitor-server
243 #chkconfig monitor-server on
244
245 %post client
246 chkconfig --add monitor
247 chkconfig monitor on
248
249 %post runlevelagent
250 chkconfig --add monitor-runlevelagent
251 chkconfig monitor-runlevelagent on
252
253 %changelog
254 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-12
255 - improve installation
256 - improve nodequery defaults
257 - add RT configuration check in mailer.py
258
259 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-11
260 - remove zabbix
261 - improve install support
262 - allow web to use monitor module in more cases.
263
264 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-10
265 - sync
266 - cache
267 - better policy
268
269 * Fri Apr 03 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-9
270 - added new models to db.
271 - major updates throughout.
272 - better unification. needs an install test.
273
274 * Wed Apr 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-8
275 - removed old pkl database references.
276 - added blacklist to db model
277 - added fix to IntelAMT remoteControl to start an power-down node
278 - added policy.py
279 - added global error count before bailing entirely.
280
281 * Fri Mar 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-7
282 - improved db model
283 - updated files that use db model
284 - updated web view based on node, site, and pcu states.
285 - added local mirror to zabbix Make file.
286
287 * Tue Mar 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-6
288 - added action view to gui
289 - added penalty_applied bit to db model.
290
291 * Fri Mar 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-5
292 - tag for updates to 2.0 db model
293
294 * Fri Mar 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-4
295 - splits reboot.py across pcucontrol and monitor modules
296 - moves command.py from monitor/util to pcucontrol/util
297
298 * Tue Mar 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-3
299 - add email exceptions
300 - other bug fixes.
301
302 * Tue Mar 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-2
303 - getting the pcucontrol and findall.py scripts to work in an integrated
304 - fashion.
305
306 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
307 - preparing to make a 2.0 branch for monitor.
308
309 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
310 - new changes are significantly different, that I'm upping the number for clarity.
311
312 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
313 - These are all changes in the latest Monitor code.  I will branch this version
314 - next, before making additional large changes.
315
316 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
317 - Checkpointing current version for 4.2-rc21 - many many changes
318
319 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
320 - This is a major tag of every thing.  probably needs a very different release
321 - number.
322
323 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
324 - Incremental improvements
325
326 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
327 - tagging everything for OneLab tech-transfer.
328
329
330 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
331
332
333 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
334
335
336 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
337 - This should be ready for 4.2rc2
338
339
340 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
341 - initial addition.
342
343 %define module_current_branch 1.0