"easy_install" dependencies while building packages to make monitor package self...
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 25
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57
58 Requires: compat-libstdc++-296
59 Requires: openssh-clients
60 Requires: perl-libwww-perl
61 Requires: perl-IO-Socket-SSL 
62 Requires: MySQL-python
63 Requires: nmap
64 Requires: nc
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## PCU Control
94
95 %package pcucontrol
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
98 requires: python
99 requires: OpenIPMI-tools
100
101 %description pcucontrol
102 both monitor and the plcapi use a set of common commands to reboot machines
103 using their external or internal pcus.  this package is a library of several
104 supported models.
105
106 ####################################### RunlevelAgent
107 %package runlevelagent
108 summary: the RunlevelAgent that reports node runlevels
109 group: applications/system
110 requires: python
111
112 %description runlevelagent
113 The RunlevelAgent starts as early as possible during boot-up and production
114 mode to actively report the observed runlevel to PLC and update the
115 'last_contact' field.
116
117 %prep
118 %setup -q
119
120 %build
121 # NOTE: the build uses g++ cmdamt/
122 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
123 cd pcucontrol/models/intelamt
124 export TMPDIR=$PWD/tmp
125 make
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 #################### CLIENT 
131 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
132 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
133 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
134
135
136 #################### SERVER
137 install -d $RPM_BUILD_ROOT/usr/share/%{name}
138 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
140 install -d $RPM_BUILD_ROOT/var/lib/%{name}
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
142 #install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
143 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
144 install -d $RPM_BUILD_ROOT/%{python_sitearch}/
145
146 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
147 # pack monitor's dependencies in RPM to make it easier to deploy.
148 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
149 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
150 easy_install --build-directory /var/tmp -UZ Elixir
151 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
152
153 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
154 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
155 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
156
157 echo " * Installing core scripts"
158 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
159           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
160
161 echo " * Installing web pages"
162 #rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
163 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
164
165 echo " * Installing cron job for automated polling"
166 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
167 echo " * TODO: Setting up Monitor account in local MyPLC"
168 # TODO: 
169
170 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
171 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
172 # TODO: need a much better way to do this.
173 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
174 #for file in __init__.py database.py config.py ; do 
175 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
176 #done
177 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
178 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
179
180 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
181 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
182
183 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
184 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
185
186 #################### RunlevelAgent
187 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
188 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
189
190 mkdir -p $RPM_BUILD_ROOT/var/log
191 touch $RPM_BUILD_ROOT/var/log/server-deps.log
192
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files server-deps
198 /var/log/server-deps.log
199
200 %files server
201 %defattr(-,root,root)
202 #%config /usr/share/%{name}/monitorconfig.py
203 #%config /etc/monitor.conf
204 /usr/share/%{name}
205 /var/lib/%{name}
206 #/var/www/cgi-bin/monitor
207 %{_sysconfdir}/cron.d/monitor-server.cron
208 %{python_sitearch}/threadpool.py
209 %{python_sitearch}/threadpool.pyc
210 %{python_sitearch}/threadpool.pyo
211 %{python_sitearch}/monitor
212 %{python_sitearch}/Turbo*
213 %{python_sitearch}/SQLAlchemy*
214 %{python_sitearch}/Elixir*
215 %{python_sitearch}/easy-install.pth
216 %{python_sitearch}/tg-admin
217 %{_sysconfdir}/plc.d/monitor
218 %{_sysconfdir}/plc.d/monitor.functions
219 %{_sysconfdir}/plc.d/zabbix
220
221 %files client
222 %defattr(-,root,root)
223 #%{_initrddir}/monitor
224 #%{_sysconfdir}/cron.d/monitor
225 /usr/bin/timeout.pl
226
227 %files pcucontrol
228 %{python_sitearch}/pcucontrol
229
230 %files runlevelagent
231 /usr/bin/RunlevelAgent.py
232 /usr/bin/RunlevelAgent.pyo
233 /usr/bin/RunlevelAgent.pyc
234 /%{_initrddir}/monitor-runlevelagent
235
236 %post server-deps
237
238 # crazy openssl libs for racadm binary
239 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
240 mkdir %{_datadir}/%{name}/.ssh
241 chmod 700 %{_datadir}/%{name}/.ssh
242
243 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
244     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
245 fi
246
247 # NOTE: enable monitor by default, since we're installing it.
248 if ! plc-config --category plc_monitor --variable enabled ; then 
249         plc-config --category plc_monitor --variable enabled --value true \
250                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
251 fi
252 if ! plc-config --category plc_monitor --variable from_email ; then
253         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
254                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
255 fi
256 if ! plc-config --category plc_monitor --variable cc_email ; then
257         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
258                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
259 fi
260 if ! plc-config --category plc_monitor --variable rt_queue ; then
261         plc-config --category plc_monitor --variable rt_queue --value support \
262                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
263 fi
264
265 # zabbix:
266 if ! plc-config --category plc_zabbix --variable enabled ; then
267         plc-config --category plc_zabbix --variable enabled --value false \
268                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
269 fi
270 if ! plc-config --category plc_zabbix --variable host ; then
271         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
272                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
273 fi
274 if ! plc-config --category plc_zabbix --variable ip ; then
275         plc-config --category plc_zabbix --variable ip --value "" \ 
276                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
277 fi
278
279 %post server
280 # TODO: this will be nice when we have a web-based service running., such as
281 #               an API server or so on.
282 # TODO: create real monitorconfig.py from monitorconfig-default.py
283 # TODO: create symlink in /var/lib/monitor for chroot environments
284 # TODO: update the content of automate_pl03.sh 
285 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
286
287 # NOTE: generate the python defines from zabbix include files.
288 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
289
290 # apply patches to zabbix
291 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
292
293 #chkconfig --add monitor-server
294 #chkconfig monitor-server on
295
296 %post client
297 chkconfig --add monitor
298 chkconfig monitor on
299
300 %post runlevelagent
301 chkconfig --add monitor-runlevelagent
302 chkconfig monitor-runlevelagent on
303 if [ "$PL_BOOTCD" != "1" ] ; then
304         service monitor-runlevelagent restart
305 fi
306
307
308 %changelog
309 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
310 - add option for site status to include both node & pcu status
311 - improve ticket handling
312 - template gadget.xml for a site-specific google-gadget summary
313
314 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
315 - - add install_date
316
317 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
318 - - remove monitor-client.cron
319 - - remove unused monitor-client init script
320 - - fix UP/DOWN summary on nodes page.
321 - - make node page display all nodes by default
322 - - add boot_server field
323 - - add myops_ssh_key to the keychain
324 - - use ext_consortium_id to distinguish pending sites.
325
326 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
327 - show/hide advance query form.
328
329 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
330 - fixed pause_penalty bug.
331 - fixed IPAL pcucontrol bug
332 - fixed bootman tunnel setup bug (occurred in rare cases)
333 - deprecated pcuview
334 - added BootmanSequenceRecords to separate config data from source code
335 - added get/setBootmanSequence(s) to xmlrpc API
336
337 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
338 - Major Features:
339 - added bm log collection and optional integration with BootManager's log Upload()
340 - added iptables_status
341 - expanded advanced query
342 - added differentiated bootmanager_restore actions so that actionsummary displays
343 - counts for each kind of bootmanager action
344 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
345 - added plain-text options for query page by adding tg_format=plain to URL
346 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
347 - fixed a bug in determining whether comon's dir was running on a node
348
349 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
350 - Major increment -
351 - adds multiple features and web changes
352 - adds new fields to db
353 - improved layout
354 - general improvements otherwise
355
356 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
357 - bug fixes.
358 - improved templates and views
359 - cleaned controller code for web
360 - added IPMI requirement to pcucontrol package.
361
362 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
363 - added bootmanager log links
364 - addressed root cause of IntegrityErrors ; big deal
365 - adjusted templates to accomodate fix for IntegrityErrors
366 - added session.flush() to bootman.py to write out ActionsRecords
367 - fixed policy to either pause penalties or apply them ; not both.
368
369 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
370 -- Added Rpyc from 1.0 branch.
371 -- add pcuhistory
372 -- add setup-agent for password protected keys.
373 -- other minor improvements.
374
375 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
376 - automate install
377 - auto-close tickets
378
379 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
380 - update web
381 - update policy
382 - added statistics dir
383
384 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
385 - remove plccache from controllers, all lookups from db.
386 - reformat emailTxt messags
387 - updated bootstates in bootman.py
388
389 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
390 - tag of latest changes.
391 - need to test end to end.
392
393 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
394 - big merge from the 2.0 branch
395
396 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
397 - minor improvements in rendering with sortable tables
398
399 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
400
401 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
402 - first draft with sortable tables + checkpoint
403
404 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
405 - use plekit tables from plewww.
406 - depend on plewww-plekit
407
408 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
409 - make docs a noop
410 - fix for package name dependency
411 - correct docs
412
413 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
414 - add improved docs to the latest build and tag.
415
416 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
417 - add documentation hooks for adding in-line docs like NM and PLCAPI
418
419 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
420 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
421 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
422 - 'safeboot', 'failboot', 'reinstall', etc.
423
424 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
425 - same as 2.0-12 tag.
426
427 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
428 - merge from 2.0, remove more zabbix code, simplify install, etc.
429
430 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
431 - major merge from 2.0 branch.
432 - ready to be updated with 4.3 and web changes.
433
434 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
435 - preparing to make a 2.0 branch for monitor.
436
437 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
438 - new changes are significantly different, that I'm upping the number for clarity.
439
440 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
441 - These are all changes in the latest Monitor code.  I will branch this version
442 - next, before making additional large changes.
443
444 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
445 - Checkpointing current version for 4.2-rc21 - many many changes
446
447 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
448 - This is a major tag of every thing.  probably needs a very different release
449 - number.
450
451 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
452 - Incremental improvements
453
454 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
455 - tagging everything for OneLab tech-transfer.
456
457
458 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
459
460
461 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
462
463
464 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
465 - This should be ready for 4.2rc2
466
467
468 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
469 - initial addition.
470
471 %define module_current_branch 2.0