start zabbix_agent after installing it... assumes it's in a prod env.
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 2.0
9 %define taglevel 0
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49
50 ######################################## Server
51 %package server
52 Summary: Monitor hooks for the PLC server.
53 Group: Applications/System
54
55 Requires: python
56 Requires: python-sqlalchemy
57 Requires: python-elixir
58
59 Requires: openssh-clients
60 Requires: perl-libwww-perl
61 Requires: perl-IO-Socket-SSL 
62 Requires: MySQL-python
63 Requires: rt3 == 3.4.1
64 Requires: nmap
65 Requires: PLCWWW >= 4.2
66 Requires: bootcd-planetlab-i386 >= 4.2
67
68 Requires: zabbix-client
69 Requires: zabbix-gui
70 Requires: zabbix-server
71
72 %description server
73 The server side include all python modules and scripts needed to fully
74 operation, track, and interact with any third-party monitoring software, such
75 as Zabbix DB.
76
77 ######################################## PCU Control
78
79 %package pcucontrol
80 Summary: PCU Controls for Monitor and PLCAPI
81 Group: Applications/System
82 Requires: python
83
84 %description pcucontrol
85 Both Monitor and the PLCAPI use a set of common commands to reboot machines
86 using their external or internal PCUs.  This package is a library of several
87 supported models.
88
89 %prep
90 %setup -q
91
92 %build
93 # NOTE: the build uses g++ cmdamt/
94 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
95 cd pcucontrol/models/intelamt
96 export TMPDIR=$PWD/tmp
97 make
98 cd ..
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 #################### CLIENT 
103 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
104 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
105
106 #################### SERVER
107 install -d $RPM_BUILD_ROOT/usr/share/%{name}
108 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
109 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
110 install -d $RPM_BUILD_ROOT/var/lib/%{name}
111 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
112 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
113
114 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
115
116 echo " * Installing core scripts"
117 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
118           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
119
120 echo " * Installing web pages"
121 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
122
123 echo " * Installing cron job for automated polling"
124 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
125 echo " * TODO: Setting up Monitor account in local MyPLC"
126 # TODO: 
127
128 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
129 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
130 # TODO: need a much better way to do this.
131 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
132 #for file in __init__.py database.py config.py ; do 
133 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
134 #done
135 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
136 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
137
138 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
139 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
140
141 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
142 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147
148 %files server
149 %defattr(-,root,root)
150 #%config /usr/share/%{name}/monitorconfig.py
151 #%config /etc/monitor.conf
152 /usr/share/%{name}
153 /var/lib/%{name}
154 /var/www/cgi-bin/monitor
155 %{_sysconfdir}/cron.d/monitor-server.cron
156 %{python_sitearch}/threadpool.py
157 %{python_sitearch}/threadpool.pyc
158 %{python_sitearch}/threadpool.pyo
159 %{python_sitearch}/monitor
160 %{_sysconfdir}/plc.d/monitor
161
162 %files client
163 %defattr(-,root,root)
164 %{_initrddir}/monitor
165 %{_sysconfdir}/cron.d/monitor
166
167 %files pcucontrol
168 %{python_sitearch}/pcucontrol
169
170 %post server
171 # TODO: this will be nice when we have a web-based service running., such as
172 #               an API server or so on.
173 # TODO: create real monitorconfig.py from monitorconfig-default.py
174 # TODO: create monitorconfig.php using phpconfig.py 
175 # TODO: create symlink in /var/lib/monitor for chroot environments
176 # TODO: update the content of automate_pl03.sh 
177 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
178
179 # NOTE: generate the python defines from zabbix include files.
180 php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
181
182 # apply patches to zabbix
183 patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
184
185 #chkconfig --add monitor-server
186 #chkconfig monitor-server on
187
188 %post client
189 chkconfig --add monitor
190 chkconfig monitor on
191
192 %changelog
193 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
194 - new changes are significantly different, that I'm upping the number for clarity.
195
196 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
197 - These are all changes in the latest Monitor code.  I will branch this version
198 - next, before making additional large changes.
199
200 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
201 - Checkpointing current version for 4.2-rc21 - many many changes
202
203 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
204 - This is a major tag of every thing.  probably needs a very different release
205 - number.
206
207 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
208 - Incremental improvements
209
210 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
211 - tagging everything for OneLab tech-transfer.
212
213
214 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
215
216
217 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
218
219
220 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
221 - This should be ready for 4.2rc2
222
223
224 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
225 - initial addition.
226
227 %define module_current_branch 1.0