require OpenIPMI-tools to provide ipmitool command.
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 17
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## RT setup
94
95 %package rt
96 summary: Dependencies and default configuration for RT3
97 group: applications/system
98 Requires: monitor-server
99 Requires: rt3
100 Requires: rt3-mailgate
101
102 %description rt
103 RT3 is a ticket tracking system.  This RPM integrates RT into the MyOps
104 framework, and MyPLC in general.
105
106 ######################################## PCU Control
107
108 %package pcucontrol
109 summary: pcu controls for monitor and plcapi
110 group: applications/system
111 requires: python
112 requires: OpenIPMI-tools
113
114 %description pcucontrol
115 both monitor and the plcapi use a set of common commands to reboot machines
116 using their external or internal pcus.  this package is a library of several
117 supported models.
118
119 ####################################### RunlevelAgent
120 %package runlevelagent
121 summary: the RunlevelAgent that reports node runlevels
122 group: applications/system
123 requires: python
124
125 %description runlevelagent
126 The RunlevelAgent starts as early as possible during boot-up and production
127 mode to actively report the observed runlevel to PLC and update the
128 'last_contact' field.
129
130 %prep
131 %setup -q
132
133 %build
134 # NOTE: the build uses g++ cmdamt/
135 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
136 cd pcucontrol/models/intelamt
137 export TMPDIR=$PWD/tmp
138 make
139 cd ..
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 #################### CLIENT 
144 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
145 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
146
147 #################### SERVER
148 install -d $RPM_BUILD_ROOT/usr/share/%{name}
149 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
150 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
151 install -d $RPM_BUILD_ROOT/var/lib/%{name}
152 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
153 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
154 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
155
156 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
157 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
158 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
159 install -D -m 755 rt3/monitor-rt3.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/rt3
160
161 echo " * Installing core scripts"
162 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
163           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
164
165 echo " * Installing web pages"
166 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
167 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
168
169 echo " * Installing cron job for automated polling"
170 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
171 echo " * TODO: Setting up Monitor account in local MyPLC"
172 # TODO: 
173
174 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
175 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
176 # TODO: need a much better way to do this.
177 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
178 #for file in __init__.py database.py config.py ; do 
179 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
180 #done
181 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
182 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
183
184 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
185 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
186
187 install -D -m 644 rt3/rt.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/rt.cron
188 chmod 755 $RPM_BUILD_ROOT/usr/share/%{name}/rt3/adduserstort.pl
189 chmod 755 $RPM_BUILD_ROOT/usr/share/%{name}/rt3/rtcron.d/*.sh
190 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
191 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
192
193 #################### RunlevelAgent
194 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
195 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
196
197 mkdir -p $RPM_BUILD_ROOT/var/log
198 touch $RPM_BUILD_ROOT/var/log/server-deps.log
199
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %files server-deps
205 /var/log/server-deps.log
206
207 %files server
208 %defattr(-,root,root)
209 #%config /usr/share/%{name}/monitorconfig.py
210 #%config /etc/monitor.conf
211 /usr/share/%{name}
212 /var/lib/%{name}
213 /var/www/cgi-bin/monitor
214 %{_sysconfdir}/cron.d/monitor-server.cron
215 %{python_sitearch}/threadpool.py
216 %{python_sitearch}/threadpool.pyc
217 %{python_sitearch}/threadpool.pyo
218 %{python_sitearch}/monitor
219 %{_sysconfdir}/plc.d/monitor
220 %{_sysconfdir}/plc.d/monitor.functions
221 %{_sysconfdir}/plc.d/zabbix
222
223 %files client
224 %defattr(-,root,root)
225 %{_initrddir}/monitor
226 %{_sysconfdir}/cron.d/monitor
227
228 %files rt 
229 %defattr(-,root,root)
230 /usr/share/%{name}/rt3
231 %{_sysconfdir}/plc.d/rt3
232 %{_sysconfdir}/cron.d/rt.cron
233
234 %files pcucontrol
235 %{python_sitearch}/pcucontrol
236
237 %files runlevelagent
238 /usr/bin/RunlevelAgent.py
239 /usr/bin/RunlevelAgent.pyo
240 /usr/bin/RunlevelAgent.pyc
241 /%{_initrddir}/monitor-runlevelagent
242
243 %post server-deps
244 #easy_install --build-directory /var/tmp -UZ ElementTree
245 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
246
247
248 ## TODO: something is bad wrong with this approach.
249 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
250 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
251 easy_install --build-directory /var/tmp -UZ Elixir
252
253 # crazy openssl libs for racadm binary
254 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
255 mkdir /usr/share/monitor/.ssh
256 chmod 700 /usr/share/monitor/.ssh
257
258 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
259     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
260 fi
261 # NOTE: add the default xml stuff if it's not already in the default xml config.
262 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
263     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
264 fi
265 if ! grep '<category id="plc_rt">' /etc/planetlab/default_config.xml ; then 
266     sed -i 's|<category id="plc_net">| <category id="plc_rt">\n <name>RT Configuration</name>\n <description>RT</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the RT server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
267 fi
268 if ! grep '<category id="plc_zabbix">' /etc/planetlab/default_config.xml ; then 
269     sed -i 's|<category id="plc_net">| <category id="plc_zabbix">\n <name>Zabbix Configuration</name>\n <description>Zabbix</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the Zabbix server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
270 fi
271
272 # NOTE: enable monitor by default, since we're installing it.
273 plc-config --save /etc/planetlab/default_config.xml \
274                         --category plc_monitor --variable enabled --value true
275
276 %post rt
277 plc-config --save /etc/planetlab/default_config.xml \
278                         --category plc_rt --variable enabled --value true
279
280 %post server
281 # TODO: this will be nice when we have a web-based service running., such as
282 #               an API server or so on.
283 # TODO: create real monitorconfig.py from monitorconfig-default.py
284 # TODO: create monitorconfig.php using phpconfig.py 
285 # TODO: create symlink in /var/lib/monitor for chroot environments
286 # TODO: update the content of automate_pl03.sh 
287 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
288
289 # NOTE: generate the python defines from zabbix include files.
290 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
291
292 # apply patches to zabbix
293 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
294
295 #chkconfig --add monitor-server
296 #chkconfig monitor-server on
297
298 %post client
299 chkconfig --add monitor
300 chkconfig monitor on
301
302 %post runlevelagent
303 chkconfig --add monitor-runlevelagent
304 chkconfig monitor-runlevelagent on
305 if [ "$PL_BOOTCD" != "1" ] ; then
306         service monitor-runlevelagent restart
307 fi
308
309
310 %changelog
311 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
312 - added bootmanager log links
313 - addressed root cause of IntegrityErrors ; big deal
314 - adjusted templates to accomodate fix for IntegrityErrors
315 - added session.flush() to bootman.py to write out ActionsRecords
316 - fixed policy to either pause penalties or apply them ; not both.
317
318 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
319 -- Added Rpyc from 1.0 branch.
320 -- add pcuhistory
321 -- add setup-agent for password protected keys.
322 -- other minor improvements.
323
324 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
325 - automate install
326 - auto-close tickets
327
328 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
329 - update web
330 - update policy
331 - added statistics dir
332
333 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
334 - remove plccache from controllers, all lookups from db.
335 - reformat emailTxt messags
336 - updated bootstates in bootman.py
337
338 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
339 - tag of latest changes.
340 - need to test end to end.
341
342 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
343 - big merge from the 2.0 branch
344
345 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
346 - minor improvements in rendering with sortable tables
347
348 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
349
350 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
351 - first draft with sortable tables + checkpoint
352
353 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
354 - use plekit tables from plewww.
355 - depend on plewww-plekit
356
357 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
358 - make docs a noop
359 - fix for package name dependency
360 - correct docs
361
362 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
363 - add improved docs to the latest build and tag.
364
365 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
366 - add documentation hooks for adding in-line docs like NM and PLCAPI
367
368 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
369 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
370 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
371 - 'safeboot', 'failboot', 'reinstall', etc.
372
373 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
374 - same as 2.0-12 tag.
375
376 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
377 - merge from 2.0, remove more zabbix code, simplify install, etc.
378
379 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
380 - major merge from 2.0 branch.
381 - ready to be updated with 4.3 and web changes.
382
383 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
384 - preparing to make a 2.0 branch for monitor.
385
386 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
387 - new changes are significantly different, that I'm upping the number for clarity.
388
389 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
390 - These are all changes in the latest Monitor code.  I will branch this version
391 - next, before making additional large changes.
392
393 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
394 - Checkpointing current version for 4.2-rc21 - many many changes
395
396 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
397 - This is a major tag of every thing.  probably needs a very different release
398 - number.
399
400 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
401 - Incremental improvements
402
403 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
404 - tagging everything for OneLab tech-transfer.
405
406
407 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
408
409
410 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
411
412
413 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
414 - This should be ready for 4.2rc2
415
416
417 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
418 - initial addition.
419
420 %define module_current_branch 2.0