Setting tag monitor-3.1-1
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 1
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53 Requires: sendmail
54 Requires: php
55 Requires: httpd
56
57 Requires: cronie
58 Requires: nagios
59 Requires: nagios-common
60 Requires: nagios-devel
61 Requires: nagios-plugins-all
62 Requires: ndoutils
63 Requires: ndoutils-mysql
64
65 Requires: rt3
66
67
68 %description nagios
69 Scripts and setup necessary to integrate and monitor PLC with Nagios.
70 Best suited to F12 or above.
71
72 ######################################## CLIENT
73
74 %package client
75 Summary: Monitor hooks for a PLC node
76 Group: Applications/System
77 Requires: curl
78 Requires: coreutils
79
80 %description client
81 The client scripts handle account creation inside of a node.  This will
82 include configuration setup for the monitoring agent running on the node.  It
83 will also include any cron or init scripts needed to perform this kind of
84 maintenance.
85 ######################################## Server Deps
86 %package server-deps
87 Summary: Monitor hooks for the PLC server.
88 Group: Applications/System
89
90 Requires: python
91 Requires: python-setuptools-devel
92 Requires: python-peak-util-extremes
93
94 Requires: compat-libstdc++-296
95 Requires: openssh-clients
96 Requires: perl-libwww-perl
97 Requires: perl-IO-Socket-SSL 
98 Requires: MySQL-python
99 Requires: nmap
100 Requires: nc
101 Requires: rt3
102
103 Requires: plewww-plekit
104
105 #Requires: zabbix-client
106 #Requires: zabbix-gui
107 #Requires: zabbix-server
108
109 %description server-deps
110 The server side include all python modules and scripts needed to fully
111
112 ######################################## Server
113 %package server
114 Summary: Monitor hooks for the PLC server.
115 Group: Applications/System
116
117 Requires: python
118
119 Requires: monitor-server-deps
120 Requires: PLCWWW >= 4.2
121 Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
122 Requires: pcucontrol
123
124 %description server
125 The server side include all python modules and scripts needed to fully
126 operation, track, and interact with any third-party monitoring software, such
127 as Zabbix DB.
128
129 ####################################### RunlevelAgent
130 %package runlevelagent
131 summary: the RunlevelAgent that reports node runlevels
132 group: applications/system
133 requires: python
134
135 %description runlevelagent
136 The RunlevelAgent starts as early as possible during boot-up and production
137 mode to actively report the observed runlevel to PLC and update the
138 'last_contact' field.
139
140 %prep
141 %setup -q
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 #################### CLIENT 
146 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
147 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
148 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
149
150
151 #################### SERVER
152 install -d $RPM_BUILD_ROOT/usr/share/%{name}
153 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
154 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
155 install -d $RPM_BUILD_ROOT/var/lib/%{name}
156 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
157 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
158 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
159 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
160
161 # plc.d scripts
162 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
163 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
164 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
165
166 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
167 install -D -m 644 nagios/monitor-nagios.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-nagios.cron
168
169 # cron job for automated polling
170 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
171
172 # apache configuration
173 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
174
175 # we'll install monitor in site-packages install rest to
176 # /usr/share/monitor
177 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
178     --exclude monitor/ \
179     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
180
181 # install monitor python package
182 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
183
184 install -D -m 644 monitor/wrapper/plc.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
185 install -D -m 644 monitor/generic.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
186
187 # install third-party module to site-packages
188 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
189
190 # TODO: 
191 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
192 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
193
194 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
195 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
196
197 #################### RunlevelAgent
198 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
199 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
200
201 mkdir -p $RPM_BUILD_ROOT/var/log
202 touch $RPM_BUILD_ROOT/var/log/server-deps.log
203
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %files server-deps
209 /var/log/server-deps.log
210
211 %files nagios
212 %defattr(-,root,root)
213 %{_sysconfdir}/plc.d/monitor-nagios
214 /usr/share/%{name}/nagios 
215 %{_sysconfdir}/cron.d/monitor-nagios.cron
216
217 %files server
218 %defattr(-,root,root)
219 #%config /usr/share/%{name}/monitorconfig.py
220 #%config /etc/monitor.conf
221 /var/lib/%{name}
222 /usr/share/%{name}/MANIFEST.in
223 /usr/share/%{name}/Makefile
224 /usr/share/%{name}/Monitor.spec
225 /usr/share/%{name}/README.txt
226 /usr/share/%{name}/RunlevelAgent.py*
227 /usr/share/%{name}/automate-default.sh
228 /usr/share/%{name}/monitor-default.conf
229 /usr/share/%{name}/monitor-runlevelagent.init
230 /usr/share/%{name}/monitor-server.cron
231 /usr/share/%{name}/monitor-server.init
232 /usr/share/%{name}/monitor.functions
233 /usr/share/%{name}/setup.py*
234 /usr/share/%{name}/threadpool.py*
235 /usr/share/%{name}/zabbix.spec
236
237 /usr/share/%{name}/bootcd
238 /usr/share/%{name}/commands
239 /usr/share/%{name}/config.d
240 /usr/share/%{name}/cron.d
241 /usr/share/%{name}/docs
242 /usr/share/%{name}/keys
243 /usr/share/%{name}/log
244 /usr/share/%{name}/statistics
245 /usr/share/%{name}/tests
246 /usr/share/%{name}/tools
247 /usr/share/%{name}/upgrade
248 /usr/share/%{name}/web
249 /usr/share/%{name}/zabbix
250
251 #/var/www/cgi-bin/monitor
252 %{_sysconfdir}/cron.d/monitor-server.cron
253 %{_sysconfdir}/plc.d/monitor
254 %{_sysconfdir}/plc.d/monitor.functions
255 %{_sysconfdir}/plc.d/zabbix
256 %{_sysconfdir}/httpd/conf.d
257 %{python_sitearch}
258
259
260 %files client
261 %defattr(-,root,root)
262 #%{_initrddir}/monitor
263 #%{_sysconfdir}/cron.d/monitor
264 /usr/bin/timeout.pl
265
266 %files runlevelagent
267 /usr/bin/RunlevelAgent.py*
268 /%{_initrddir}/monitor-runlevelagent
269
270
271 %post server-deps
272 #
273 # TODO: depend on distribution packages where feasible.
274 #
275 #  it would be better to be able to depend on the distribution's
276 # packages for these additional python modules, but packages provided
277 # by fedora 8 (our current deployment) doesn't match the version
278 # requirements.
279 export TMPDIR=/var/tmp/
280 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
281 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
282 easy_install -UZ Elixir
283
284 # crazy openssl libs for racadm binary
285 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
286 mkdir %{_datadir}/%{name}/.ssh
287 chmod 700 %{_datadir}/%{name}/.ssh
288
289 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
290     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
291 fi
292
293 # NOTE: enable monitor by default, since we're installing it.
294 if ! plc-config --category plc_monitor --variable enabled ; then 
295         plc-config --category plc_monitor --variable enabled --value true \
296                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
297 fi
298 if ! plc-config --category plc_monitor --variable from_email ; then
299         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
300                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
301 fi
302 if ! plc-config --category plc_monitor --variable cc_email ; then
303         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
304                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
305 fi
306 if ! plc-config --category plc_monitor --variable rt_queue ; then
307         plc-config --category plc_monitor --variable rt_queue --value support \
308                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
309 fi
310
311 # zabbix:
312 if ! plc-config --category plc_zabbix --variable enabled ; then
313         plc-config --category plc_zabbix --variable enabled --value false \
314                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
315 fi
316 if ! plc-config --category plc_zabbix --variable host ; then
317         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
318                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
319 fi
320 if ! plc-config --category plc_zabbix --variable ip ; then
321         plc-config --category plc_zabbix --variable ip --value "" \ 
322                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
323 fi
324
325 %post nagios
326 # TODO: do as much as possible to get the host setup and running.
327 #chkconfig --add monitor-nagios
328 #chkconfig monitor-nagios on
329 chkconfig mysqld on
330
331 %post server
332 # TODO: this will be nice when we have a web-based service running., such as
333 #               an API server or so on.
334 # TODO: create real monitorconfig.py from monitorconfig-default.py
335 # TODO: create symlink in /var/lib/monitor for chroot environments
336 # TODO: update the content of automate_pl03.sh 
337 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
338
339 # NOTE: generate the python defines from zabbix include files.
340 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
341
342 # apply patches to zabbix
343 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
344
345 #chkconfig --add monitor-server
346 #chkconfig monitor-server on
347
348 %post client
349 chkconfig --add monitor
350 chkconfig monitor on
351
352 %post runlevelagent
353 if [ -f /etc/planetlab/node_id ] ; then
354     chkconfig --add monitor-runlevelagent
355     chkconfig monitor-runlevelagent on
356     if [ "$PL_BOOTCD" != "1" ] ; then
357         service monitor-runlevelagent restart
358     fi
359 fi
360
361
362 %changelog
363 * Fri May 06 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-1
364 - last tag before some more major changes
365
366 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
367 - Add CSV link on Advanced query
368 - Preparing to branch
369
370 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
371 - * copy selections to clipbord on Advanced Query page
372 - * RPM Pattern as regexp
373 - * scan ipmi port
374
375 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
376 - handle hostname changes
377
378 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
379 - from this version, suitable for 5.0
380 - requires bootcd with the new 5.0 naming style 3-part nodefamily
381
382 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
383 - added fix for node delete/add causing conflicts in MyOps db.
384 - added statistics scripts
385
386 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
387 - * fix paths for automate script
388
389 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
390 - - separate pcucontrol as an svn module
391 - - restore easy_instal back into post install stage of server-deps
392 - - template imporovements for web interface
393
394 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
395 - do not need buildrequires. a new tag to fix centos builds
396
397 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
398 - fix rpm build issues
399
400 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
401 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
402
403 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
404 - add option for site status to include both node & pcu status
405 - improve ticket handling
406 - template gadget.xml for a site-specific google-gadget summary
407
408 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
409 - - add install_date
410
411 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
412 - - remove monitor-client.cron
413 - - remove unused monitor-client init script
414 - - fix UP/DOWN summary on nodes page.
415 - - make node page display all nodes by default
416 - - add boot_server field
417 - - add myops_ssh_key to the keychain
418 - - use ext_consortium_id to distinguish pending sites.
419
420 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
421 - show/hide advance query form.
422
423 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
424 - fixed pause_penalty bug.
425 - fixed IPAL pcucontrol bug
426 - fixed bootman tunnel setup bug (occurred in rare cases)
427 - deprecated pcuview
428 - added BootmanSequenceRecords to separate config data from source code
429 - added get/setBootmanSequence(s) to xmlrpc API
430
431 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
432 - Major Features:
433 - added bm log collection and optional integration with BootManager's log Upload()
434 - added iptables_status
435 - expanded advanced query
436 - added differentiated bootmanager_restore actions so that actionsummary displays
437 - counts for each kind of bootmanager action
438 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
439 - added plain-text options for query page by adding tg_format=plain to URL
440 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
441 - fixed a bug in determining whether comon's dir was running on a node
442
443 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
444 - Major increment -
445 - adds multiple features and web changes
446 - adds new fields to db
447 - improved layout
448 - general improvements otherwise
449
450 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
451 - bug fixes.
452 - improved templates and views
453 - cleaned controller code for web
454 - added IPMI requirement to pcucontrol package.
455
456 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
457 - added bootmanager log links
458 - addressed root cause of IntegrityErrors ; big deal
459 - adjusted templates to accomodate fix for IntegrityErrors
460 - added session.flush() to bootman.py to write out ActionsRecords
461 - fixed policy to either pause penalties or apply them ; not both.
462
463 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
464 -- Added Rpyc from 1.0 branch.
465 -- add pcuhistory
466 -- add setup-agent for password protected keys.
467 -- other minor improvements.
468
469 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
470 - automate install
471 - auto-close tickets
472
473 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
474 - update web
475 - update policy
476 - added statistics dir
477
478 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
479 - remove plccache from controllers, all lookups from db.
480 - reformat emailTxt messags
481 - updated bootstates in bootman.py
482
483 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
484 - tag of latest changes.
485 - need to test end to end.
486
487 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
488 - big merge from the 2.0 branch
489
490 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
491 - minor improvements in rendering with sortable tables
492
493 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
494
495 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
496 - first draft with sortable tables + checkpoint
497
498 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
499 - use plekit tables from plewww.
500 - depend on plewww-plekit
501
502 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
503 - make docs a noop
504 - fix for package name dependency
505 - correct docs
506
507 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
508 - add improved docs to the latest build and tag.
509
510 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
511 - add documentation hooks for adding in-line docs like NM and PLCAPI
512
513 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
514 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
515 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
516 - 'safeboot', 'failboot', 'reinstall', etc.
517
518 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
519 - same as 2.0-12 tag.
520
521 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
522 - merge from 2.0, remove more zabbix code, simplify install, etc.
523
524 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
525 - major merge from 2.0 branch.
526 - ready to be updated with 4.3 and web changes.
527
528 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
529 - preparing to make a 2.0 branch for monitor.
530
531 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
532 - new changes are significantly different, that I'm upping the number for clarity.
533
534 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
535 - These are all changes in the latest Monitor code.  I will branch this version
536 - next, before making additional large changes.
537
538 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
539 - Checkpointing current version for 4.2-rc21 - many many changes
540
541 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
542 - This is a major tag of every thing.  probably needs a very different release
543 - number.
544
545 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
546 - Incremental improvements
547
548 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
549 - tagging everything for OneLab tech-transfer.
550
551
552 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
553
554
555 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
556
557
558 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
559 - This should be ready for 4.2rc2
560
561
562 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
563 - initial addition.
564
565 %define module_current_branch 3.0