Tagging module Monitor - Monitor-1.0-6
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 1.0
9 %define taglevel 6
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: Monitor account initialization for the root image.
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: curl
28 Requires: coreutils
29
30 %description
31 Scripts for creating the monitor account in the root filesystem, to enable node access 
32 without using the 'root' account.
33
34 %prep
35 %setup -q
36
37 %build
38 echo "There is no build stage.  Simply copy files."
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -D -m 755 monitor.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
43 install -D -m 755 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(-,root,root)
50 %{_initrddir}/monitor
51 %{_sysconfdir}/cron.d/monitor
52
53 %post
54 chkconfig --add monitor
55 chkconfig monitor on
56
57 %changelog
58 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
59 - This is a major tag of every thing.  probably needs a very different release
60 - number.
61
62 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
63 - Incremental improvements
64
65 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
66 - tagging everything for OneLab tech-transfer.
67
68
69 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
70
71
72 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
73
74
75 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
76 - This should be ready for 4.2rc2
77
78
79 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
80 - initial addition.