Tagging module Monitor - Monitor-3.0-2
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 2
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56
57 Requires: openssh-clients
58 Requires: perl-libwww-perl
59 Requires: perl-IO-Socket-SSL 
60 Requires: MySQL-python
61 Requires: nmap
62 Requires: rt3
63
64 #Requires: python-sqlalchemy
65 #Requires: python-elixir
66 #Requires: zabbix-client
67 #Requires: zabbix-gui
68 #Requires: zabbix-server
69
70 %description server-deps
71 The server side include all python modules and scripts needed to fully
72
73 ######################################## Server
74 %package server
75 Summary: Monitor hooks for the PLC server.
76 Group: Applications/System
77
78 Requires: python
79
80 Requires: monitor-server-deps
81 Requires: monitor-pcucontrol
82 Requires: PLCWWW >= 4.2
83 Requires: bootcd-planetlab-i386 >= 4.2
84
85 %description server
86 The server side include all python modules and scripts needed to fully
87 operation, track, and interact with any third-party monitoring software, such
88 as Zabbix DB.
89
90 ######################################## PCU Control
91
92 %package pcucontrol
93 summary: pcu controls for monitor and plcapi
94 group: applications/system
95 requires: python
96
97 %description pcucontrol
98 both monitor and the plcapi use a set of common commands to reboot machines
99 using their external or internal pcus.  this package is a library of several
100 supported models.
101
102 ####################################### RunlevelAgent
103 %package runlevelagent
104 summary: the RunlevelAgent that reports node runlevels
105 group: applications/system
106 requires: python
107
108 %description runlevelagent
109 The RunlevelAgent starts as early as possible during boot-up and production
110 mode to actively report the observed runlevel to PLC and update the
111 'last_contact' field.
112
113 %prep
114 %setup -q
115
116 %build
117 # NOTE: the build uses g++ cmdamt/
118 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
119 cd pcucontrol/models/intelamt
120 export TMPDIR=$PWD/tmp
121 make
122 cd ..
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 #################### CLIENT 
127 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
128 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
129
130 #################### SERVER
131 install -d $RPM_BUILD_ROOT/usr/share/%{name}
132 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
133 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
134 install -d $RPM_BUILD_ROOT/var/lib/%{name}
135 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
136 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
137
138 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
139
140 echo " * Installing core scripts"
141 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
142           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
143
144 echo " * Installing web pages"
145 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
146
147 echo " * Installing cron job for automated polling"
148 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
149 echo " * TODO: Setting up Monitor account in local MyPLC"
150 # TODO: 
151
152 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
153 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
154 # TODO: need a much better way to do this.
155 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
156 #for file in __init__.py database.py config.py ; do 
157 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
158 #done
159 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
160 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
161
162 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
163 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
164
165 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
166 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
167
168 #################### RunlevelAgent
169 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
170 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
171
172 mkdir -p $RPM_BUILD_ROOT/var/log
173 touch $RPM_BUILD_ROOT/var/log/server-deps.log
174
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %files server-deps
180 /var/log/server-deps.log
181
182 %files server
183 %defattr(-,root,root)
184 #%config /usr/share/%{name}/monitorconfig.py
185 #%config /etc/monitor.conf
186 /usr/share/%{name}
187 /var/lib/%{name}
188 /var/www/cgi-bin/monitor
189 %{_sysconfdir}/cron.d/monitor-server.cron
190 %{python_sitearch}/threadpool.py
191 %{python_sitearch}/threadpool.pyc
192 %{python_sitearch}/threadpool.pyo
193 %{python_sitearch}/monitor
194 %{_sysconfdir}/plc.d/monitor
195
196 %files client
197 %defattr(-,root,root)
198 %{_initrddir}/monitor
199 %{_sysconfdir}/cron.d/monitor
200
201 %files pcucontrol
202 %{python_sitearch}/pcucontrol
203
204 %files runlevelagent
205 /usr/bin/RunlevelAgent.py
206 /usr/bin/RunlevelAgent.pyo
207 /usr/bin/RunlevelAgent.pyc
208 /%{_initrddir}/monitor-runlevelagent
209
210 %post server-deps
211 easy_install -UZ Elixir
212 easy_install -UZ ElementTree
213 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
214 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
215
216 # NOTE: add the default xml stuff if it's not already in the default xml config.
217 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
218     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
219 fi
220
221
222 %post server
223 # TODO: this will be nice when we have a web-based service running., such as
224 #               an API server or so on.
225 # TODO: create real monitorconfig.py from monitorconfig-default.py
226 # TODO: create monitorconfig.php using phpconfig.py 
227 # TODO: create symlink in /var/lib/monitor for chroot environments
228 # TODO: update the content of automate_pl03.sh 
229 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
230
231 # NOTE: generate the python defines from zabbix include files.
232 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
233
234 # apply patches to zabbix
235 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
236
237 #chkconfig --add monitor-server
238 #chkconfig monitor-server on
239
240 %post client
241 chkconfig --add monitor
242 chkconfig monitor on
243
244 %post runlevelagent
245 chkconfig --add monitor-runlevelagent
246 chkconfig monitor-runlevelagent on
247
248 %changelog
249 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
250 - merge from 2.0, remove more zabbix code, simplify install, etc.
251
252 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
253 - major merge from 2.0 branch.
254 - ready to be updated with 4.3 and web changes.
255
256 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
257 - preparing to make a 2.0 branch for monitor.
258
259 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
260 - new changes are significantly different, that I'm upping the number for clarity.
261
262 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
263 - These are all changes in the latest Monitor code.  I will branch this version
264 - next, before making additional large changes.
265
266 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
267 - Checkpointing current version for 4.2-rc21 - many many changes
268
269 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
270 - This is a major tag of every thing.  probably needs a very different release
271 - number.
272
273 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
274 - Incremental improvements
275
276 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
277 - tagging everything for OneLab tech-transfer.
278
279
280 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
281
282
283 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
284
285
286 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
287 - This should be ready for 4.2rc2
288
289
290 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
291 - initial addition.
292
293 %define module_current_branch 2.0