require pcucontrol.
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 28
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # this is only required for fedora and we have this in devel.pkgs for
29 # all fedora builds.
30 # BuildRequires: python-setuptools-devel
31
32
33 Summary: Monitor account initialization for the root image.
34 Group: Applications/System
35
36 %description
37 Monitor is a collection of secondary scripts for configuring the node polling
38 system, syncing the PLC db with the monitoring database, notifying users,
39 interacting with PCU hardware, applying penalties to sites that violate
40 acceptable use.
41
42 ######################################## CLIENT
43
44 %package client
45 Summary: Monitor hooks for a PLC node
46 Group: Applications/System
47 Requires: curl
48 Requires: coreutils
49
50 %description client
51 The client scripts handle account creation inside of a node.  This will
52 include configuration setup for the monitoring agent running on the node.  It
53 will also include any cron or init scripts needed to perform this kind of
54 maintenance.
55 ######################################## Server Deps
56 %package server-deps
57 Summary: Monitor hooks for the PLC server.
58 Group: Applications/System
59
60 Requires: python
61 Requires: python-peak-util-extremes
62
63 Requires: compat-libstdc++-296
64 Requires: openssh-clients
65 Requires: perl-libwww-perl
66 Requires: perl-IO-Socket-SSL 
67 Requires: MySQL-python
68 Requires: nmap
69 Requires: nc
70 Requires: rt3
71
72 Requires: plewww-plekit
73
74 #Requires: zabbix-client
75 #Requires: zabbix-gui
76 #Requires: zabbix-server
77
78 %description server-deps
79 The server side include all python modules and scripts needed to fully
80
81 ######################################## Server
82 %package server
83 Summary: Monitor hooks for the PLC server.
84 Group: Applications/System
85
86 Requires: python
87
88 Requires: monitor-server-deps
89 Requires: PLCWWW >= 4.2
90 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
91 Requires: pcucontrol
92
93 %description server
94 The server side include all python modules and scripts needed to fully
95 operation, track, and interact with any third-party monitoring software, such
96 as Zabbix DB.
97
98 ####################################### RunlevelAgent
99 %package runlevelagent
100 summary: the RunlevelAgent that reports node runlevels
101 group: applications/system
102 requires: python
103
104 %description runlevelagent
105 The RunlevelAgent starts as early as possible during boot-up and production
106 mode to actively report the observed runlevel to PLC and update the
107 'last_contact' field.
108
109 %prep
110 %setup -q
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 #################### CLIENT 
115 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
116 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
117 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
118
119
120 #################### SERVER
121 install -d $RPM_BUILD_ROOT/usr/share/%{name}
122 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
123 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
124 install -d $RPM_BUILD_ROOT/var/lib/%{name}
125 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
126 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
127 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
128 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
129
130 # pack monitor's dependencies in RPM to make it easier to deploy.
131 export TMPDIR=/var/tmp/
132 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
133 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
134 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
135 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
136 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
137
138 # plc.d scripts
139 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
140 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
141 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
142
143 # cron job for automated polling
144 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
145
146 # apache configuration
147 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
148
149 # we'll install monitor in site-packages install rest to
150 # /usr/share/monitor
151 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
152     --exclude monitor/ \
153     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
154
155 # install monitor python package
156 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
157
158 # install third-party module to site-packages
159 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
160
161 # TODO: 
162 echo " * TODO: Setting up Monitor account in local MyPLC"
163
164 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
165 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
166
167 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
168 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
169
170 #################### RunlevelAgent
171 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
172 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
173
174 mkdir -p $RPM_BUILD_ROOT/var/log
175 touch $RPM_BUILD_ROOT/var/log/server-deps.log
176
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %files server-deps
182 /var/log/server-deps.log
183
184 %files server
185 %defattr(-,root,root)
186 #%config /usr/share/%{name}/monitorconfig.py
187 #%config /etc/monitor.conf
188 /usr/share/%{name}
189 /var/lib/%{name}
190 #/var/www/cgi-bin/monitor
191 %{_sysconfdir}/cron.d/monitor-server.cron
192 %{_sysconfdir}/plc.d/monitor
193 %{_sysconfdir}/plc.d/monitor.functions
194 %{_sysconfdir}/plc.d/zabbix
195 %{_sysconfdir}/httpd/conf.d
196 %{python_sitearch}
197
198 %files client
199 %defattr(-,root,root)
200 #%{_initrddir}/monitor
201 #%{_sysconfdir}/cron.d/monitor
202 /usr/bin/timeout.pl
203
204 %files runlevelagent
205 /usr/bin/RunlevelAgent.py*
206 /%{_initrddir}/monitor-runlevelagent
207
208 %post server-deps
209
210 # crazy openssl libs for racadm binary
211 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
212 mkdir %{_datadir}/%{name}/.ssh
213 chmod 700 %{_datadir}/%{name}/.ssh
214
215 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
216     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
217 fi
218
219 # NOTE: enable monitor by default, since we're installing it.
220 if ! plc-config --category plc_monitor --variable enabled ; then 
221         plc-config --category plc_monitor --variable enabled --value true \
222                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
223 fi
224 if ! plc-config --category plc_monitor --variable from_email ; then
225         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
226                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
227 fi
228 if ! plc-config --category plc_monitor --variable cc_email ; then
229         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
230                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
231 fi
232 if ! plc-config --category plc_monitor --variable rt_queue ; then
233         plc-config --category plc_monitor --variable rt_queue --value support \
234                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
235 fi
236
237 # zabbix:
238 if ! plc-config --category plc_zabbix --variable enabled ; then
239         plc-config --category plc_zabbix --variable enabled --value false \
240                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
241 fi
242 if ! plc-config --category plc_zabbix --variable host ; then
243         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
244                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
245 fi
246 if ! plc-config --category plc_zabbix --variable ip ; then
247         plc-config --category plc_zabbix --variable ip --value "" \ 
248                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
249 fi
250
251 %post server
252 # TODO: this will be nice when we have a web-based service running., such as
253 #               an API server or so on.
254 # TODO: create real monitorconfig.py from monitorconfig-default.py
255 # TODO: create symlink in /var/lib/monitor for chroot environments
256 # TODO: update the content of automate_pl03.sh 
257 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
258
259 # NOTE: generate the python defines from zabbix include files.
260 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
261
262 # apply patches to zabbix
263 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
264
265 #chkconfig --add monitor-server
266 #chkconfig monitor-server on
267
268 %post client
269 chkconfig --add monitor
270 chkconfig monitor on
271
272 %post runlevelagent
273 chkconfig --add monitor-runlevelagent
274 chkconfig monitor-runlevelagent on
275 if [ "$PL_BOOTCD" != "1" ] ; then
276         service monitor-runlevelagent restart
277 fi
278
279
280 %changelog
281 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
282 - do not need buildrequires. a new tag to fix centos builds
283
284 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
285 - fix rpm build issues
286
287 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
288 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
289
290 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
291 - add option for site status to include both node & pcu status
292 - improve ticket handling
293 - template gadget.xml for a site-specific google-gadget summary
294
295 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
296 - - add install_date
297
298 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
299 - - remove monitor-client.cron
300 - - remove unused monitor-client init script
301 - - fix UP/DOWN summary on nodes page.
302 - - make node page display all nodes by default
303 - - add boot_server field
304 - - add myops_ssh_key to the keychain
305 - - use ext_consortium_id to distinguish pending sites.
306
307 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
308 - show/hide advance query form.
309
310 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
311 - fixed pause_penalty bug.
312 - fixed IPAL pcucontrol bug
313 - fixed bootman tunnel setup bug (occurred in rare cases)
314 - deprecated pcuview
315 - added BootmanSequenceRecords to separate config data from source code
316 - added get/setBootmanSequence(s) to xmlrpc API
317
318 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
319 - Major Features:
320 - added bm log collection and optional integration with BootManager's log Upload()
321 - added iptables_status
322 - expanded advanced query
323 - added differentiated bootmanager_restore actions so that actionsummary displays
324 - counts for each kind of bootmanager action
325 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
326 - added plain-text options for query page by adding tg_format=plain to URL
327 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
328 - fixed a bug in determining whether comon's dir was running on a node
329
330 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
331 - Major increment -
332 - adds multiple features and web changes
333 - adds new fields to db
334 - improved layout
335 - general improvements otherwise
336
337 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
338 - bug fixes.
339 - improved templates and views
340 - cleaned controller code for web
341 - added IPMI requirement to pcucontrol package.
342
343 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
344 - added bootmanager log links
345 - addressed root cause of IntegrityErrors ; big deal
346 - adjusted templates to accomodate fix for IntegrityErrors
347 - added session.flush() to bootman.py to write out ActionsRecords
348 - fixed policy to either pause penalties or apply them ; not both.
349
350 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
351 -- Added Rpyc from 1.0 branch.
352 -- add pcuhistory
353 -- add setup-agent for password protected keys.
354 -- other minor improvements.
355
356 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
357 - automate install
358 - auto-close tickets
359
360 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
361 - update web
362 - update policy
363 - added statistics dir
364
365 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
366 - remove plccache from controllers, all lookups from db.
367 - reformat emailTxt messags
368 - updated bootstates in bootman.py
369
370 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
371 - tag of latest changes.
372 - need to test end to end.
373
374 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
375 - big merge from the 2.0 branch
376
377 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
378 - minor improvements in rendering with sortable tables
379
380 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
381
382 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
383 - first draft with sortable tables + checkpoint
384
385 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
386 - use plekit tables from plewww.
387 - depend on plewww-plekit
388
389 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
390 - make docs a noop
391 - fix for package name dependency
392 - correct docs
393
394 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
395 - add improved docs to the latest build and tag.
396
397 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
398 - add documentation hooks for adding in-line docs like NM and PLCAPI
399
400 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
401 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
402 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
403 - 'safeboot', 'failboot', 'reinstall', etc.
404
405 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
406 - same as 2.0-12 tag.
407
408 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
409 - merge from 2.0, remove more zabbix code, simplify install, etc.
410
411 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
412 - major merge from 2.0 branch.
413 - ready to be updated with 4.3 and web changes.
414
415 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
416 - preparing to make a 2.0 branch for monitor.
417
418 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
419 - new changes are significantly different, that I'm upping the number for clarity.
420
421 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
422 - These are all changes in the latest Monitor code.  I will branch this version
423 - next, before making additional large changes.
424
425 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
426 - Checkpointing current version for 4.2-rc21 - many many changes
427
428 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
429 - This is a major tag of every thing.  probably needs a very different release
430 - number.
431
432 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
433 - Incremental improvements
434
435 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
436 - tagging everything for OneLab tech-transfer.
437
438
439 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
440
441
442 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
443
444
445 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
446 - This should be ready for 4.2rc2
447
448
449 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
450 - initial addition.
451
452 %define module_current_branch 2.0