remove pcucontrol from Monitor.spec
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 28
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # this is only required for fedora and we have this in devel.pkgs for
29 # all fedora builds.
30 # BuildRequires: python-setuptools-devel
31
32
33 Summary: Monitor account initialization for the root image.
34 Group: Applications/System
35
36 %description
37 Monitor is a collection of secondary scripts for configuring the node polling
38 system, syncing the PLC db with the monitoring database, notifying users,
39 interacting with PCU hardware, applying penalties to sites that violate
40 acceptable use.
41
42 ######################################## CLIENT
43
44 %package client
45 Summary: Monitor hooks for a PLC node
46 Group: Applications/System
47 Requires: curl
48 Requires: coreutils
49
50 %description client
51 The client scripts handle account creation inside of a node.  This will
52 include configuration setup for the monitoring agent running on the node.  It
53 will also include any cron or init scripts needed to perform this kind of
54 maintenance.
55 ######################################## Server Deps
56 %package server-deps
57 Summary: Monitor hooks for the PLC server.
58 Group: Applications/System
59
60 Requires: python
61 Requires: python-peak-util-extremes
62
63 Requires: compat-libstdc++-296
64 Requires: openssh-clients
65 Requires: perl-libwww-perl
66 Requires: perl-IO-Socket-SSL 
67 Requires: MySQL-python
68 Requires: nmap
69 Requires: nc
70 Requires: rt3
71
72 Requires: plewww-plekit
73
74 #Requires: zabbix-client
75 #Requires: zabbix-gui
76 #Requires: zabbix-server
77
78 %description server-deps
79 The server side include all python modules and scripts needed to fully
80
81 ######################################## Server
82 %package server
83 Summary: Monitor hooks for the PLC server.
84 Group: Applications/System
85
86 Requires: python
87
88 Requires: monitor-server-deps
89 Requires: PLCWWW >= 4.2
90 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
91
92 %description server
93 The server side include all python modules and scripts needed to fully
94 operation, track, and interact with any third-party monitoring software, such
95 as Zabbix DB.
96
97 ####################################### RunlevelAgent
98 %package runlevelagent
99 summary: the RunlevelAgent that reports node runlevels
100 group: applications/system
101 requires: python
102
103 %description runlevelagent
104 The RunlevelAgent starts as early as possible during boot-up and production
105 mode to actively report the observed runlevel to PLC and update the
106 'last_contact' field.
107
108 %prep
109 %setup -q
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 #################### CLIENT 
114 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
115 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
116 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
117
118
119 #################### SERVER
120 install -d $RPM_BUILD_ROOT/usr/share/%{name}
121 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
122 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
123 install -d $RPM_BUILD_ROOT/var/lib/%{name}
124 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
125 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
126 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
127 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
128
129 # pack monitor's dependencies in RPM to make it easier to deploy.
130 export TMPDIR=/var/tmp/
131 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
132 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
133 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
134 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
135 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
136
137 # plc.d scripts
138 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
139 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
140 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
141
142 # cron job for automated polling
143 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
144
145 # apache configuration
146 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
147
148 # we'll install monitor in site-packages install rest to
149 # /usr/share/monitor
150 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
151     --exclude monitor/ \
152     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
153
154 # install monitor python package
155 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
156
157 # install third-party module to site-packages
158 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
159
160 # TODO: 
161 echo " * TODO: Setting up Monitor account in local MyPLC"
162
163 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
164 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
165
166 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
167 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
168
169 #################### RunlevelAgent
170 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
171 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
172
173 mkdir -p $RPM_BUILD_ROOT/var/log
174 touch $RPM_BUILD_ROOT/var/log/server-deps.log
175
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files server-deps
181 /var/log/server-deps.log
182
183 %files server
184 %defattr(-,root,root)
185 #%config /usr/share/%{name}/monitorconfig.py
186 #%config /etc/monitor.conf
187 /usr/share/%{name}
188 /var/lib/%{name}
189 #/var/www/cgi-bin/monitor
190 %{_sysconfdir}/cron.d/monitor-server.cron
191 %{_sysconfdir}/plc.d/monitor
192 %{_sysconfdir}/plc.d/monitor.functions
193 %{_sysconfdir}/plc.d/zabbix
194 %{_sysconfdir}/httpd/conf.d
195 %{python_sitearch}
196
197 %files client
198 %defattr(-,root,root)
199 #%{_initrddir}/monitor
200 #%{_sysconfdir}/cron.d/monitor
201 /usr/bin/timeout.pl
202
203 %files runlevelagent
204 /usr/bin/RunlevelAgent.py*
205 /%{_initrddir}/monitor-runlevelagent
206
207 %post server-deps
208
209 # crazy openssl libs for racadm binary
210 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
211 mkdir %{_datadir}/%{name}/.ssh
212 chmod 700 %{_datadir}/%{name}/.ssh
213
214 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
215     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
216 fi
217
218 # NOTE: enable monitor by default, since we're installing it.
219 if ! plc-config --category plc_monitor --variable enabled ; then 
220         plc-config --category plc_monitor --variable enabled --value true \
221                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
222 fi
223 if ! plc-config --category plc_monitor --variable from_email ; then
224         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
225                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
226 fi
227 if ! plc-config --category plc_monitor --variable cc_email ; then
228         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
229                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
230 fi
231 if ! plc-config --category plc_monitor --variable rt_queue ; then
232         plc-config --category plc_monitor --variable rt_queue --value support \
233                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
234 fi
235
236 # zabbix:
237 if ! plc-config --category plc_zabbix --variable enabled ; then
238         plc-config --category plc_zabbix --variable enabled --value false \
239                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
240 fi
241 if ! plc-config --category plc_zabbix --variable host ; then
242         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
243                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
244 fi
245 if ! plc-config --category plc_zabbix --variable ip ; then
246         plc-config --category plc_zabbix --variable ip --value "" \ 
247                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
248 fi
249
250 %post server
251 # TODO: this will be nice when we have a web-based service running., such as
252 #               an API server or so on.
253 # TODO: create real monitorconfig.py from monitorconfig-default.py
254 # TODO: create symlink in /var/lib/monitor for chroot environments
255 # TODO: update the content of automate_pl03.sh 
256 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
257
258 # NOTE: generate the python defines from zabbix include files.
259 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
260
261 # apply patches to zabbix
262 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
263
264 #chkconfig --add monitor-server
265 #chkconfig monitor-server on
266
267 %post client
268 chkconfig --add monitor
269 chkconfig monitor on
270
271 %post runlevelagent
272 chkconfig --add monitor-runlevelagent
273 chkconfig monitor-runlevelagent on
274 if [ "$PL_BOOTCD" != "1" ] ; then
275         service monitor-runlevelagent restart
276 fi
277
278
279 %changelog
280 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
281 - do not need buildrequires. a new tag to fix centos builds
282
283 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
284 - fix rpm build issues
285
286 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
287 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
288
289 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
290 - add option for site status to include both node & pcu status
291 - improve ticket handling
292 - template gadget.xml for a site-specific google-gadget summary
293
294 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
295 - - add install_date
296
297 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
298 - - remove monitor-client.cron
299 - - remove unused monitor-client init script
300 - - fix UP/DOWN summary on nodes page.
301 - - make node page display all nodes by default
302 - - add boot_server field
303 - - add myops_ssh_key to the keychain
304 - - use ext_consortium_id to distinguish pending sites.
305
306 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
307 - show/hide advance query form.
308
309 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
310 - fixed pause_penalty bug.
311 - fixed IPAL pcucontrol bug
312 - fixed bootman tunnel setup bug (occurred in rare cases)
313 - deprecated pcuview
314 - added BootmanSequenceRecords to separate config data from source code
315 - added get/setBootmanSequence(s) to xmlrpc API
316
317 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
318 - Major Features:
319 - added bm log collection and optional integration with BootManager's log Upload()
320 - added iptables_status
321 - expanded advanced query
322 - added differentiated bootmanager_restore actions so that actionsummary displays
323 - counts for each kind of bootmanager action
324 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
325 - added plain-text options for query page by adding tg_format=plain to URL
326 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
327 - fixed a bug in determining whether comon's dir was running on a node
328
329 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
330 - Major increment -
331 - adds multiple features and web changes
332 - adds new fields to db
333 - improved layout
334 - general improvements otherwise
335
336 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
337 - bug fixes.
338 - improved templates and views
339 - cleaned controller code for web
340 - added IPMI requirement to pcucontrol package.
341
342 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
343 - added bootmanager log links
344 - addressed root cause of IntegrityErrors ; big deal
345 - adjusted templates to accomodate fix for IntegrityErrors
346 - added session.flush() to bootman.py to write out ActionsRecords
347 - fixed policy to either pause penalties or apply them ; not both.
348
349 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
350 -- Added Rpyc from 1.0 branch.
351 -- add pcuhistory
352 -- add setup-agent for password protected keys.
353 -- other minor improvements.
354
355 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
356 - automate install
357 - auto-close tickets
358
359 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
360 - update web
361 - update policy
362 - added statistics dir
363
364 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
365 - remove plccache from controllers, all lookups from db.
366 - reformat emailTxt messags
367 - updated bootstates in bootman.py
368
369 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
370 - tag of latest changes.
371 - need to test end to end.
372
373 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
374 - big merge from the 2.0 branch
375
376 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
377 - minor improvements in rendering with sortable tables
378
379 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
380
381 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
382 - first draft with sortable tables + checkpoint
383
384 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
385 - use plekit tables from plewww.
386 - depend on plewww-plekit
387
388 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
389 - make docs a noop
390 - fix for package name dependency
391 - correct docs
392
393 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
394 - add improved docs to the latest build and tag.
395
396 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
397 - add documentation hooks for adding in-line docs like NM and PLCAPI
398
399 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
400 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
401 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
402 - 'safeboot', 'failboot', 'reinstall', etc.
403
404 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
405 - same as 2.0-12 tag.
406
407 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
408 - merge from 2.0, remove more zabbix code, simplify install, etc.
409
410 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
411 - major merge from 2.0 branch.
412 - ready to be updated with 4.3 and web changes.
413
414 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
415 - preparing to make a 2.0 branch for monitor.
416
417 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
418 - new changes are significantly different, that I'm upping the number for clarity.
419
420 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
421 - These are all changes in the latest Monitor code.  I will branch this version
422 - next, before making additional large changes.
423
424 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
425 - Checkpointing current version for 4.2-rc21 - many many changes
426
427 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
428 - This is a major tag of every thing.  probably needs a very different release
429 - number.
430
431 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
432 - Incremental improvements
433
434 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
435 - tagging everything for OneLab tech-transfer.
436
437
438 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
439
440
441 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
442
443
444 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
445 - This should be ready for 4.2rc2
446
447
448 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
449 - initial addition.
450
451 %define module_current_branch 2.0