Setting tag Monitor-3.0-31
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 31
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## CLIENT
39
40 %package client
41 Summary: Monitor hooks for a PLC node
42 Group: Applications/System
43 Requires: curl
44 Requires: coreutils
45
46 %description client
47 The client scripts handle account creation inside of a node.  This will
48 include configuration setup for the monitoring agent running on the node.  It
49 will also include any cron or init scripts needed to perform this kind of
50 maintenance.
51 ######################################## Server Deps
52 %package server-deps
53 Summary: Monitor hooks for the PLC server.
54 Group: Applications/System
55
56 Requires: python
57 Requires: python-setuptools-devel
58 Requires: python-peak-util-extremes
59
60 Requires: compat-libstdc++-296
61 Requires: openssh-clients
62 Requires: perl-libwww-perl
63 Requires: perl-IO-Socket-SSL 
64 Requires: MySQL-python
65 Requires: nmap
66 Requires: nc
67 Requires: rt3
68
69 Requires: plewww-plekit
70
71 #Requires: zabbix-client
72 #Requires: zabbix-gui
73 #Requires: zabbix-server
74
75 %description server-deps
76 The server side include all python modules and scripts needed to fully
77
78 ######################################## Server
79 %package server
80 Summary: Monitor hooks for the PLC server.
81 Group: Applications/System
82
83 Requires: python
84
85 Requires: monitor-server-deps
86 Requires: PLCWWW >= 4.2
87 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
88 Requires: pcucontrol
89
90 %description server
91 The server side include all python modules and scripts needed to fully
92 operation, track, and interact with any third-party monitoring software, such
93 as Zabbix DB.
94
95 ####################################### RunlevelAgent
96 %package runlevelagent
97 summary: the RunlevelAgent that reports node runlevels
98 group: applications/system
99 requires: python
100
101 %description runlevelagent
102 The RunlevelAgent starts as early as possible during boot-up and production
103 mode to actively report the observed runlevel to PLC and update the
104 'last_contact' field.
105
106 %prep
107 %setup -q
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 #################### CLIENT 
112 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
113 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
114 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
115
116
117 #################### SERVER
118 install -d $RPM_BUILD_ROOT/usr/share/%{name}
119 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
120 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
121 install -d $RPM_BUILD_ROOT/var/lib/%{name}
122 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
123 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
124 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
125 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
126
127 # plc.d scripts
128 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
129 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
130 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
131
132 # cron job for automated polling
133 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
134
135 # apache configuration
136 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
137
138 # we'll install monitor in site-packages install rest to
139 # /usr/share/monitor
140 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
141     --exclude monitor/ \
142     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
143
144 # install monitor python package
145 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
146
147 # install third-party module to site-packages
148 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
149
150 # TODO: 
151 echo " * TODO: Setting up Monitor account in local MyPLC"
152
153 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
154 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
155
156 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
157 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
158
159 #################### RunlevelAgent
160 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
161 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
162
163 mkdir -p $RPM_BUILD_ROOT/var/log
164 touch $RPM_BUILD_ROOT/var/log/server-deps.log
165
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %files server-deps
171 /var/log/server-deps.log
172
173 %files server
174 %defattr(-,root,root)
175 #%config /usr/share/%{name}/monitorconfig.py
176 #%config /etc/monitor.conf
177 /usr/share/%{name}
178 /var/lib/%{name}
179 #/var/www/cgi-bin/monitor
180 %{_sysconfdir}/cron.d/monitor-server.cron
181 %{_sysconfdir}/plc.d/monitor
182 %{_sysconfdir}/plc.d/monitor.functions
183 %{_sysconfdir}/plc.d/zabbix
184 %{_sysconfdir}/httpd/conf.d
185 %{python_sitearch}
186
187 %files client
188 %defattr(-,root,root)
189 #%{_initrddir}/monitor
190 #%{_sysconfdir}/cron.d/monitor
191 /usr/bin/timeout.pl
192
193 %files runlevelagent
194 /usr/bin/RunlevelAgent.py*
195 /%{_initrddir}/monitor-runlevelagent
196
197 %post server-deps
198 #
199 # TODO: depend on distribution packages where feasible.
200 #
201 #  it would be better to be able to depend on the distribution's
202 # packages for these additional python modules, but packages provided
203 # by fedora 8 (our current deployment) doesn't match the version
204 # requirements.
205 export TMPDIR=/var/tmp/
206 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
207 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
208 easy_install -UZ Elixir
209
210 # crazy openssl libs for racadm binary
211 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
212 mkdir %{_datadir}/%{name}/.ssh
213 chmod 700 %{_datadir}/%{name}/.ssh
214
215 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
216     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
217 fi
218
219 # NOTE: enable monitor by default, since we're installing it.
220 if ! plc-config --category plc_monitor --variable enabled ; then 
221         plc-config --category plc_monitor --variable enabled --value true \
222                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
223 fi
224 if ! plc-config --category plc_monitor --variable from_email ; then
225         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
226                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
227 fi
228 if ! plc-config --category plc_monitor --variable cc_email ; then
229         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
230                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
231 fi
232 if ! plc-config --category plc_monitor --variable rt_queue ; then
233         plc-config --category plc_monitor --variable rt_queue --value support \
234                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
235 fi
236
237 # zabbix:
238 if ! plc-config --category plc_zabbix --variable enabled ; then
239         plc-config --category plc_zabbix --variable enabled --value false \
240                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
241 fi
242 if ! plc-config --category plc_zabbix --variable host ; then
243         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
244                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
245 fi
246 if ! plc-config --category plc_zabbix --variable ip ; then
247         plc-config --category plc_zabbix --variable ip --value "" \ 
248                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
249 fi
250
251 %post server
252 # TODO: this will be nice when we have a web-based service running., such as
253 #               an API server or so on.
254 # TODO: create real monitorconfig.py from monitorconfig-default.py
255 # TODO: create symlink in /var/lib/monitor for chroot environments
256 # TODO: update the content of automate_pl03.sh 
257 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
258
259 # NOTE: generate the python defines from zabbix include files.
260 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
261
262 # apply patches to zabbix
263 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
264
265 #chkconfig --add monitor-server
266 #chkconfig monitor-server on
267
268 %post client
269 chkconfig --add monitor
270 chkconfig monitor on
271
272 %post runlevelagent
273 chkconfig --add monitor-runlevelagent
274 chkconfig monitor-runlevelagent on
275 if [ "$PL_BOOTCD" != "1" ] ; then
276         service monitor-runlevelagent restart
277 fi
278
279
280 %changelog
281 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
282 - added fix for node delete/add causing conflicts in MyOps db.
283 - added statistics scripts
284
285 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
286 - * fix paths for automate script
287
288 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
289 - - separate pcucontrol as an svn module
290 - - restore easy_instal back into post install stage of server-deps
291 - - template imporovements for web interface
292
293 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
294 - do not need buildrequires. a new tag to fix centos builds
295
296 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
297 - fix rpm build issues
298
299 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
300 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
301
302 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
303 - add option for site status to include both node & pcu status
304 - improve ticket handling
305 - template gadget.xml for a site-specific google-gadget summary
306
307 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
308 - - add install_date
309
310 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
311 - - remove monitor-client.cron
312 - - remove unused monitor-client init script
313 - - fix UP/DOWN summary on nodes page.
314 - - make node page display all nodes by default
315 - - add boot_server field
316 - - add myops_ssh_key to the keychain
317 - - use ext_consortium_id to distinguish pending sites.
318
319 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
320 - show/hide advance query form.
321
322 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
323 - fixed pause_penalty bug.
324 - fixed IPAL pcucontrol bug
325 - fixed bootman tunnel setup bug (occurred in rare cases)
326 - deprecated pcuview
327 - added BootmanSequenceRecords to separate config data from source code
328 - added get/setBootmanSequence(s) to xmlrpc API
329
330 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
331 - Major Features:
332 - added bm log collection and optional integration with BootManager's log Upload()
333 - added iptables_status
334 - expanded advanced query
335 - added differentiated bootmanager_restore actions so that actionsummary displays
336 - counts for each kind of bootmanager action
337 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
338 - added plain-text options for query page by adding tg_format=plain to URL
339 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
340 - fixed a bug in determining whether comon's dir was running on a node
341
342 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
343 - Major increment -
344 - adds multiple features and web changes
345 - adds new fields to db
346 - improved layout
347 - general improvements otherwise
348
349 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
350 - bug fixes.
351 - improved templates and views
352 - cleaned controller code for web
353 - added IPMI requirement to pcucontrol package.
354
355 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
356 - added bootmanager log links
357 - addressed root cause of IntegrityErrors ; big deal
358 - adjusted templates to accomodate fix for IntegrityErrors
359 - added session.flush() to bootman.py to write out ActionsRecords
360 - fixed policy to either pause penalties or apply them ; not both.
361
362 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
363 -- Added Rpyc from 1.0 branch.
364 -- add pcuhistory
365 -- add setup-agent for password protected keys.
366 -- other minor improvements.
367
368 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
369 - automate install
370 - auto-close tickets
371
372 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
373 - update web
374 - update policy
375 - added statistics dir
376
377 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
378 - remove plccache from controllers, all lookups from db.
379 - reformat emailTxt messags
380 - updated bootstates in bootman.py
381
382 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
383 - tag of latest changes.
384 - need to test end to end.
385
386 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
387 - big merge from the 2.0 branch
388
389 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
390 - minor improvements in rendering with sortable tables
391
392 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
393
394 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
395 - first draft with sortable tables + checkpoint
396
397 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
398 - use plekit tables from plewww.
399 - depend on plewww-plekit
400
401 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
402 - make docs a noop
403 - fix for package name dependency
404 - correct docs
405
406 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
407 - add improved docs to the latest build and tag.
408
409 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
410 - add documentation hooks for adding in-line docs like NM and PLCAPI
411
412 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
413 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
414 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
415 - 'safeboot', 'failboot', 'reinstall', etc.
416
417 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
418 - same as 2.0-12 tag.
419
420 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
421 - merge from 2.0, remove more zabbix code, simplify install, etc.
422
423 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
424 - major merge from 2.0 branch.
425 - ready to be updated with 4.3 and web changes.
426
427 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
428 - preparing to make a 2.0 branch for monitor.
429
430 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
431 - new changes are significantly different, that I'm upping the number for clarity.
432
433 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
434 - These are all changes in the latest Monitor code.  I will branch this version
435 - next, before making additional large changes.
436
437 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
438 - Checkpointing current version for 4.2-rc21 - many many changes
439
440 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
441 - This is a major tag of every thing.  probably needs a very different release
442 - number.
443
444 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
445 - Incremental improvements
446
447 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
448 - tagging everything for OneLab tech-transfer.
449
450
451 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
452
453
454 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
455
456
457 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
458 - This should be ready for 4.2rc2
459
460
461 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
462 - initial addition.
463
464 %define module_current_branch 2.0