Tagging module Monitor - Monitor-1.0-13
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 1.0
9 %define taglevel 13
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: Monitor account initialization for the root image.
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Requires: curl
28 Requires: coreutils
29
30 %description
31 Scripts for creating the monitor account in the root filesystem, to enable node access 
32 without using the 'root' account.
33
34 %prep
35 %setup -q
36
37 %build
38 echo "There is no build stage.  Simply copy files."
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -D -m 755 monitor.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
43 install -D -m 755 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(-,root,root)
50 %{_initrddir}/monitor
51 %{_sysconfdir}/cron.d/monitor
52
53 %post
54 chkconfig --add monitor
55 chkconfig monitor on
56
57 %changelog
58 * Tue Nov 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-13
59 - Fixed for email change in unified_model.py tweaks in others.
60
61 * Wed Oct 29 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-12
62 - Improvements in web pages, and default installation options, and RT queue
63 - setup.
64 - Send direct emails rather than using tech- & pi- aliases
65
66 * Tue Oct 21 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-11
67 - send direct email, not to tech-* and pi-* aliases.
68
69 * Tue Oct 14 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-10
70 - an update to the latest tag.  looks like I actually needed to update the tags
71 - file more than this.
72
73 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-9
74 - includes all removals of 'monitorconfig'
75
76 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
77 - These are all changes in the latest Monitor code.  I will branch this version
78 - next, before making additional large changes.
79
80 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
81 - Checkpointing current version for 4.2-rc21 - many many changes
82
83 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
84 - This is a major tag of every thing.  probably needs a very different release
85 - number.
86
87 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
88 - Incremental improvements
89
90 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
91 - tagging everything for OneLab tech-transfer.
92
93
94 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
95
96
97 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
98
99
100 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
101 - This should be ready for 4.2rc2
102
103
104 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
105 - initial addition.