39331055910a6ca1fd4229095961ce91a2dfaa5f
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 50
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d NodeManager ] || ln -s nodemanager NodeManager
46 [ -d MyPLC ] || ln -s myplc MyPLC
47
48 pushd PLCAPI
49 # beware that making the pdf file somehow overwrites the html
50 make -C doc PLCAPI.pdf 
51 rm -f doc/PLCAPI.html
52 make -C doc PLCAPI.html 
53 popd
54
55 pushd NodeManager
56 # beware that making the pdf file somehow overwrites the html
57 make -C doc NMAPI.pdf 
58 rm -f doc/NMAPI.html
59 make -C doc NMAPI.html 
60 popd
61
62 %install
63
64 for ext in pdf html; do
65     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
66     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
67 done
68
69 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
70     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
71     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
72 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(-,root,root,-)
81 /var/www/html/planetlab/doc/
82
83 %changelog
84 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
85 - Do not preserve /etc/planetlab on upgrade operations
86
87 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
88 - Remove Monitor references from spec file
89
90 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
91 - Introduce staticroute tagtype
92
93 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
94 - attempt to fix small glitches
95
96 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
97 - enable short_open_tag for backward compatibility
98
99 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
100 - Cherry-pick PHP5 timezone fix form master
101
102 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
103 - pick the greatest version as a kernel
104
105 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
106 - handle directory name changes for myplc-docs package as well
107
108 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
109 - handle directory name changes
110
111 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
112 - Use correct resolv.conf file.
113
114 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
115 - Make dnsmasq usable.
116
117 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
118 - Allow dnsmasq configuration to be extended.
119
120 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
121 - Add DRL slice.
122 - Generalize bootcd-kernel.
123
124 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
125 - support for fedora 12
126 - new package myplc-config for use by sfa
127 - drupal user registration turned off
128
129 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
130 - - fix to make sure when API, BOOT, MONITOR are on the same
131 - machine as WWW that the SSL key,cert for WWW takes precedence.
132 - - Do proper setup for SSL CA certficate to be used as the server
133 - chain.
134
135 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
136 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
137
138 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
139 - depend on pcucontrol
140
141 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
142 - * validate input according to type in plc_config
143 - * added the _genicw system slice
144 - * add tag types for sites and persons
145 - * add new tags for nodes and slices for exemption from myops
146
147 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
148 - turn off drupal on a box that acts as BOOT server but not as WWW server
149 - cleanup some obsolete code for old chroot-jail packaging in the process
150 - new bootcd-kernel script for keeping bootcd variants up2date
151
152 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
153 - Make the /etc/hosts manipulation optional.
154
155 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
156 - Fix SetRole.
157
158 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
159 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
160 - into the DB.
161 - - Added the root ssh key handling support back into plc.d/ssh and the
162 - default xml file.  This should be identical to the way it was in
163 - rc12.
164 - - Added support in the db-config.d/01-init script to register the root
165 - ssh public key with the default administrator.  In this way the root
166 - ssh key will make it into the root account on the nodes by means of
167 - NodeManager's specialaccounts plugin.
168
169 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
170 - db-config ignores sliver tags
171 - sirius's db-config script renamed (was sirious)
172
173 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
174 - fix for silverauth - missing tag types now created at plc startup time
175
176 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
177 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
178
179 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
180 - companion to NM's specialaccounts plugin
181 - do not generate /etc/planetlab/root_ssh_key* anymore
182 - remove related config. variables and conf_files
183
184 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
185 - clarified description text to refer only to plcrt and not other optional
186 - packages.
187
188 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
189 - fixed a bug setting slice multiple attributes with the same tag name
190
191 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
192 - SSL setup for monitor box, and related new config variables
193 - new conf_file for /etc/planetlab/extensions
194 - various tweaks in db-config internals, about initscripts among others
195 - also more messages defined in the db
196
197 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
198 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
199
200 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
201 - bugfix in db-config, tag 4.3-19 would not fly
202
203 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
204 - Refactored db-config into snippets in db-config.d/.
205
206 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
207 - oops, tag 4.3-17 was broken and would not work
208
209 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
210 - bugfix - escape sequences inserted in xml configs
211
212 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
213 - Handle db-config.d files properly.
214
215 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
216 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
217 - than the log file
218 - - Fix db-config to be a bit more cautious when
219 - /etc/planetlab/db-config.d doesn't exist
220 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
221 - .orig files.
222 - - Refactor generic plc-config-tty code into plc_config.py.
223 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
224 - and the list of validated variables and the corresponding
225 - validator() function. This refactoring lets one reuse plc_config.py
226 - as a generic cmdline configuration tool for highly customer MyPLC
227 - like software.
228
229 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
230 - update PCU Type descriptions.
231 - updates to init scripts
232
233 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
234 - requires monitor-pcucontrol so register-wizard can work
235
236 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
237 - cleaned up plc-config-tty, no more need to configure plc-devel
238
239 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
240 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
241
242 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
243 - tighter right permissions on site_admin's authorized keys for more robustness
244
245 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
246 - fix issue in db-config that prevented correct operation
247
248 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
249 - remove support for chroot-based packaging - no crond nor syslog step anymore
250 - plc init script now named plc.init instead of former guest.init
251
252 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
253 - add Monitor to docs build
254
255 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
256 - plc_config.py and plc-config-tty: generalized to work for more diverse
257 - MyPLC configurations.
258 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
259 - deployments and increase the memory limits in php.ini
260 - plc.d/crond: add --full option to vacuumdb
261
262 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
263 - avoid generating ssl certificates for disabled services among www api boot
264
265 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
266 - cleaned up old entries in db-config
267 - mtail more robust
268
269 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
270 - php include path tweaked for plekit includes
271 - reviewed myplc (fka native) packaging dependencies
272 - renumbered 4.3
273
274 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
275 - rename myplc into myplc-chroot and myplc-native into myplc
276 - new settings (shortname & hrn_root) for local peer
277
278 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
279 - First iteration of new data model
280 - Bunch of various fixes
281
282 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
283 - Removed proper ops from planetflow slice.
284
285 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
286 - myplc-native requires myplc-docs
287 - fixed doc build by locating locally installed DTDs at build-time
288
289 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
290 - turn myplc-docs off for now
291
292 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
293 - figures in doc package
294
295 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
296 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
297 - chroot packaging does not have docs anymore
298 - 'cvs' and 'dev' not required from myplc-native anymore
299 - cosmetic change in kml output
300
301
302 %define module_current_branch 4.2