4b186aeb504c965f80b1b3f85fc96fc7e5605d18
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
100 - define open_basedir in php.ini to stop confidentiality leak
101 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
102 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
103 - new utilities check-hrns.py and check-vsys-defaults.py
104
105 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
106 - set TimeoutSec to 300 in plc.service
107 - remove ref to deprecated svn $URL$ in db-config usage
108
109 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
110 - expose mtail.py as simply mtail
111
112 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
113 - plc-kml.py now has support for nodegroups
114
115 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
116 - use nodeimage package instead of deprecated bootstrapfs
117 - has systemd-friendly startup script
118 - plc_reload moved to functions/ - no more service plc reload
119 - no svn keywords anymore
120
121 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
122 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
123
124 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
125 - new settings for myslice (comon&tophat) and monitor (db)
126 - removed mentions of chroot in description
127 - can redo myplc-docs on broken f12-latex
128 - set short_open_tag in php.ini
129 - fixes in gen-sites-xml (is that still used ?)
130 - partial-repo.sh has moved to 'build' where it more belongs
131 - tweaks in convenience tool 'mtail'
132
133 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
134 - fixed changelog, no change from 5.0-16
135
136 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
137 - requires ed for the plc.d/packages step
138 - sirius initscript to handle stop and restart
139
140 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
141 - ignore steps in db-config.d if they have a '.' or '~' in their name
142
143 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
144 - can redo myplc-docs without the doc for monitor
145
146 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
147 - no semantic change - just fixed specfile for git URL
148
149 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
150 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
151
152 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
153 - add missing files to rpm package
154
155 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
156 - mtail.py -s for SFA
157 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
158
159 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
160 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
161
162 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
163 - plc-config-tty now has a validator on booleans
164 - e.g. entering 'True' now is rejected rather than silently recording 'false'
165
166 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
167 - disable mod_wsgi
168
169 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
170 - module name changes
171 - start wsgi support
172
173 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
174 - new setting PLC_RESERVATION_GRANULARITY
175
176 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
177 - * partial-repo.sh script
178 - * preserve key along with certificates
179
180 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
181 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
182
183 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
184 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
185 - new OMF category in the config
186 - create the drl system slice
187
188 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
189 - first working version of 5.0:
190 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
191 - nodefamily is 3-fold with pldistro-fcdistro-arch
192 - new PLC_FLAVOUR config category
193 - reviewed module layout
194 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
195
196 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
197 - support for fedora 12
198 - new package myplc-config for use by sfa
199 - drupal user registration turned off
200
201 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
202 - - fix to make sure when API, BOOT, MONITOR are on the same
203 - machine as WWW that the SSL key,cert for WWW takes precedence.
204 - - Do proper setup for SSL CA certficate to be used as the server
205 - chain.
206
207 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
208 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
209
210 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
211 - depend on pcucontrol
212
213 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
214 - * validate input according to type in plc_config
215 - * added the _genicw system slice
216 - * add tag types for sites and persons
217 - * add new tags for nodes and slices for exemption from myops
218
219 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
220 - turn off drupal on a box that acts as BOOT server but not as WWW server
221 - cleanup some obsolete code for old chroot-jail packaging in the process
222 - new bootcd-kernel script for keeping bootcd variants up2date
223
224 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
225 - Make the /etc/hosts manipulation optional.
226
227 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
228 - Fix SetRole.
229
230 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
231 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
232 - into the DB.
233 - - Added the root ssh key handling support back into plc.d/ssh and the
234 - default xml file.  This should be identical to the way it was in
235 - rc12.
236 - - Added support in the db-config.d/01-init script to register the root
237 - ssh public key with the default administrator.  In this way the root
238 - ssh key will make it into the root account on the nodes by means of
239 - NodeManager's specialaccounts plugin.
240
241 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
242 - db-config ignores sliver tags
243 - sirius's db-config script renamed (was sirious)
244
245 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
246 - fix for silverauth - missing tag types now created at plc startup time
247
248 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
249 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
250
251 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
252 - companion to NM's specialaccounts plugin
253 - do not generate /etc/planetlab/root_ssh_key* anymore
254 - remove related config. variables and conf_files
255
256 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
257 - clarified description text to refer only to plcrt and not other optional
258 - packages.
259
260 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
261 - fixed a bug setting slice multiple attributes with the same tag name
262
263 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
264 - SSL setup for monitor box, and related new config variables
265 - new conf_file for /etc/planetlab/extensions
266 - various tweaks in db-config internals, about initscripts among others
267 - also more messages defined in the db
268
269 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
270 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
271
272 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
273 - bugfix in db-config, tag 4.3-19 would not fly
274
275 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
276 - Refactored db-config into snippets in db-config.d/.
277
278 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
279 - oops, tag 4.3-17 was broken and would not work
280
281 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
282 - bugfix - escape sequences inserted in xml configs
283
284 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
285 - Handle db-config.d files properly.
286
287 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
288 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
289 - than the log file
290 - - Fix db-config to be a bit more cautious when
291 - /etc/planetlab/db-config.d doesn't exist
292 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
293 - .orig files.
294 - - Refactor generic plc-config-tty code into plc_config.py.
295 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
296 - and the list of validated variables and the corresponding
297 - validator() function. This refactoring lets one reuse plc_config.py
298 - as a generic cmdline configuration tool for highly customer MyPLC
299 - like software.
300
301 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
302 - update PCU Type descriptions.
303 - updates to init scripts
304
305 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
306 - requires monitor-pcucontrol so register-wizard can work
307
308 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
309 - cleaned up plc-config-tty, no more need to configure plc-devel
310
311 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
312 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
313
314 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
315 - tighter right permissions on site_admin's authorized keys for more robustness
316
317 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
318 - fix issue in db-config that prevented correct operation
319
320 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
321 - remove support for chroot-based packaging - no crond nor syslog step anymore
322 - plc init script now named plc.init instead of former guest.init
323
324 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
325 - add Monitor to docs build
326
327 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
328 - plc_config.py and plc-config-tty: generalized to work for more diverse
329 - MyPLC configurations.
330 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
331 - deployments and increase the memory limits in php.ini
332 - plc.d/crond: add --full option to vacuumdb
333
334 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
335 - avoid generating ssl certificates for disabled services among www api boot
336
337 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
338 - cleaned up old entries in db-config
339 - mtail more robust
340
341 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
342 - php include path tweaked for plekit includes
343 - reviewed myplc (fka native) packaging dependencies
344 - renumbered 4.3
345
346 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
347 - rename myplc into myplc-chroot and myplc-native into myplc
348 - new settings (shortname & hrn_root) for local peer
349
350 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
351 - First iteration of new data model
352 - Bunch of various fixes
353
354 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
355 - Removed proper ops from planetflow slice.
356
357 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
358 - myplc-native requires myplc-docs
359 - fixed doc build by locating locally installed DTDs at build-time
360
361 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
362 - turn myplc-docs off for now
363
364 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
365 - figures in doc package
366
367 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
368 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
369 - chroot packaging does not have docs anymore
370 - 'cvs' and 'dev' not required from myplc-native anymore
371 - cosmetic change in kml output
372
373
374 %define module_current_branch 4.3