809e54cd96df8861e7da8239eb2c0e1dc9e1f23f
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
100 - takes care of creating plcapi log file
101
102 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
103 - tweaked renew_reminder for federation
104
105 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
106 - tweaks in check-hrns.py
107 - do not require PyXML any more
108
109 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
110 - review check-hrns for plcapi-5.3
111 - add PLC_HRN_ROOT in usual plc-config-tty's settings
112
113 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
114 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
115 - add an rpm-sign dependency on feedora>=16
116
117 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
118 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
119
120 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
121 - plc.d/gpg now does not rm /dev/random but preserves it
122 - this is because libvirt won't let us run mknod
123
124 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
125 - fix typo in check-hrns - used to print 'host' while dealing with persons
126
127 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
128 - supports httpd config for either mod_python (preferred) or mod_wsgi
129 - requires mod_wsgi on f18 only, otherwise mod_python
130 - supports httpd config for apache 2.4 (f18)
131 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
132
133 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
134 - bugfix in check-vsys-defaults.py
135
136 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
137 - define open_basedir in php.ini to stop confidentiality leak
138 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
139 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
140 - new utilities check-hrns.py and check-vsys-defaults.py
141
142 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
143 - set TimeoutSec to 300 in plc.service
144 - remove ref to deprecated svn $URL$ in db-config usage
145
146 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
147 - expose mtail.py as simply mtail
148
149 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
150 - plc-kml.py now has support for nodegroups
151
152 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
153 - use nodeimage package instead of deprecated bootstrapfs
154 - has systemd-friendly startup script
155 - plc_reload moved to functions/ - no more service plc reload
156 - no svn keywords anymore
157
158 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
159 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
160
161 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
162 - new settings for myslice (comon&tophat) and monitor (db)
163 - removed mentions of chroot in description
164 - can redo myplc-docs on broken f12-latex
165 - set short_open_tag in php.ini
166 - fixes in gen-sites-xml (is that still used ?)
167 - partial-repo.sh has moved to 'build' where it more belongs
168 - tweaks in convenience tool 'mtail'
169
170 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
171 - fixed changelog, no change from 5.0-16
172
173 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
174 - requires ed for the plc.d/packages step
175 - sirius initscript to handle stop and restart
176
177 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
178 - ignore steps in db-config.d if they have a '.' or '~' in their name
179
180 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
181 - can redo myplc-docs without the doc for monitor
182
183 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
184 - no semantic change - just fixed specfile for git URL
185
186 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
187 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
188
189 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
190 - add missing files to rpm package
191
192 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
193 - mtail.py -s for SFA
194 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
195
196 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
197 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
198
199 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
200 - plc-config-tty now has a validator on booleans
201 - e.g. entering 'True' now is rejected rather than silently recording 'false'
202
203 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
204 - disable mod_wsgi
205
206 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
207 - module name changes
208 - start wsgi support
209
210 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
211 - new setting PLC_RESERVATION_GRANULARITY
212
213 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
214 - * partial-repo.sh script
215 - * preserve key along with certificates
216
217 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
218 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
219
220 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
221 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
222 - new OMF category in the config
223 - create the drl system slice
224
225 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
226 - first working version of 5.0:
227 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
228 - nodefamily is 3-fold with pldistro-fcdistro-arch
229 - new PLC_FLAVOUR config category
230 - reviewed module layout
231 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
232
233 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
234 - support for fedora 12
235 - new package myplc-config for use by sfa
236 - drupal user registration turned off
237
238 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
239 - - fix to make sure when API, BOOT, MONITOR are on the same
240 - machine as WWW that the SSL key,cert for WWW takes precedence.
241 - - Do proper setup for SSL CA certficate to be used as the server
242 - chain.
243
244 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
245 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
246
247 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
248 - depend on pcucontrol
249
250 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
251 - * validate input according to type in plc_config
252 - * added the _genicw system slice
253 - * add tag types for sites and persons
254 - * add new tags for nodes and slices for exemption from myops
255
256 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
257 - turn off drupal on a box that acts as BOOT server but not as WWW server
258 - cleanup some obsolete code for old chroot-jail packaging in the process
259 - new bootcd-kernel script for keeping bootcd variants up2date
260
261 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
262 - Make the /etc/hosts manipulation optional.
263
264 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
265 - Fix SetRole.
266
267 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
268 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
269 - into the DB.
270 - - Added the root ssh key handling support back into plc.d/ssh and the
271 - default xml file.  This should be identical to the way it was in
272 - rc12.
273 - - Added support in the db-config.d/01-init script to register the root
274 - ssh public key with the default administrator.  In this way the root
275 - ssh key will make it into the root account on the nodes by means of
276 - NodeManager's specialaccounts plugin.
277
278 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
279 - db-config ignores sliver tags
280 - sirius's db-config script renamed (was sirious)
281
282 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
283 - fix for silverauth - missing tag types now created at plc startup time
284
285 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
286 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
287
288 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
289 - companion to NM's specialaccounts plugin
290 - do not generate /etc/planetlab/root_ssh_key* anymore
291 - remove related config. variables and conf_files
292
293 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
294 - clarified description text to refer only to plcrt and not other optional
295 - packages.
296
297 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
298 - fixed a bug setting slice multiple attributes with the same tag name
299
300 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
301 - SSL setup for monitor box, and related new config variables
302 - new conf_file for /etc/planetlab/extensions
303 - various tweaks in db-config internals, about initscripts among others
304 - also more messages defined in the db
305
306 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
307 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
308
309 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
310 - bugfix in db-config, tag 4.3-19 would not fly
311
312 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
313 - Refactored db-config into snippets in db-config.d/.
314
315 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
316 - oops, tag 4.3-17 was broken and would not work
317
318 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
319 - bugfix - escape sequences inserted in xml configs
320
321 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
322 - Handle db-config.d files properly.
323
324 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
325 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
326 - than the log file
327 - - Fix db-config to be a bit more cautious when
328 - /etc/planetlab/db-config.d doesn't exist
329 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
330 - .orig files.
331 - - Refactor generic plc-config-tty code into plc_config.py.
332 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
333 - and the list of validated variables and the corresponding
334 - validator() function. This refactoring lets one reuse plc_config.py
335 - as a generic cmdline configuration tool for highly customer MyPLC
336 - like software.
337
338 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
339 - update PCU Type descriptions.
340 - updates to init scripts
341
342 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
343 - requires monitor-pcucontrol so register-wizard can work
344
345 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
346 - cleaned up plc-config-tty, no more need to configure plc-devel
347
348 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
349 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
350
351 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
352 - tighter right permissions on site_admin's authorized keys for more robustness
353
354 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
355 - fix issue in db-config that prevented correct operation
356
357 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
358 - remove support for chroot-based packaging - no crond nor syslog step anymore
359 - plc init script now named plc.init instead of former guest.init
360
361 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
362 - add Monitor to docs build
363
364 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
365 - plc_config.py and plc-config-tty: generalized to work for more diverse
366 - MyPLC configurations.
367 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
368 - deployments and increase the memory limits in php.ini
369 - plc.d/crond: add --full option to vacuumdb
370
371 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
372 - avoid generating ssl certificates for disabled services among www api boot
373
374 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
375 - cleaned up old entries in db-config
376 - mtail more robust
377
378 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
379 - php include path tweaked for plekit includes
380 - reviewed myplc (fka native) packaging dependencies
381 - renumbered 4.3
382
383 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
384 - rename myplc into myplc-chroot and myplc-native into myplc
385 - new settings (shortname & hrn_root) for local peer
386
387 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
388 - First iteration of new data model
389 - Bunch of various fixes
390
391 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
392 - Removed proper ops from planetflow slice.
393
394 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
395 - myplc-native requires myplc-docs
396 - fixed doc build by locating locally installed DTDs at build-time
397
398 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
399 - turn myplc-docs off for now
400
401 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
402 - figures in doc package
403
404 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
405 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
406 - chroot packaging does not have docs anymore
407 - 'cvs' and 'dev' not required from myplc-native anymore
408 - cosmetic change in kml output
409
410
411 %define module_current_branch 4.3