d9444f734a8791b3ad60a80e85e13b89bac85081
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 47
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d Monitor ] || ln -s monitor Monitor
46 [ -d NodeManager ] || ln -s nodemanager NodeManager
47 [ -d MyPLC ] || ln -s myplc MyPLC
48
49 pushd PLCAPI
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd NodeManager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd Monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
97 - attempt to fix small glitches
98
99 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
100 - enable short_open_tag for backward compatibility
101
102 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
103 - Cherry-pick PHP5 timezone fix form master
104
105 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
106 - pick the greatest version as a kernel
107
108 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
109 - handle directory name changes for myplc-docs package as well
110
111 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
112 - handle directory name changes
113
114 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
115 - Use correct resolv.conf file.
116
117 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
118 - Make dnsmasq usable.
119
120 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
121 - Allow dnsmasq configuration to be extended.
122
123 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
124 - Add DRL slice.
125 - Generalize bootcd-kernel.
126
127 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
128 - support for fedora 12
129 - new package myplc-config for use by sfa
130 - drupal user registration turned off
131
132 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
133 - - fix to make sure when API, BOOT, MONITOR are on the same
134 - machine as WWW that the SSL key,cert for WWW takes precedence.
135 - - Do proper setup for SSL CA certficate to be used as the server
136 - chain.
137
138 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
139 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
140
141 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
142 - depend on pcucontrol
143
144 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
145 - * validate input according to type in plc_config
146 - * added the _genicw system slice
147 - * add tag types for sites and persons
148 - * add new tags for nodes and slices for exemption from myops
149
150 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
151 - turn off drupal on a box that acts as BOOT server but not as WWW server
152 - cleanup some obsolete code for old chroot-jail packaging in the process
153 - new bootcd-kernel script for keeping bootcd variants up2date
154
155 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
156 - Make the /etc/hosts manipulation optional.
157
158 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
159 - Fix SetRole.
160
161 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
162 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
163 - into the DB.
164 - - Added the root ssh key handling support back into plc.d/ssh and the
165 - default xml file.  This should be identical to the way it was in
166 - rc12.
167 - - Added support in the db-config.d/01-init script to register the root
168 - ssh public key with the default administrator.  In this way the root
169 - ssh key will make it into the root account on the nodes by means of
170 - NodeManager's specialaccounts plugin.
171
172 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
173 - db-config ignores sliver tags
174 - sirius's db-config script renamed (was sirious)
175
176 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
177 - fix for silverauth - missing tag types now created at plc startup time
178
179 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
180 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
181
182 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
183 - companion to NM's specialaccounts plugin
184 - do not generate /etc/planetlab/root_ssh_key* anymore
185 - remove related config. variables and conf_files
186
187 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
188 - clarified description text to refer only to plcrt and not other optional
189 - packages.
190
191 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
192 - fixed a bug setting slice multiple attributes with the same tag name
193
194 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
195 - SSL setup for monitor box, and related new config variables
196 - new conf_file for /etc/planetlab/extensions
197 - various tweaks in db-config internals, about initscripts among others
198 - also more messages defined in the db
199
200 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
201 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
202
203 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
204 - bugfix in db-config, tag 4.3-19 would not fly
205
206 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
207 - Refactored db-config into snippets in db-config.d/.
208
209 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
210 - oops, tag 4.3-17 was broken and would not work
211
212 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
213 - bugfix - escape sequences inserted in xml configs
214
215 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
216 - Handle db-config.d files properly.
217
218 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
219 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
220 - than the log file
221 - - Fix db-config to be a bit more cautious when
222 - /etc/planetlab/db-config.d doesn't exist
223 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
224 - .orig files.
225 - - Refactor generic plc-config-tty code into plc_config.py.
226 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
227 - and the list of validated variables and the corresponding
228 - validator() function. This refactoring lets one reuse plc_config.py
229 - as a generic cmdline configuration tool for highly customer MyPLC
230 - like software.
231
232 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
233 - update PCU Type descriptions.
234 - updates to init scripts
235
236 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
237 - requires monitor-pcucontrol so register-wizard can work
238
239 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
240 - cleaned up plc-config-tty, no more need to configure plc-devel
241
242 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
243 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
244
245 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
246 - tighter right permissions on site_admin's authorized keys for more robustness
247
248 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
249 - fix issue in db-config that prevented correct operation
250
251 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
252 - remove support for chroot-based packaging - no crond nor syslog step anymore
253 - plc init script now named plc.init instead of former guest.init
254
255 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
256 - add Monitor to docs build
257
258 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
259 - plc_config.py and plc-config-tty: generalized to work for more diverse
260 - MyPLC configurations.
261 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
262 - deployments and increase the memory limits in php.ini
263 - plc.d/crond: add --full option to vacuumdb
264
265 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
266 - avoid generating ssl certificates for disabled services among www api boot
267
268 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
269 - cleaned up old entries in db-config
270 - mtail more robust
271
272 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
273 - php include path tweaked for plekit includes
274 - reviewed myplc (fka native) packaging dependencies
275 - renumbered 4.3
276
277 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
278 - rename myplc into myplc-chroot and myplc-native into myplc
279 - new settings (shortname & hrn_root) for local peer
280
281 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
282 - First iteration of new data model
283 - Bunch of various fixes
284
285 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
286 - Removed proper ops from planetflow slice.
287
288 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
289 - myplc-native requires myplc-docs
290 - fixed doc build by locating locally installed DTDs at build-time
291
292 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
293 - turn myplc-docs off for now
294
295 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
296 - figures in doc package
297
298 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
299 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
300 - chroot packaging does not have docs anymore
301 - 'cvs' and 'dev' not required from myplc-native anymore
302 - cosmetic change in kml output
303
304
305 %define module_current_branch 4.2