e4c24c7164889f6c1264709143b3d9b5cf006e10
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
91 - first working version of 5.0:
92 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
93 - nodefamily is 3-fold with pldistro-fcdistro-arch
94 - new PLC_FLAVOUR config category
95 - reviewed module layout
96 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
97
98 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
99 - support for fedora 12
100 - new package myplc-config for use by sfa
101 - drupal user registration turned off
102
103 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
104 - - fix to make sure when API, BOOT, MONITOR are on the same
105 - machine as WWW that the SSL key,cert for WWW takes precedence.
106 - - Do proper setup for SSL CA certficate to be used as the server
107 - chain.
108
109 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
110 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
111
112 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
113 - depend on pcucontrol
114
115 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
116 - * validate input according to type in plc_config
117 - * added the _genicw system slice
118 - * add tag types for sites and persons
119 - * add new tags for nodes and slices for exemption from myops
120
121 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
122 - turn off drupal on a box that acts as BOOT server but not as WWW server
123 - cleanup some obsolete code for old chroot-jail packaging in the process
124 - new bootcd-kernel script for keeping bootcd variants up2date
125
126 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
127 - Make the /etc/hosts manipulation optional.
128
129 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
130 - Fix SetRole.
131
132 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
133 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
134 - into the DB.
135 - - Added the root ssh key handling support back into plc.d/ssh and the
136 - default xml file.  This should be identical to the way it was in
137 - rc12.
138 - - Added support in the db-config.d/01-init script to register the root
139 - ssh public key with the default administrator.  In this way the root
140 - ssh key will make it into the root account on the nodes by means of
141 - NodeManager's specialaccounts plugin.
142
143 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
144 - db-config ignores sliver tags
145 - sirius's db-config script renamed (was sirious)
146
147 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
148 - fix for silverauth - missing tag types now created at plc startup time
149
150 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
151 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
152
153 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
154 - companion to NM's specialaccounts plugin
155 - do not generate /etc/planetlab/root_ssh_key* anymore
156 - remove related config. variables and conf_files
157
158 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
159 - clarified description text to refer only to plcrt and not other optional
160 - packages.
161
162 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
163 - fixed a bug setting slice multiple attributes with the same tag name
164
165 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
166 - SSL setup for monitor box, and related new config variables
167 - new conf_file for /etc/planetlab/extensions
168 - various tweaks in db-config internals, about initscripts among others
169 - also more messages defined in the db
170
171 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
172 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
173
174 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
175 - bugfix in db-config, tag 4.3-19 would not fly
176
177 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
178 - Refactored db-config into snippets in db-config.d/.
179
180 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
181 - oops, tag 4.3-17 was broken and would not work
182
183 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
184 - bugfix - escape sequences inserted in xml configs
185
186 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
187 - Handle db-config.d files properly.
188
189 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
190 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
191 - than the log file
192 - - Fix db-config to be a bit more cautious when
193 - /etc/planetlab/db-config.d doesn't exist
194 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
195 - .orig files.
196 - - Refactor generic plc-config-tty code into plc_config.py.
197 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
198 - and the list of validated variables and the corresponding
199 - validator() function. This refactoring lets one reuse plc_config.py
200 - as a generic cmdline configuration tool for highly customer MyPLC
201 - like software.
202
203 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
204 - update PCU Type descriptions.
205 - updates to init scripts
206
207 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
208 - requires monitor-pcucontrol so register-wizard can work
209
210 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
211 - cleaned up plc-config-tty, no more need to configure plc-devel
212
213 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
214 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
215
216 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
217 - tighter right permissions on site_admin's authorized keys for more robustness
218
219 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
220 - fix issue in db-config that prevented correct operation
221
222 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
223 - remove support for chroot-based packaging - no crond nor syslog step anymore
224 - plc init script now named plc.init instead of former guest.init
225
226 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
227 - add Monitor to docs build
228
229 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
230 - plc_config.py and plc-config-tty: generalized to work for more diverse
231 - MyPLC configurations.
232 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
233 - deployments and increase the memory limits in php.ini
234 - plc.d/crond: add --full option to vacuumdb
235
236 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
237 - avoid generating ssl certificates for disabled services among www api boot
238
239 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
240 - cleaned up old entries in db-config
241 - mtail more robust
242
243 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
244 - php include path tweaked for plekit includes
245 - reviewed myplc (fka native) packaging dependencies
246 - renumbered 4.3
247
248 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
249 - rename myplc into myplc-chroot and myplc-native into myplc
250 - new settings (shortname & hrn_root) for local peer
251
252 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
253 - First iteration of new data model
254 - Bunch of various fixes
255
256 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
257 - Removed proper ops from planetflow slice.
258
259 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
260 - myplc-native requires myplc-docs
261 - fixed doc build by locating locally installed DTDs at build-time
262
263 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
264 - turn myplc-docs off for now
265
266 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
267 - figures in doc package
268
269 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
270 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
271 - chroot packaging does not have docs anymore
272 - 'cvs' and 'dev' not required from myplc-native anymore
273 - cosmetic change in kml output
274
275
276 %define module_current_branch 4.3