5455537713267e79bc60738830841ba96e11ae76
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 46
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
61 - enable short_open_tag for backward compatibility
62
63 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
64 - Cherry-pick PHP5 timezone fix form master
65
66 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
67 - pick the greatest version as a kernel
68
69 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
70 - handle directory name changes for myplc-docs package as well
71
72 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
73 - handle directory name changes
74
75 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
76 - Use correct resolv.conf file.
77
78 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
79 - Make dnsmasq usable.
80
81 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
82 - Allow dnsmasq configuration to be extended.
83
84 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
85 - Add DRL slice.
86 - Generalize bootcd-kernel.
87
88 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
89 - support for fedora 12
90 - new package myplc-config for use by sfa
91 - drupal user registration turned off
92
93 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
94 - - fix to make sure when API, BOOT, MONITOR are on the same
95 - machine as WWW that the SSL key,cert for WWW takes precedence.
96 - - Do proper setup for SSL CA certficate to be used as the server
97 - chain.
98
99 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
100 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
101
102 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
103 - depend on pcucontrol
104
105 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
106 - * validate input according to type in plc_config
107 - * added the _genicw system slice
108 - * add tag types for sites and persons
109 - * add new tags for nodes and slices for exemption from myops
110
111 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
112 - turn off drupal on a box that acts as BOOT server but not as WWW server
113 - cleanup some obsolete code for old chroot-jail packaging in the process
114 - new bootcd-kernel script for keeping bootcd variants up2date
115
116 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
117 - Make the /etc/hosts manipulation optional.
118
119 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
120 - Fix SetRole.
121
122 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
123 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
124 - into the DB.
125 - - Added the root ssh key handling support back into plc.d/ssh and the
126 - default xml file.  This should be identical to the way it was in
127 - rc12.
128 - - Added support in the db-config.d/01-init script to register the root
129 - ssh public key with the default administrator.  In this way the root
130 - ssh key will make it into the root account on the nodes by means of
131 - NodeManager's specialaccounts plugin.
132
133 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
134 - db-config ignores sliver tags
135 - sirius's db-config script renamed (was sirious)
136
137 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
138 - fix for silverauth - missing tag types now created at plc startup time
139
140 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
141 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
142
143 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
144 - companion to NM's specialaccounts plugin
145 - do not generate /etc/planetlab/root_ssh_key* anymore
146 - remove related config. variables and conf_files
147
148 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
149 - clarified description text to refer only to plcrt and not other optional
150 - packages.
151
152 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
153 - fixed a bug setting slice multiple attributes with the same tag name
154
155 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
156 - SSL setup for monitor box, and related new config variables
157 - new conf_file for /etc/planetlab/extensions
158 - various tweaks in db-config internals, about initscripts among others
159 - also more messages defined in the db
160
161 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
162 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
163
164 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
165 - bugfix in db-config, tag 4.3-19 would not fly
166
167 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
168 - Refactored db-config into snippets in db-config.d/.
169
170 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
171 - oops, tag 4.3-17 was broken and would not work
172
173 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
174 - bugfix - escape sequences inserted in xml configs
175
176 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
177 - Handle db-config.d files properly.
178
179 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
180 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
181 - than the log file
182 - - Fix db-config to be a bit more cautious when
183 - /etc/planetlab/db-config.d doesn't exist
184 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
185 - .orig files.
186 - - Refactor generic plc-config-tty code into plc_config.py.
187 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
188 - and the list of validated variables and the corresponding
189 - validator() function. This refactoring lets one reuse plc_config.py
190 - as a generic cmdline configuration tool for highly customer MyPLC
191 - like software.
192
193 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
194 - update PCU Type descriptions.
195 - updates to init scripts
196
197 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
198 - requires monitor-pcucontrol so register-wizard can work
199
200 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
201 - cleaned up plc-config-tty, no more need to configure plc-devel
202
203 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
204 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
205
206 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
207 - tighter right permissions on site_admin's authorized keys for more robustness
208
209 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
210 - fix issue in db-config that prevented correct operation
211
212 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
213 - remove support for chroot-based packaging - no crond nor syslog step anymore
214 - plc init script now named plc.init instead of former guest.init
215
216 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
217 - add Monitor to docs build
218
219 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
220 - plc_config.py and plc-config-tty: generalized to work for more diverse
221 - MyPLC configurations.
222 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
223 - deployments and increase the memory limits in php.ini
224 - plc.d/crond: add --full option to vacuumdb
225
226 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
227 - avoid generating ssl certificates for disabled services among www api boot
228
229 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
230 - cleaned up old entries in db-config
231 - mtail more robust
232
233 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
234 - php include path tweaked for plekit includes
235 - reviewed myplc (fka native) packaging dependencies
236 - renumbered 4.3
237
238 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
239 - rename myplc into myplc-chroot and myplc-native into myplc
240 - new settings (shortname & hrn_root) for local peer
241