c49356d7ffa73b07884eb01015c804e90ebd1e1e
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 38
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
61 - Add DRL slice.
62 - Generalize bootcd-kernel.
63
64 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
65 - support for fedora 12
66 - new package myplc-config for use by sfa
67 - drupal user registration turned off
68
69 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
70 - - fix to make sure when API, BOOT, MONITOR are on the same
71 - machine as WWW that the SSL key,cert for WWW takes precedence.
72 - - Do proper setup for SSL CA certficate to be used as the server
73 - chain.
74
75 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
76 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
77
78 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
79 - depend on pcucontrol
80
81 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
82 - * validate input according to type in plc_config
83 - * added the _genicw system slice
84 - * add tag types for sites and persons
85 - * add new tags for nodes and slices for exemption from myops
86
87 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
88 - turn off drupal on a box that acts as BOOT server but not as WWW server
89 - cleanup some obsolete code for old chroot-jail packaging in the process
90 - new bootcd-kernel script for keeping bootcd variants up2date
91
92 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
93 - Make the /etc/hosts manipulation optional.
94
95 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
96 - Fix SetRole.
97
98 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
99 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
100 - into the DB.
101 - - Added the root ssh key handling support back into plc.d/ssh and the
102 - default xml file.  This should be identical to the way it was in
103 - rc12.
104 - - Added support in the db-config.d/01-init script to register the root
105 - ssh public key with the default administrator.  In this way the root
106 - ssh key will make it into the root account on the nodes by means of
107 - NodeManager's specialaccounts plugin.
108
109 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
110 - db-config ignores sliver tags
111 - sirius's db-config script renamed (was sirious)
112
113 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
114 - fix for silverauth - missing tag types now created at plc startup time
115
116 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
117 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
118
119 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
120 - companion to NM's specialaccounts plugin
121 - do not generate /etc/planetlab/root_ssh_key* anymore
122 - remove related config. variables and conf_files
123
124 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
125 - clarified description text to refer only to plcrt and not other optional
126 - packages.
127
128 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
129 - fixed a bug setting slice multiple attributes with the same tag name
130
131 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
132 - SSL setup for monitor box, and related new config variables
133 - new conf_file for /etc/planetlab/extensions
134 - various tweaks in db-config internals, about initscripts among others
135 - also more messages defined in the db
136
137 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
138 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
139
140 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
141 - bugfix in db-config, tag 4.3-19 would not fly
142
143 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
144 - Refactored db-config into snippets in db-config.d/.
145
146 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
147 - oops, tag 4.3-17 was broken and would not work
148
149 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
150 - bugfix - escape sequences inserted in xml configs
151
152 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
153 - Handle db-config.d files properly.
154
155 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
156 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
157 - than the log file
158 - - Fix db-config to be a bit more cautious when
159 - /etc/planetlab/db-config.d doesn't exist
160 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
161 - .orig files.
162 - - Refactor generic plc-config-tty code into plc_config.py.
163 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
164 - and the list of validated variables and the corresponding
165 - validator() function. This refactoring lets one reuse plc_config.py
166 - as a generic cmdline configuration tool for highly customer MyPLC
167 - like software.
168
169 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
170 - update PCU Type descriptions.
171 - updates to init scripts
172
173 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
174 - requires monitor-pcucontrol so register-wizard can work
175
176 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
177 - cleaned up plc-config-tty, no more need to configure plc-devel
178
179 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
180 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
181
182 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
183 - tighter right permissions on site_admin's authorized keys for more robustness
184
185 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
186 - fix issue in db-config that prevented correct operation
187
188 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
189 - remove support for chroot-based packaging - no crond nor syslog step anymore
190 - plc init script now named plc.init instead of former guest.init
191
192 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
193 - add Monitor to docs build
194
195 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
196 - plc_config.py and plc-config-tty: generalized to work for more diverse
197 - MyPLC configurations.
198 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
199 - deployments and increase the memory limits in php.ini
200 - plc.d/crond: add --full option to vacuumdb
201
202 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
203 - avoid generating ssl certificates for disabled services among www api boot
204
205 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
206 - cleaned up old entries in db-config
207 - mtail more robust
208
209 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
210 - php include path tweaked for plekit includes
211 - reviewed myplc (fka native) packaging dependencies
212 - renumbered 4.3
213
214 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
215 - rename myplc into myplc-chroot and myplc-native into myplc
216 - new settings (shortname & hrn_root) for local peer
217