e934d2b8b9f950515db6da7b944f5b763ada39ee
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 52
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
61 - use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
62
63 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
64 - generate plc_config.rb via plc-config
65
66 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
67 - Do not preserve /etc/planetlab on upgrade operations
68
69 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
70 - Remove Monitor references from spec file
71
72 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
73 - Introduce staticroute tagtype
74
75 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
76 - attempt to fix small glitches
77
78 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
79 - enable short_open_tag for backward compatibility
80
81 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
82 - Cherry-pick PHP5 timezone fix form master
83
84 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
85 - pick the greatest version as a kernel
86
87 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
88 - handle directory name changes for myplc-docs package as well
89
90 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
91 - handle directory name changes
92
93 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
94 - Use correct resolv.conf file.
95
96 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
97 - Make dnsmasq usable.
98
99 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
100 - Allow dnsmasq configuration to be extended.
101
102 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
103 - Add DRL slice.
104 - Generalize bootcd-kernel.
105
106 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
107 - support for fedora 12
108 - new package myplc-config for use by sfa
109 - drupal user registration turned off
110
111 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
112 - - fix to make sure when API, BOOT, MONITOR are on the same
113 - machine as WWW that the SSL key,cert for WWW takes precedence.
114 - - Do proper setup for SSL CA certficate to be used as the server
115 - chain.
116
117 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
118 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
119
120 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
121 - depend on pcucontrol
122
123 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
124 - * validate input according to type in plc_config
125 - * added the _genicw system slice
126 - * add tag types for sites and persons
127 - * add new tags for nodes and slices for exemption from myops
128
129 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
130 - turn off drupal on a box that acts as BOOT server but not as WWW server
131 - cleanup some obsolete code for old chroot-jail packaging in the process
132 - new bootcd-kernel script for keeping bootcd variants up2date
133
134 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
135 - Make the /etc/hosts manipulation optional.
136
137 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
138 - Fix SetRole.
139
140 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
141 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
142 - into the DB.
143 - - Added the root ssh key handling support back into plc.d/ssh and the
144 - default xml file.  This should be identical to the way it was in
145 - rc12.
146 - - Added support in the db-config.d/01-init script to register the root
147 - ssh public key with the default administrator.  In this way the root
148 - ssh key will make it into the root account on the nodes by means of
149 - NodeManager's specialaccounts plugin.
150
151 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
152 - db-config ignores sliver tags
153 - sirius's db-config script renamed (was sirious)
154
155 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
156 - fix for silverauth - missing tag types now created at plc startup time
157
158 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
159 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
160
161 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
162 - companion to NM's specialaccounts plugin
163 - do not generate /etc/planetlab/root_ssh_key* anymore
164 - remove related config. variables and conf_files
165
166 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
167 - clarified description text to refer only to plcrt and not other optional
168 - packages.
169
170 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
171 - fixed a bug setting slice multiple attributes with the same tag name
172
173 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
174 - SSL setup for monitor box, and related new config variables
175 - new conf_file for /etc/planetlab/extensions
176 - various tweaks in db-config internals, about initscripts among others
177 - also more messages defined in the db
178
179 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
180 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
181
182 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
183 - bugfix in db-config, tag 4.3-19 would not fly
184
185 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
186 - Refactored db-config into snippets in db-config.d/.
187
188 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
189 - oops, tag 4.3-17 was broken and would not work
190
191 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
192 - bugfix - escape sequences inserted in xml configs
193
194 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
195 - Handle db-config.d files properly.
196
197 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
198 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
199 - than the log file
200 - - Fix db-config to be a bit more cautious when
201 - /etc/planetlab/db-config.d doesn't exist
202 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
203 - .orig files.
204 - - Refactor generic plc-config-tty code into plc_config.py.
205 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
206 - and the list of validated variables and the corresponding
207 - validator() function. This refactoring lets one reuse plc_config.py
208 - as a generic cmdline configuration tool for highly customer MyPLC
209 - like software.
210
211 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
212 - update PCU Type descriptions.
213 - updates to init scripts
214
215 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
216 - requires monitor-pcucontrol so register-wizard can work
217
218 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
219 - cleaned up plc-config-tty, no more need to configure plc-devel
220
221 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
222 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
223
224 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
225 - tighter right permissions on site_admin's authorized keys for more robustness
226
227 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
228 - fix issue in db-config that prevented correct operation
229
230 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
231 - remove support for chroot-based packaging - no crond nor syslog step anymore
232 - plc init script now named plc.init instead of former guest.init
233
234 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
235 - add Monitor to docs build
236
237 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
238 - plc_config.py and plc-config-tty: generalized to work for more diverse
239 - MyPLC configurations.
240 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
241 - deployments and increase the memory limits in php.ini
242 - plc.d/crond: add --full option to vacuumdb
243
244 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
245 - avoid generating ssl certificates for disabled services among www api boot
246
247 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
248 - cleaned up old entries in db-config
249 - mtail more robust
250
251 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
252 - php include path tweaked for plekit includes
253 - reviewed myplc (fka native) packaging dependencies
254 - renumbered 4.3
255
256 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
257 - rename myplc into myplc-chroot and myplc-native into myplc
258 - new settings (shortname & hrn_root) for local peer
259