28066237a78eb1ac5d515b5ebcae0a7486f0fd81
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 #Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 Requires: cronie
56 # starting with f16 we depend on this new rpm
57 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
58 Requires: rpm-sign
59 %endif
60 # starting with f27 we depend on this new rpm
61 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
62 Requires: php-fpm
63 %endif
64
65 # planetlab stuff
66 Requires: bootmanager
67 Requires: bootcd-%{nodefamily}
68 Requires: bootcd-initscripts
69 Requires: PLCWWW
70 Requires: www-register-wizard
71 Requires: nodeconfig
72 Requires: nodeyum
73 Requires: plcapi >= 5.2
74 # this technically is a plcapi dependency but it's simpler here for chosing which
75 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
76 Requires: mod_wsgi
77 %else
78 Requires: mod_python
79 %endif
80 Requires: nodeimage-%{nodefamily}
81 Requires: myplc-docs
82 Requires: myplc-release
83 Requires: myplc-config
84
85 %define debug_package %{nil}
86
87 %description 
88 MyPLC is a complete PlanetLab Central (PLC) portable installation.
89 The default installation consists of a web server, an XML-RPC API
90 server, a boot server, and a database server: the core components of
91 PLC. The installation may be customized through a graphical
92 interface. All PLC services are started up and shut down through a
93 single System V init script.
94
95 ####################### myplc-config
96
97 %package config
98
99 Summary: PlanetLab Central (PLC) configuration python module
100 Group: Applications/Systems
101 Requires: python
102
103 %description config
104 This package provides the Python module to configure MyPLC.
105
106
107 %prep
108 %setup -q
109
110 %build
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 # Install configuration scripts
116 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
117 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
118 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
119
120 echo "* Installing scripts in /usr/bin"
121 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
122 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
123 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
124 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
125
126 # Install initscript 
127 echo "* Installing plc initscript"
128 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
129 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
130
131 # Install initscripts
132 echo "* Installing plc.d initscripts"
133 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
134 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
135
136 # Install db-config.d files
137 echo "* Installing db-config.d files"
138 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
139 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
140 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
141
142 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
143 echo "* Installing scripts in /etc/support-scripts"
144 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
145 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
146 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
147
148 # copy initscripts to etc/plc_sliceinitscripts
149 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
150 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
151 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
152
153 # Install configuration file
154 echo "* myplc: Installing configuration file"
155 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
156 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
157     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
158 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
159
160 echo "* Installing bashrc convenience"
161 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
162
163 # yumgroups.xml and yum repo : let noderepo handle that
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %pre
169 if [ -x %{_sysconfdir}/init.d/plc ] ; then
170     %{_sysconfdir}/init.d/plc stop
171 fi
172
173 # Old versions of myplc used to ship with a bootstrapped database and
174 # /etc/planetlab directory. Including generated files in the manifest
175 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
176 # names from one RPM build to another, it would be rpmsaved and thus
177 # effectively deleted. Now we do not include these files in the
178 # manifest. However, to avoid deleting these files in the process of
179 # upgrading from one of these old versions of myplc, we must back up
180 # the database and /etc/planetlab and restore them after the old
181 # version has been uninstalled in %triggerpostun (also in %post, in
182 # case we are force upgrading to the same version).
183 #
184 # This code can be removed once all myplc-0.4-1 installations have
185 # been upgraded to at least myplc-0.4-2.
186
187 # 0 = install, 1 = upgrade
188 if [ $1 -gt 0 ] ; then
189     for dir in /var/lib/pgsql/data /etc/planetlab ; do
190         if [ -d $dir ] ; then
191             echo "Preserving $dir"
192             mkdir -p $dir.rpmsave
193             tar -C $dir -cpf - . | \
194                tar -C $dir.rpmsave -xpf -
195
196             # Except for the default configuration file and DTD, which
197             # really should be considered for upgrade.
198             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
199         fi
200     done
201 fi
202
203 %post
204 if [ -x /sbin/chkconfig ] ; then
205     /sbin/chkconfig --add plc
206     /sbin/chkconfig plc on
207 fi
208
209 %if "%{distro}" == "Fedora" && %{distrorelease} >= 27
210 systemctl enable php-fpm
211 systemctl start  php-fpm
212 %endif
213
214 %triggerpostun -- %{name}
215 # 0 = erase, 1 = upgrade
216 if [ $1 -gt 0 ] ; then
217     for dir in /var/lib/pgsql/data /etc/planetlab ; do
218         if [ -d $dir.rpmsave -a -d $dir ] ; then
219             echo "Merging $dir"
220             if tar -C $dir.rpmsave -cpf - . | \
221                tar -C $dir -xpf - ; then
222                 rm -rf $dir.rpmsave
223             fi
224         fi
225     done
226 fi    
227
228 %preun
229 # 0 = erase, 1 = upgrade
230 if [ $1 -eq 0 ] ; then
231     %{_sysconfdir}/init.d/plc stop
232     if [ -x /sbin/chkconfig ] ; then
233         /sbin/chkconfig plc off
234         /sbin/chkconfig --del plc
235     fi
236 fi
237
238 %files
239 %defattr(-,root,root,-)
240 # Host startup script and configuration file
241 /etc/init.d/plc
242 /etc/plc.d
243 /etc/planetlab
244 /etc/plc_sliceinitscripts
245 /etc/support-scripts
246 /usr/share/myplc/bashrc
247 # keep a detailed list, to avoid duplicate of plc-config,
248 # that belongs to the myplc-config rpm
249 /usr/bin/plc-config-tty
250 /usr/bin/db-config
251 /usr/bin/dns-config
252 /usr/bin/refresh-peer.py*
253 /usr/bin/mtail.py*
254 /usr/bin/mtail
255 /usr/bin/plc-map.py*
256 /usr/bin/plc-kml.py*
257 /usr/bin/clean-empty-dirs.py*
258 /usr/bin/plc-check-ssl-peering.py*
259 /usr/bin/plc-orphan-accounts.py*
260 /usr/bin/spot-aliens.py*
261 /usr/bin/check-hrns.py*
262 /usr/bin/check-vsys-defaults.py*
263 /usr/bin/spot-dup-accounts.sh
264 /lib/systemd/system/plc.service
265
266 %files config
267 %defattr(-,root,root,-)
268 /usr/bin/plc-config
269 %{python_sitearch}/plc_config.py*
270
271
272 %changelog
273 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
274 - takes care of creating plcapi log file
275
276 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
277 - tweaked renew_reminder for federation
278
279 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
280 - tweaks in check-hrns.py
281 - do not require PyXML any more
282
283 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
284 - review check-hrns for plcapi-5.3
285 - add PLC_HRN_ROOT in usual plc-config-tty's settings
286
287 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
288 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
289 - add an rpm-sign dependency on feedora>=16
290
291 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
292 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
293
294 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
295 - plc.d/gpg now does not rm /dev/random but preserves it
296 - this is because libvirt won't let us run mknod
297
298 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
299 - fix typo in check-hrns - used to print 'host' while dealing with persons
300
301 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
302 - supports httpd config for either mod_python (preferred) or mod_wsgi
303 - requires mod_wsgi on f18 only, otherwise mod_python
304 - supports httpd config for apache 2.4 (f18)
305 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
306
307 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
308 - bugfix in check-vsys-defaults.py
309
310 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
311 - define open_basedir in php.ini to stop confidentiality leak
312 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
313 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
314 - new utilities check-hrns.py and check-vsys-defaults.py
315
316 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
317 - set TimeoutSec to 300 in plc.service
318 - remove ref to deprecated svn $URL$ in db-config usage
319
320 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
321 - expose mtail.py as simply mtail
322
323 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
324 - plc-kml.py now has support for nodegroups
325
326 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
327 - use nodeimage package instead of deprecated bootstrapfs
328 - has systemd-friendly startup script
329 - plc_reload moved to functions/ - no more service plc reload
330 - no svn keywords anymore
331
332 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
333 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
334
335 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
336 - new settings for myslice (comon&tophat) and monitor (db)
337 - removed mentions of chroot in description
338 - can redo myplc-docs on broken f12-latex
339 - set short_open_tag in php.ini
340 - fixes in gen-sites-xml (is that still used ?)
341 - partial-repo.sh has moved to 'build' where it more belongs
342 - tweaks in convenience tool 'mtail'
343
344 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
345 - fixed changelog, no change from 5.0-16
346
347 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
348 - requires ed for the plc.d/packages step
349 - sirius initscript to handle stop and restart
350
351 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
352 - ignore steps in db-config.d if they have a '.' or '~' in their name
353
354 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
355 - can redo myplc-docs without the doc for monitor
356
357 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
358 - no semantic change - just fixed specfile for git URL
359
360 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
361 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
362
363 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
364 - add missing files to rpm package
365
366 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
367 - mtail.py -s for SFA
368 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
369
370 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
371 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
372
373 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
374 - plc-config-tty now has a validator on booleans
375 - e.g. entering 'True' now is rejected rather than silently recording 'false'
376
377 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
378 - disable mod_wsgi
379
380 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
381 - module name changes
382 - start wsgi support
383
384 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
385 - new setting PLC_RESERVATION_GRANULARITY
386
387 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
388 - * partial-repo.sh script
389 - * preserve key along with certificates
390
391 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
392 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
393
394 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
395 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
396 - new OMF category in the config
397 - create the drl system slice
398
399 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
400 - first working version of 5.0:
401 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
402 - nodefamily is 3-fold with pldistro-fcdistro-arch
403 - new PLC_FLAVOUR config category
404 - reviewed module layout
405 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
406
407 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
408 - support for fedora 12
409 - new package myplc-config for use by sfa
410 - drupal user registration turned off
411
412 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
413 - - fix to make sure when API, BOOT, MONITOR are on the same
414 - machine as WWW that the SSL key,cert for WWW takes precedence.
415 - - Do proper setup for SSL CA certficate to be used as the server
416 - chain.
417
418 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
419 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
420
421 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
422 - depend on pcucontrol
423
424 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
425 - * validate input according to type in plc_config
426 - * added the _genicw system slice
427 - * add tag types for sites and persons
428 - * add new tags for nodes and slices for exemption from myops
429
430 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
431 - turn off drupal on a box that acts as BOOT server but not as WWW server
432 - cleanup some obsolete code for old chroot-jail packaging in the process
433 - new bootcd-kernel script for keeping bootcd variants up2date
434
435 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
436 - Make the /etc/hosts manipulation optional.
437
438 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
439 - Fix SetRole.
440
441 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
442 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
443 - into the DB.
444 - - Added the root ssh key handling support back into plc.d/ssh and the
445 - default xml file.  This should be identical to the way it was in
446 - rc12.
447 - - Added support in the db-config.d/01-init script to register the root
448 - ssh public key with the default administrator.  In this way the root
449 - ssh key will make it into the root account on the nodes by means of
450 - NodeManager's specialaccounts plugin.
451
452 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
453 - db-config ignores sliver tags
454 - sirius's db-config script renamed (was sirious)
455
456 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
457 - fix for silverauth - missing tag types now created at plc startup time
458
459 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
460 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
461
462 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
463 - companion to NM's specialaccounts plugin
464 - do not generate /etc/planetlab/root_ssh_key* anymore
465 - remove related config. variables and conf_files
466
467 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
468 - clarified description text to refer only to plcrt and not other optional
469 - packages.
470
471 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
472 - fixed a bug setting slice multiple attributes with the same tag name
473
474 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
475 - SSL setup for monitor box, and related new config variables
476 - new conf_file for /etc/planetlab/extensions
477 - various tweaks in db-config internals, about initscripts among others
478 - also more messages defined in the db
479
480 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
481 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
482
483 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
484 - bugfix in db-config, tag 4.3-19 would not fly
485
486 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
487 - Refactored db-config into snippets in db-config.d/.
488
489 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
490 - oops, tag 4.3-17 was broken and would not work
491
492 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
493 - bugfix - escape sequences inserted in xml configs
494
495 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
496 - Handle db-config.d files properly.
497
498 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
499 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
500 - than the log file
501 - - Fix db-config to be a bit more cautious when
502 - /etc/planetlab/db-config.d doesn''t exist
503 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
504 - .orig files.
505 - - Refactor generic plc-config-tty code into plc_config.py.
506 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
507 - and the list of validated variables and the corresponding
508 - validator() function. This refactoring lets one reuse plc_config.py
509 - as a generic cmdline configuration tool for highly customer MyPLC
510 - like software.
511
512 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
513 - update PCU Type descriptions.
514 - updates to init scripts
515
516 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
517 - requires monitor-pcucontrol so register-wizard can work
518
519 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
520 - cleaned up plc-config-tty, no more need to configure plc-devel
521
522 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
523 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
524
525 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
526 - fix issue in db-config that prevented correct operation
527
528 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
529 - remove support for chroot-based packaging - no crond nor syslog step anymore
530 - plc init script now named plc.init instead of former guest.init
531
532 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
533 - add Monitor to docs build
534
535 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
536 - plc_config.py and plc-config-tty: generalized to work for more diverse
537 - MyPLC configurations.
538 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
539 - deployments and increase the memory limits in php.ini
540 - plc.d/crond: add --full option to vacuumdb
541
542 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
543 - avoid generating ssl certificates for disabled services among www api boot
544
545 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
546 - cleaned up old entries in db-config
547 - mtail more robust
548
549 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
550 - php include path tweaked for plekit includes
551 - reviewed myplc (fka native) packaging dependencies
552 - renumbered 4.3
553
554 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
555 - rename myplc into myplc-chroot and myplc-native into myplc
556 - new settings (shortname & hrn_root) for local peer
557
558 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
559 - First iteration of new data model
560 - Bunch of various fixes
561
562 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
563 - Removed proper ops from planetflow slice.
564
565 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
566 - myplc-native requires myplc-docs
567 - fixed doc build by locating locally installed DTDs at build-time
568
569 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
570 - turn myplc-docs off for now
571
572 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
573 - figures in doc package
574
575 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
576 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
577 - chroot packaging does not have docs anymore
578 - 'cvs' and 'dev' not required from myplc-native anymore
579 - cosmetic change in kml output
580
581 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
582 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
583 - gethostbyname uses python rather than perl (hope this shrinks deps) 
584 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
585 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
586 - make sync now works towards vserver-based myplc only 
587
588 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
589
590 - added vsys 'pfmount' script to the default netflow slice attributes.
591
592
593 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
594 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
595 - to new bootcd packaging
596
597 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
598 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
599
600 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
601 - packaging of mplc-release in myplc-native
602 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
603 - resolv file in /etc/resolv.conf, not plc_resolv.conf
604 - improved sirius script
605 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
606 - expires more properly set 
607
608 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
609
610
611 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
612 - renew_reminder script moved to support-scripts/
613 - gen-aliases script added in support-scripts/
614 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
615 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
616 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
617 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
618 - new setting 'Mom list address' for sending emails to a separate destination
619 - starts rsyslogd/syslogd as appropriate
620 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
621 - convenience generation of yum.conf in resulting image based on build/mirroring
622
623 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
624 - refresh-peer.py removed (duplicate with PLCAPI)
625 - plc.d/ scripts cleaned up
626 - sirius initscript updated
627 - slice auto renewal fixed
628
629 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
630 - initial build.
631
632 %define module_current_branch 4.3