8151677feaccf77f70d890c90ba63491b662a027
[myplc.git] / myplc.spec
1 %define name myplc
2 %define version 5.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 BuildArch: noarch
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
22
23 ####################### myplc
24 Summary: PlanetLab Central (PLC) Portable Installation
25 Group: Applications/Systems
26
27 # as much as possible, requires should go in the subpackages specfile
28 Requires: redhat-lsb
29 Requires: bzip2
30 Requires: tar 
31 Requires: less
32 Requires: sendmail
33 Requires: sendmail-cf
34 Requires: openssl
35 Requires: expect
36 Requires: php-pgsql
37 Requires: curl
38 Requires: rsync
39 Requires: python-devel
40 Requires: yum
41 Requires: PyXML
42 Requires: createrepo
43 Requires: cpio
44 Requires: wget
45 Requires: php
46 Requires: openssh
47 Requires: dnsmasq
48 Requires: diffutils
49 Requires: gzip
50 Requires: vim-minimal
51 Requires: findutils
52 Requires: xmlsec1
53 Requires: xmlsec1-openssl
54 Requires: ed
55 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
56 Requires: cronie
57 %else
58 Requires: vixie-cron
59 %endif
60 # planetlab stuff
61 Requires: bootmanager
62 Requires: bootcd-%{nodefamily}
63 Requires: bootcd-initscripts
64 Requires: PLCWWW
65 Requires: www-register-wizard
66 Requires: nodeconfig
67 Requires: nodeyum
68 Requires: PLCAPI
69 Requires: nodeimage-%{nodefamily}
70 Requires: myplc-docs
71 Requires: myplc-release
72 Requires: myplc-config
73
74 %define debug_package %{nil}
75
76 %description 
77 MyPLC is a complete PlanetLab Central (PLC) portable installation.
78 The default installation consists of a web server, an XML-RPC API
79 server, a boot server, and a database server: the core components of
80 PLC. The installation may be customized through a graphical
81 interface. All PLC services are started up and shut down through a
82 single System V init script.
83
84 ####################### myplc-config
85
86 %package config
87
88 Summary: PlanetLab Central (PLC) configuration python module
89 Group: Applications/Systems
90 Requires: python
91
92 %description config
93 This package provides the Python module to configure MyPLC.
94
95
96 %prep
97 %setup -q
98
99 %build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 # Install configuration scripts
105 echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
106 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
107 install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
108
109 echo "* Installing scripts in /usr/bin"
110 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
111 rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
112 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
113 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
114
115 # Install initscript 
116 echo "* Installing plc initscript"
117 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
118 install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
119
120 # Install initscripts
121 echo "* Installing plc.d initscripts"
122 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
123 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
124
125 # Install db-config.d files
126 echo "* Installing db-config.d files"
127 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
128 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
130
131 # Extra scripts (mostly for mail and dns) not installed by myplc by default.  Used in production
132 echo "* Installing scripts in /etc/support-scripts"
133 mkdir -p ${RPM_BUILD_ROOT}/etc/support-scripts
134 cp support-scripts/* ${RPM_BUILD_ROOT}/etc/support-scripts
135 chmod 444 ${RPM_BUILD_ROOT}/etc/support-scripts/*
136
137 # copy initscripts to etc/plc_sliceinitscripts
138 mkdir -p ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
139 cp plc_sliceinitscripts/* ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts
140 chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
141
142 # Install configuration file
143 echo "* myplc: Installing configuration file"
144 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
145 sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
146     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
147 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
148
149 echo "* Installing bashrc convenience"
150 install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
151
152 # yumgroups.xml and yum repo : let noderepo handle that
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %pre
158 if [ -x %{_sysconfdir}/init.d/plc ] ; then
159     %{_sysconfdir}/init.d/plc stop
160 fi
161
162 # Old versions of myplc used to ship with a bootstrapped database and
163 # /etc/planetlab directory. Including generated files in the manifest
164 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
165 # names from one RPM build to another, it would be rpmsaved and thus
166 # effectively deleted. Now we do not include these files in the
167 # manifest. However, to avoid deleting these files in the process of
168 # upgrading from one of these old versions of myplc, we must back up
169 # the database and /etc/planetlab and restore them after the old
170 # version has been uninstalled in %triggerpostun (also in %post, in
171 # case we are force upgrading to the same version).
172 #
173 # This code can be removed once all myplc-0.4-1 installations have
174 # been upgraded to at least myplc-0.4-2.
175
176 # 0 = install, 1 = upgrade
177 if [ $1 -gt 0 ] ; then
178     for dir in /var/lib/pgsql/data /etc/planetlab ; do
179         if [ -d $dir ] ; then
180             echo "Preserving $dir"
181             mkdir -p $dir.rpmsave
182             tar -C $dir -cpf - . | \
183                tar -C $dir.rpmsave -xpf -
184
185             # Except for the default configuration file and DTD, which
186             # really should be considered for upgrade.
187             rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
188         fi
189     done
190 fi
191
192 %post
193 if [ -x /sbin/chkconfig ] ; then
194     /sbin/chkconfig --add plc
195     /sbin/chkconfig plc on
196 fi
197
198 %triggerpostun -- %{name}
199 # 0 = erase, 1 = upgrade
200 if [ $1 -gt 0 ] ; then
201     for dir in /var/lib/pgsql/data /etc/planetlab ; do
202         if [ -d $dir.rpmsave -a -d $dir ] ; then
203             echo "Merging $dir"
204             if tar -C $dir.rpmsave -cpf - . | \
205                tar -C $dir -xpf - ; then
206                 rm -rf $dir.rpmsave
207             fi
208         fi
209     done
210 fi    
211
212 %preun
213 # 0 = erase, 1 = upgrade
214 if [ $1 -eq 0 ] ; then
215     %{_sysconfdir}/init.d/plc stop
216     if [ -x /sbin/chkconfig ] ; then
217         /sbin/chkconfig plc off
218         /sbin/chkconfig --del plc
219     fi
220 fi
221
222 %files
223 %defattr(-,root,root,-)
224 # Host startup script and configuration file
225 /etc/init.d/plc
226 /etc/plc.d
227 /etc/planetlab
228 /etc/plc_sliceinitscripts
229 /etc/support-scripts
230 /usr/share/myplc/bashrc
231 # keep a detailed list, to avoid duplicate of plc-config,
232 # that belongs to the myplc-config rpm
233 /usr/bin/plc-config-tty
234 /usr/bin/db-config
235 /usr/bin/dns-config
236 /usr/bin/refresh-peer.py*
237 /usr/bin/mtail.py*
238 /usr/bin/mtail
239 /usr/bin/plc-map.py*
240 /usr/bin/plc-kml.py*
241 /usr/bin/clean-empty-dirs.py*
242 /usr/bin/plc-check-ssl-peering.py*
243 /usr/bin/plc-orphan-accounts.py*
244 /usr/bin/spot-aliens.py*
245 /usr/bin/check-hrns.py*
246 /usr/bin/check-vsys-defaults.py*
247 /usr/bin/spot-dup-accounts.sh
248 /lib/systemd/system/plc.service
249
250 %files config
251 %defattr(-,root,root,-)
252 /usr/bin/plc-config
253 %{python_sitearch}/plc_config.py*
254
255
256 %changelog
257 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
258 - define open_basedir in php.ini to stop confidentiality leak
259 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
260 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
261 - new utilities check-hrns.py and check-vsys-defaults.py
262
263 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
264 - set TimeoutSec to 300 in plc.service
265 - remove ref to deprecated svn $URL$ in db-config usage
266
267 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
268 - expose mtail.py as simply mtail
269
270 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
271 - plc-kml.py now has support for nodegroups
272
273 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
274 - use nodeimage package instead of deprecated bootstrapfs
275 - has systemd-friendly startup script
276 - plc_reload moved to functions/ - no more service plc reload
277 - no svn keywords anymore
278
279 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
280 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
281
282 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
283 - new settings for myslice (comon&tophat) and monitor (db)
284 - removed mentions of chroot in description
285 - can redo myplc-docs on broken f12-latex
286 - set short_open_tag in php.ini
287 - fixes in gen-sites-xml (is that still used ?)
288 - partial-repo.sh has moved to 'build' where it more belongs
289 - tweaks in convenience tool 'mtail'
290
291 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
292 - fixed changelog, no change from 5.0-16
293
294 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
295 - requires ed for the plc.d/packages step
296 - sirius initscript to handle stop and restart
297
298 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
299 - ignore steps in db-config.d if they have a '.' or '~' in their name
300
301 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
302 - can redo myplc-docs without the doc for monitor
303
304 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
305 - no semantic change - just fixed specfile for git URL
306
307 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
308 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
309
310 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
311 - add missing files to rpm package
312
313 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
314 - mtail.py -s for SFA
315 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
316
317 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
318 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
319
320 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
321 - plc-config-tty now has a validator on booleans
322 - e.g. entering 'True' now is rejected rather than silently recording 'false'
323
324 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
325 - disable mod_wsgi
326
327 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
328 - module name changes
329 - start wsgi support
330
331 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
332 - new setting PLC_RESERVATION_GRANULARITY
333
334 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
335 - * partial-repo.sh script
336 - * preserve key along with certificates
337
338 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
339 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
340
341 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
342 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
343 - new OMF category in the config
344 - create the drl system slice
345
346 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
347 - first working version of 5.0:
348 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
349 - nodefamily is 3-fold with pldistro-fcdistro-arch
350 - new PLC_FLAVOUR config category
351 - reviewed module layout
352 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
353
354 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
355 - support for fedora 12
356 - new package myplc-config for use by sfa
357 - drupal user registration turned off
358
359 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
360 - - fix to make sure when API, BOOT, MONITOR are on the same
361 - machine as WWW that the SSL key,cert for WWW takes precedence.
362 - - Do proper setup for SSL CA certficate to be used as the server
363 - chain.
364
365 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
366 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
367
368 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
369 - depend on pcucontrol
370
371 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
372 - * validate input according to type in plc_config
373 - * added the _genicw system slice
374 - * add tag types for sites and persons
375 - * add new tags for nodes and slices for exemption from myops
376
377 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
378 - turn off drupal on a box that acts as BOOT server but not as WWW server
379 - cleanup some obsolete code for old chroot-jail packaging in the process
380 - new bootcd-kernel script for keeping bootcd variants up2date
381
382 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
383 - Make the /etc/hosts manipulation optional.
384
385 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
386 - Fix SetRole.
387
388 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
389 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
390 - into the DB.
391 - - Added the root ssh key handling support back into plc.d/ssh and the
392 - default xml file.  This should be identical to the way it was in
393 - rc12.
394 - - Added support in the db-config.d/01-init script to register the root
395 - ssh public key with the default administrator.  In this way the root
396 - ssh key will make it into the root account on the nodes by means of
397 - NodeManager's specialaccounts plugin.
398
399 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
400 - db-config ignores sliver tags
401 - sirius's db-config script renamed (was sirious)
402
403 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
404 - fix for silverauth - missing tag types now created at plc startup time
405
406 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
407 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
408
409 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
410 - companion to NM's specialaccounts plugin
411 - do not generate /etc/planetlab/root_ssh_key* anymore
412 - remove related config. variables and conf_files
413
414 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
415 - clarified description text to refer only to plcrt and not other optional
416 - packages.
417
418 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
419 - fixed a bug setting slice multiple attributes with the same tag name
420
421 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
422 - SSL setup for monitor box, and related new config variables
423 - new conf_file for /etc/planetlab/extensions
424 - various tweaks in db-config internals, about initscripts among others
425 - also more messages defined in the db
426
427 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
428 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
429
430 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
431 - bugfix in db-config, tag 4.3-19 would not fly
432
433 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
434 - Refactored db-config into snippets in db-config.d/.
435
436 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
437 - oops, tag 4.3-17 was broken and would not work
438
439 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
440 - bugfix - escape sequences inserted in xml configs
441
442 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
443 - Handle db-config.d files properly.
444
445 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
446 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
447 - than the log file
448 - - Fix db-config to be a bit more cautious when
449 - /etc/planetlab/db-config.d doesn''t exist
450 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
451 - .orig files.
452 - - Refactor generic plc-config-tty code into plc_config.py.
453 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
454 - and the list of validated variables and the corresponding
455 - validator() function. This refactoring lets one reuse plc_config.py
456 - as a generic cmdline configuration tool for highly customer MyPLC
457 - like software.
458
459 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
460 - update PCU Type descriptions.
461 - updates to init scripts
462
463 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
464 - requires monitor-pcucontrol so register-wizard can work
465
466 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
467 - cleaned up plc-config-tty, no more need to configure plc-devel
468
469 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
470 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
471
472 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
473 - fix issue in db-config that prevented correct operation
474
475 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
476 - remove support for chroot-based packaging - no crond nor syslog step anymore
477 - plc init script now named plc.init instead of former guest.init
478
479 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
480 - add Monitor to docs build
481
482 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
483 - plc_config.py and plc-config-tty: generalized to work for more diverse
484 - MyPLC configurations.
485 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
486 - deployments and increase the memory limits in php.ini
487 - plc.d/crond: add --full option to vacuumdb
488
489 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
490 - avoid generating ssl certificates for disabled services among www api boot
491
492 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
493 - cleaned up old entries in db-config
494 - mtail more robust
495
496 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
497 - php include path tweaked for plekit includes
498 - reviewed myplc (fka native) packaging dependencies
499 - renumbered 4.3
500
501 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
502 - rename myplc into myplc-chroot and myplc-native into myplc
503 - new settings (shortname & hrn_root) for local peer
504
505 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
506 - First iteration of new data model
507 - Bunch of various fixes
508
509 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
510 - Removed proper ops from planetflow slice.
511
512 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
513 - myplc-native requires myplc-docs
514 - fixed doc build by locating locally installed DTDs at build-time
515
516 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
517 - turn myplc-docs off for now
518
519 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
520 - figures in doc package
521
522 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
523 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
524 - chroot packaging does not have docs anymore
525 - 'cvs' and 'dev' not required from myplc-native anymore
526 - cosmetic change in kml output
527
528 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
529 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
530 - gethostbyname uses python rather than perl (hope this shrinks deps) 
531 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
532 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
533 - make sync now works towards vserver-based myplc only 
534
535 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
536
537 - added vsys 'pfmount' script to the default netflow slice attributes.
538
539
540 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
541 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
542 - to new bootcd packaging
543
544 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
545 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
546
547 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
548 - packaging of mplc-release in myplc-native
549 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
550 - resolv file in /etc/resolv.conf, not plc_resolv.conf
551 - improved sirius script
552 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
553 - expires more properly set 
554
555 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
556
557
558 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
559 - renew_reminder script moved to support-scripts/
560 - gen-aliases script added in support-scripts/
561 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
562 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
563 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
564 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
565 - new setting 'Mom list address' for sending emails to a separate destination
566 - starts rsyslogd/syslogd as appropriate
567 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
568 - convenience generation of yum.conf in resulting image based on build/mirroring
569
570 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
571 - refresh-peer.py removed (duplicate with PLCAPI)
572 - plc.d/ scripts cleaned up
573 - sirius initscript updated
574 - slice auto renewal fixed
575
576 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
577 - initial build.
578
579 %define module_current_branch 4.3