fix resolv.conf issue on plc
[myplc.git] / myplc-docs.spec
index b9982dd..5472b4a 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-docs
 %define version 4.3
-%define taglevel 37
+%define taglevel 53
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -40,6 +40,11 @@ http://svn.planet-lab.org/wiki/MyPLCUserGuide
 %build
 rm -rf $RPM_BUILD_ROOT
 
+# using the new lowercase names, and handling legacy
+[ -d PLCAPI ] || ln -s plcapi PLCAPI
+[ -d NodeManager ] || ln -s nodemanager NodeManager
+[ -d MyPLC ] || ln -s myplc MyPLC
+
 pushd PLCAPI
 # beware that making the pdf file somehow overwrites the html
 make -C doc PLCAPI.pdf 
@@ -54,19 +59,11 @@ rm -f doc/NMAPI.html
 make -C doc NMAPI.html 
 popd
 
-pushd Monitor
-# beware that making the pdf file somehow overwrites the html
-make -C docs Monitor.pdf 
-rm -f docs/Monitor.html
-make -C docs Monitor.html 
-popd
-
 %install
 
 for ext in pdf html; do
     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
-    install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
 done
 
 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
@@ -75,9 +72,6 @@ done
 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
-./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
-    $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
-    $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,6 +81,58 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
+- VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
+- fix gpg update.
+- this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
+- https://bugs.g10code.com/gnupg/issue1122
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
+- use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
+- generate plc_config.rb via plc-config
+
+* Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
+- Do not preserve /etc/planetlab on upgrade operations
+
+* Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
+- Remove Monitor references from spec file
+
+* Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
+- Introduce staticroute tagtype
+
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
+- attempt to fix small glitches
+
+* Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
+- enable short_open_tag for backward compatibility
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
+- Cherry-pick PHP5 timezone fix form master
+
+* Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
+- pick the greatest version as a kernel
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
+- handle directory name changes for myplc-docs package as well
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
+- handle directory name changes
+
+* Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
+- Use correct resolv.conf file.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
+- Make dnsmasq usable.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
+- Allow dnsmasq configuration to be extended.
+
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
 - support for fedora 12
 - new package myplc-config for use by sfa