fix resolv.conf issue on plc
[myplc.git] / myplc-docs.spec
index c851432..5472b4a 100644 (file)
@@ -1,11 +1,11 @@
 #
-# $Id: myplc-native.spec 9260 2008-05-07 16:20:25Z thierry $
+# $Id$
 #
-%define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/MyPLC/trunk/myplc-native.spec $
+%define url $URL$
 
 %define name myplc-docs
-%define version 5.0
-%define taglevel 0
+%define version 4.3
+%define taglevel 53
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,10 +28,11 @@ BuildRequires: docbook-dtds, docbook-utils-pdf
 
 %define debug_package %{nil}
 
-%description 
-This package contains the online documentation for MyPLC. This covers
-the overall system itself, together with the reference manuals for the
-two APIs provided, namely PLCAPI and NMAPI.
+%description
+This package contains the online documentation for MyPLC, i.e. the
+reference manuals for the two APIs provided: PLCAPI and NMAPI. A
+more general introduction to the MyPLC system can be found at
+http://svn.planet-lab.org/wiki/MyPLCUserGuide
 
 %prep
 %setup -q
@@ -39,12 +40,10 @@ two APIs provided, namely PLCAPI and NMAPI.
 %build
 rm -rf $RPM_BUILD_ROOT
 
-pushd MyPLC
-# beware that making the pdf file somehow overwrites the html
-make -C doc myplc.pdf 
-rm -f doc/myplc.html
-make -C doc myplc.html 
-popd
+# using the new lowercase names, and handling legacy
+[ -d PLCAPI ] || ln -s plcapi PLCAPI
+[ -d NodeManager ] || ln -s nodemanager NodeManager
+[ -d MyPLC ] || ln -s myplc MyPLC
 
 pushd PLCAPI
 # beware that making the pdf file somehow overwrites the html
@@ -63,23 +62,14 @@ popd
 %install
 
 for ext in pdf html; do
-    install -D -m 444 MyPLC/doc/myplc.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.$ext
     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
 done
 
-# myplc figures
-for ext in eps png; do 
-    install -m 444 MyPLC/doc/architecture.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/architecture.$ext
-done
-
-./MyPLC/doc/docbook2drupal.sh "MyPLC Documentation (%{pldistro})" \
-    $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.html \
-    $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.php 
-./MyPLC/doc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
+./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
-./MyPLC/doc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
+./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
 
@@ -91,6 +81,216 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
+- VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
+- fix gpg update.
+- this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
+- https://bugs.g10code.com/gnupg/issue1122
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
+- use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
+- generate plc_config.rb via plc-config
+
+* Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
+- Do not preserve /etc/planetlab on upgrade operations
+
+* Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
+- Remove Monitor references from spec file
+
+* Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
+- Introduce staticroute tagtype
+
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
+- attempt to fix small glitches
+
+* Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
+- enable short_open_tag for backward compatibility
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
+- Cherry-pick PHP5 timezone fix form master
+
+* Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
+- pick the greatest version as a kernel
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
+- handle directory name changes for myplc-docs package as well
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
+- handle directory name changes
+
+* Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
+- Use correct resolv.conf file.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
+- Make dnsmasq usable.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
+- Allow dnsmasq configuration to be extended.
+
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
+- support for fedora 12
+- new package myplc-config for use by sfa
+- drupal user registration turned off
+
+* Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
+- - fix to make sure when API, BOOT, MONITOR are on the same
+- machine as WWW that the SSL key,cert for WWW takes precedence.
+- - Do proper setup for SSL CA certficate to be used as the server
+- chain.
+
+* Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
+- - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
+
+* Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
+- depend on pcucontrol
+
+* Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
+- * validate input according to type in plc_config
+- * added the _genicw system slice
+- * add tag types for sites and persons
+- * add new tags for nodes and slices for exemption from myops
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
+- turn off drupal on a box that acts as BOOT server but not as WWW server
+- cleanup some obsolete code for old chroot-jail packaging in the process
+- new bootcd-kernel script for keeping bootcd variants up2date
+
+* Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
+- Make the /etc/hosts manipulation optional.
+
+* Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
+- Fix SetRole.
+
+* Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
+- - Added "SetRole()" so that db-config.d/ scriplets can insert roles
+- into the DB.
+- - Added the root ssh key handling support back into plc.d/ssh and the
+- default xml file.  This should be identical to the way it was in
+- rc12.
+- - Added support in the db-config.d/01-init script to register the root
+- ssh public key with the default administrator.  In this way the root
+- ssh key will make it into the root account on the nodes by means of
+- NodeManager's specialaccounts plugin.
+
+* Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
+- db-config ignores sliver tags
+- sirius's db-config script renamed (was sirious)
+
+* Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
+- fix for silverauth - missing tag types now created at plc startup time
+
+* Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
+- plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
+
+* Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
+- companion to NM's specialaccounts plugin
+- do not generate /etc/planetlab/root_ssh_key* anymore
+- remove related config. variables and conf_files
+
+* Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
+- clarified description text to refer only to plcrt and not other optional
+- packages.
+
+* Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
+- fixed a bug setting slice multiple attributes with the same tag name
+
+* Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
+- SSL setup for monitor box, and related new config variables
+- new conf_file for /etc/planetlab/extensions
+- various tweaks in db-config internals, about initscripts among others
+- also more messages defined in the db
+
+* Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
+- create node tags, like e.g. 'arch', that were not handled with 4.3-20
+
+* Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
+- bugfix in db-config, tag 4.3-19 would not fly
+
+* Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
+- Refactored db-config into snippets in db-config.d/.
+
+* Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
+- oops, tag 4.3-17 was broken and would not work
+
+* Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
+- bugfix - escape sequences inserted in xml configs
+
+* Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
+- Handle db-config.d files properly.
+
+* Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
+- - Fix /etc/init.d/plc to have command usage show up on the tty rather
+- than the log file
+- - Fix db-config to be a bit more cautious when
+- /etc/planetlab/db-config.d doesn't exist
+- - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
+- .orig files.
+- - Refactor generic plc-config-tty code into plc_config.py.
+- plc-config-tty now contains MyPLC specific paths, "usual" variables,
+- and the list of validated variables and the corresponding
+- validator() function. This refactoring lets one reuse plc_config.py
+- as a generic cmdline configuration tool for highly customer MyPLC
+- like software.
+
+* Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
+- update PCU Type descriptions.
+- updates to init scripts
+
+* Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
+- requires monitor-pcucontrol so register-wizard can work
+
+* Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
+- cleaned up plc-config-tty, no more need to configure plc-devel
+
+* Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
+- first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
+
+* Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
+- tighter right permissions on site_admin's authorized keys for more robustness
+
+* Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
+- fix issue in db-config that prevented correct operation
+
+* Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
+- remove support for chroot-based packaging - no crond nor syslog step anymore
+- plc init script now named plc.init instead of former guest.init
+
+* Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
+- add Monitor to docs build
+
+* Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
+- plc_config.py and plc-config-tty: generalized to work for more diverse
+- MyPLC configurations.
+- plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
+- deployments and increase the memory limits in php.ini
+- plc.d/crond: add --full option to vacuumdb
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
+- avoid generating ssl certificates for disabled services among www api boot
+
+* Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
+- cleaned up old entries in db-config
+- mtail more robust
+
+* Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
+- php include path tweaked for plekit includes
+- reviewed myplc (fka native) packaging dependencies
+- renumbered 4.3
+
+* Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
+- rename myplc into myplc-chroot and myplc-native into myplc
+- new settings (shortname & hrn_root) for local peer
+
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
+- First iteration of new data model
+- Bunch of various fixes
+
 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
 - Removed proper ops from planetflow slice.