Setting tag myplc-5.3-5
[myplc.git] / myplc-docs.spec
index d9d7fa0..acd8e5c 100644 (file)
@@ -1,10 +1,5 @@
-#
-# $Id$
-#
-%define url $URL$
-
 %define name myplc-docs
-%define version 5.0
+%define version 5.3
 %define taglevel 5
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -22,7 +17,7 @@ BuildArch: noarch
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 BuildRequires: docbook-dtds, docbook-utils-pdf
 
@@ -40,44 +35,58 @@ http://svn.planet-lab.org/wiki/MyPLCUserGuide
 %build
 rm -rf $RPM_BUILD_ROOT
 
-if [ -d PLCAPI ] ; then pushd PLCAPI ; else pushd plcapi; fi
+# using the new lowercase names, and handling legacy
+[ -d myplc ] || ln -s MyPLC myplc
+[ -d plcapi ] || ln -s PLCAPI plcapi
+[ -d nodemanager ] || ln -s NodeManager nodemanager
+[ -d monitor ] || ln -s Monitor monitor 
+
+pushd plcapi
+# june2011 & f12, latex issues weird warnings, might need to try twice
+make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
 # beware that making the pdf file somehow overwrites the html
-make -C doc PLCAPI.pdf 
 rm -f doc/PLCAPI.html
-make -C doc PLCAPI.html 
+make -C doc PLCAPI.html || make -C doc PLCAPI.html 
 popd
 
-if [ -d NodeManager ] ; then pushd NodeManager; else pushd nodemanager ; fi
+pushd nodemanager
 # beware that making the pdf file somehow overwrites the html
-make -C doc NMAPI.pdf 
+make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
 rm -f doc/NMAPI.html
-make -C doc NMAPI.html 
+make -C doc NMAPI.html || make -C doc NMAPI.html 
 popd
 
-if [ -d Monitor ] ; then pushd Monitor; else pushd monitor; fi
+# not everyone rebuilds monitor, so make it optional
+if [ -d monitor ] ; then
+pushd monitor
 # beware that making the pdf file somehow overwrites the html
-make -C docs Monitor.pdf 
+make -C docs Monitor.pdf || make -C docs Monitor.pdf 
 rm -f docs/Monitor.html
-make -C docs Monitor.html 
+make -C docs Monitor.html || make -C docs Monitor.html 
 popd
+fi
 
 %install
 
 for ext in pdf html; do
-    install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
-    install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
-    install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
+    install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
+    install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
+    if [ -d monitor ] ; then
+    install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
+    fi
 done
 
-./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
+./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
-./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
+./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
-./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
+if [ -d monitor ] ; then
+./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,6 +96,124 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-5.3-5
+- last version suitable for f27/f29 with python2
+- packaging is split up, one more rpm named 'myplc-core' is produced,
+- that covers the infrastructure side only (without bootcds and nodeimages and all node-oriented material)
+- no more init file, one systemd service only, that leverages new /usr/bin/plc-ctl
+- more robust config for httpd and php-fpm and php
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
+- takes care of creating plcapi log file
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
+- tweaked renew_reminder for federation
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
+- tweaks in check-hrns.py
+- do not require PyXML any more
+
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
+- review check-hrns for plcapi-5.3
+- add PLC_HRN_ROOT in usual plc-config-tty's settings
+
+* Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
+- reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
+- add an rpm-sign dependency on feedora>=16
+
+* Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
+- drop PLC_OMF_XMPP_{USER,PASSWORD} from config
+
+* Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
+- plc.d/gpg now does not rm /dev/random but preserves it
+- this is because libvirt won't let us run mknod
+
+* Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
+- fix typo in check-hrns - used to print 'host' while dealing with persons
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
+- supports httpd config for either mod_python (preferred) or mod_wsgi
+- requires mod_wsgi on f18 only, otherwise mod_python
+- supports httpd config for apache 2.4 (f18)
+- new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
+
+* Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
+- bugfix in check-vsys-defaults.py
+
+* Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
+- define open_basedir in php.ini to stop confidentiality leak
+- new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
+- new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
+- new utilities check-hrns.py and check-vsys-defaults.py
+
+* Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
+- set TimeoutSec to 300 in plc.service
+- remove ref to deprecated svn $URL$ in db-config usage
+
+* Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
+- expose mtail.py as simply mtail
+
+* Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
+- plc-kml.py now has support for nodegroups
+
+* Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
+- use nodeimage package instead of deprecated bootstrapfs
+- has systemd-friendly startup script
+- plc_reload moved to functions/ - no more service plc reload
+- no svn keywords anymore
+
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
+- new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
+
+* Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
+- new settings for myslice (comon&tophat) and monitor (db)
+- removed mentions of chroot in description
+- can redo myplc-docs on broken f12-latex
+- set short_open_tag in php.ini
+- fixes in gen-sites-xml (is that still used ?)
+- partial-repo.sh has moved to 'build' where it more belongs
+- tweaks in convenience tool 'mtail'
+
+* Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
+- fixed changelog, no change from 5.0-16
+
+* Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
+- requires ed for the plc.d/packages step
+- sirius initscript to handle stop and restart
+
+* Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
+- ignore steps in db-config.d if they have a '.' or '~' in their name
+
+* Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
+- can redo myplc-docs without the doc for monitor
+
+* Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
+- no semantic change - just fixed specfile for git URL
+
+* Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
+- needed for plcapi-5.0-19, i.e. tag permissions based on roles
+
+* Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
+- add missing files to rpm package
+
+* Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
+- mtail.py -s for SFA
+- spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
+
+* Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
+- avoid duplication of the plc-config binary in both myplc and myplc-config rpms
+
+* Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
+- plc-config-tty now has a validator on booleans
+- e.g. entering 'True' now is rejected rather than silently recording 'false'
+
+* Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
+- disable mod_wsgi
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
+- module name changes
+- start wsgi support
+
 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
 - new setting PLC_RESERVATION_GRANULARITY