use the FQDN for PLC_WWW_HOST rather than localhost to get cron.php
[myplc.git] / myplc-native.spec
index 7752ee4..1048bc6 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-native
 %define version 4.2
-%define taglevel 10
+%define taglevel 20
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -63,6 +63,7 @@ Requires: bootcd-%{pldistro}-%{_arch}
 Requires: dnsmasq
 Requires: diffutils
 Requires: gzip
+Requires: vim-minimal
 Requires: findutils
 # planetlab stuff
 Requires: PLCWWW
@@ -71,7 +72,12 @@ Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
 
-Provides: myplc
+# argh - ugly - we might wish to use something from build/config.%{pldistro} instead
+%if "%{pldistro}" == "onelab"
+Requires: dummynet_image
+%endif
+
+Provides: myplc = %version-%release
 
 %define debug_package %{nil}
 
@@ -107,7 +113,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
 fi
 
 %pre
@@ -198,10 +204,49 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/check-ssl-peering.py*
 /usr/share/myplc
-/var/www/html/install-rpms/%{pldistro}-%{_arch}
-/var/www/html/install-rpms/planetlab
 
 %changelog
+* Fri Apr 10 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-20
+- * Skip SSL generation for services that aren't enabled
+- * added --full flag to crond for vacuumdb
+
+* Tue Nov 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.2-19
+- Add common slice attributes.
+- Clarified 'failed to authenticate' message.
+- Make db-config extensible.
+
+* Wed Sep 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-18
+- onelab distro requires the dummynet_image package with myplc-native
+- (onelab distro does not build chroot-myplc anymore)
+
+* Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-17
+- Remove iptables conf_file.  Now in iptables module.
+- Arch specific download directory now in /data for chrooted myplc
+- Vim now a dependency in myplc. :-)
+
+* Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-16
+- yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
+- also does not create any repo under /var/www/html/install-rpms, to prevent conflicts with noderepo
+
+* Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
+- Removed proper ops from planetflow slice.
+
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
+- myplc-native requires myplc-docs
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
+- turn myplc-docs off for now
+
+* Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
+- figures in doc package
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
+- no more doc packaged outside of myplc-docs - doc/ cleaned up 
+- chroot packaging does not have docs anymore
+- 'cvs' and 'dev' not required from myplc-native anymore
+- cosmetic change in kml output
+
 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
 - gethostbyname uses python rather than perl (hope this shrinks deps)