a little nicer db-config
[myplc.git] / myplc.spec
index 7ae5097..22f8c34 100644 (file)
@@ -3,7 +3,7 @@
 %define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+
 
 Name: %{name}
 Version: %{version}
@@ -26,17 +26,17 @@ Summary: PlanetLab Central (PLC) Portable Installation
 Group: Applications/Systems
 
 # planetlab stuff
+Requires: myplc-docs
+Requires: myplc-release
+Requires: myplc-core
+Requires: createrepo
 Requires: bootmanager
 Requires: bootcd-%{nodefamily}
 Requires: bootcd-initscripts
-Requires: www-register-wizard
+Requires: nodeimage-%{nodefamily}
 Requires: nodeconfig
 Requires: nodeyum
-Requires: nodeimage-%{nodefamily}
-Requires: myplc-docs
-Requires: myplc-release
-Requires: myplc-core
-Requires: createrepo
+Requires: www-register-wizard
 
 
 # starting with f16 we depend on this new rpm
@@ -45,8 +45,6 @@ Requires: rpm-sign
 %endif
 
 
-%define debug_package %{nil}
-
 %description
 MyPLC is a complete PlanetLab Central (PLC) portable installation.
 The default installation consists of a web server, an XML-RPC API
@@ -57,17 +55,15 @@ single System V init script.
 
 
 ####################### myplc-core
+# Warning: it appears that Requires should come here
+# BEFORE the %description thingy
 
 %package core
 
-Summary: this package is designed for deployments that only need
-the API + db + www UI. Installing this will not require any node-oriented
-package, like bootcd, nodeiamge, or bootmanager.
-
-% description core
-The core of myplc is about its API + database + web interface
+Summary: core contents of myplc with API + db + www UI
 
-# as much as possible, requires should go in the subpackages specfile
+# as much as possible, requires should have gone
+# with the individual packages, but well
 Requires: myplc-config
 Requires: plcapi
 Requires: plewww
@@ -75,7 +71,7 @@ Requires: plewww
 # this technically is a plcapi dependency
 # but it's simpler here for chosing which
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 29
-Requires: python2-mod_wsgi
+Requires: python3-mod_wsgi
 %else
 Requires: mod_wsgi
 %endif
@@ -97,7 +93,7 @@ Requires: expect
 Requires: php-pgsql
 Requires: curl
 Requires: rsync
-Requires: python-devel
+Requires: python3-devel
 Requires: dnf
 #Requires: PyXML
 Requires: cpio
@@ -115,18 +111,24 @@ Requires: ed
 Requires: cronie
 
 
+%description core
+The core of myplc is about its API + database + web interface.
+Installing this will not require any node-oriented
+package, like bootcd, nodeimage, or bootmanager.
+
 ####################### myplc-config
 
 %package config
 
 Summary: PlanetLab Central (PLC) configuration python module
 Group: Applications/Systems
-Requires: python
+Requires: python3
 
 %description config
 This package provides the Python module to configure MyPLC.
 
 
+
 %prep
 %setup -q
 
@@ -136,9 +138,8 @@ This package provides the Python module to configure MyPLC.
 rm -rf $RPM_BUILD_ROOT
 
 # Install configuration scripts
-echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
-PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
-install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
+echo "* Installing plc_config.py in %{python3_sitelib}"
+install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}/plc_config.py
 
 echo "* Installing scripts in /usr/bin"
 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
@@ -258,6 +259,9 @@ fi
 
 %files core
 %defattr(-,root,root,-)
+/usr/lib/systemd/system/plc.service
+/usr/bin/plc-ctl
+/etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts
 /etc/support-scripts
@@ -283,7 +287,7 @@ fi
 %files config
 %defattr(-,root,root,-)
 /usr/bin/plc-config
-%{python_sitearch}/plc_config.py*
+%{python3_sitelib}/plc_config.py*
 
 
 %changelog