systemd services go in /usr/lib/systemd/system rather than /lib/<same>
[myplc.git] / myplc.spec
index 2806623..49240b6 100644 (file)
@@ -72,6 +72,9 @@ Requires: nodeconfig
 Requires: nodeyum
 Requires: plcapi >= 5.2
 # this technically is a plcapi dependency but it's simpler here for chosing which
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
+Requires: python2-mod_wsgi
+%else
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
 Requires: mod_wsgi
 %else
@@ -126,7 +129,7 @@ chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
 # Install initscript 
 echo "* Installing plc initscript"
 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
-install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
+install -D -m 644 plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
 
 # Install initscripts
 echo "* Installing plc.d initscripts"
@@ -261,7 +264,7 @@ fi
 /usr/bin/check-hrns.py*
 /usr/bin/check-vsys-defaults.py*
 /usr/bin/spot-dup-accounts.sh
-/lib/systemd/system/plc.service
+/usr/lib/systemd/system/plc.service
 
 %files config
 %defattr(-,root,root,-)