fixes to the service file; + former stub /etc/init.d/plc becomes /usr/bin/plc-ctl
[myplc.git] / myplc.spec
index 4cd7b03..56e7aa4 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
 %define version 5.3
-%define taglevel 1
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -27,7 +27,7 @@ Group: Applications/Systems
 # as much as possible, requires should go in the subpackages specfile
 Requires: redhat-lsb
 Requires: bzip2
-Requires: tar 
+Requires: tar
 Requires: less
 Requires: sendmail
 Requires: sendmail-cf
@@ -38,7 +38,7 @@ Requires: curl
 Requires: rsync
 Requires: python-devel
 Requires: yum
-Requires: PyXML
+#Requires: PyXML
 Requires: createrepo
 Requires: cpio
 Requires: wget
@@ -57,6 +57,10 @@ Requires: cronie
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 16
 Requires: rpm-sign
 %endif
+# starting with f27 we depend on this new rpm
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 27
+Requires: php-fpm
+%endif
 
 # planetlab stuff
 Requires: bootmanager
@@ -68,11 +72,15 @@ Requires: nodeconfig
 Requires: nodeyum
 Requires: plcapi >= 5.2
 # this technically is a plcapi dependency but it's simpler here for chosing which
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
+Requires: python2-mod_wsgi
+%else
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
 Requires: mod_wsgi
 %else
 Requires: mod_python
 %endif
+%endif
 Requires: nodeimage-%{nodefamily}
 Requires: myplc-docs
 Requires: myplc-release
@@ -80,7 +88,7 @@ Requires: myplc-config
 
 %define debug_package %{nil}
 
-%description 
+%description
 MyPLC is a complete PlanetLab Central (PLC) portable installation.
 The default installation consists of a web server, an XML-RPC API
 server, a boot server, and a database server: the core components of
@@ -119,10 +127,10 @@ rsync -av --exclude .svn bin/ ${RPM_BUILD_ROOT}/usr/bin/
 (cd $RPM_BUILD_ROOT/usr/bin; ln -s mtail.py mtail)
 chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
 
-# Install initscript 
+# Install initscript
 echo "* Installing plc initscript"
-install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
-install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
+install -D -m 755 systemd/plc-ctl ${RPM_BUILD_ROOT}/usr/bin/plc-ctl
+install -D -m 644 systemd/plc.service ${RPM_BUILD_ROOT}/usr/lib/systemd/system/plc.service
 
 # Install initscripts
 echo "* Installing plc.d initscripts"
@@ -202,6 +210,11 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig plc on
 fi
 
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 27
+systemctl enable php-fpm
+systemctl start  php-fpm
+%endif
+
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
 if [ $1 -gt 0 ] ; then
@@ -214,7 +227,7 @@ if [ $1 -gt 0 ] ; then
            fi
        fi
     done
-fi    
+fi
 
 %preun
 # 0 = erase, 1 = upgrade
@@ -229,7 +242,7 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-/etc/init.d/plc
+/usr/bin/plc-ctl
 /etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts
@@ -252,7 +265,7 @@ fi
 /usr/bin/check-hrns.py*
 /usr/bin/check-vsys-defaults.py*
 /usr/bin/spot-dup-accounts.sh
-/lib/systemd/system/plc.service
+/usr/lib/systemd/system/plc.service
 
 %files config
 %defattr(-,root,root,-)
@@ -261,6 +274,16 @@ fi
 
 
 %changelog
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
+- takes care of creating plcapi log file
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
+- tweaked renew_reminder for federation
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
+- tweaks in check-hrns.py
+- do not require PyXML any more
+
 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
 - review check-hrns for plcapi-5.3
 - add PLC_HRN_ROOT in usual plc-config-tty's settings
@@ -554,22 +577,22 @@ fi
 - figures in doc package
 
 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
-- no more doc packaged outside of myplc-docs - doc/ cleaned up 
+- no more doc packaged outside of myplc-docs - doc/ cleaned up
 - chroot packaging does not have docs anymore
 - 'cvs' and 'dev' not required from myplc-native anymore
 - cosmetic change in kml output
 
 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
-- gethostbyname uses python rather than perl (hope this shrinks deps) 
+- gethostbyname uses python rather than perl (hope this shrinks deps)
 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
-- make sync now works towards vserver-based myplc only 
+- make sync now works towards vserver-based myplc only
 
 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
-- 
+-
 - added vsys 'pfmount' script to the default netflow slice attributes.
-- 
+-
 
 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
@@ -584,10 +607,10 @@ fi
 - resolv file in /etc/resolv.conf, not plc_resolv.conf
 - improved sirius script
 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
-- expires more properly set 
+- expires more properly set
 
 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
-- 
+-
 
 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
 - renew_reminder script moved to support-scripts/