Change v3 to v4 yumgroups.xml
[myplc.git] / myplc.spec
index 1d8cc62..60ec645 100644 (file)
@@ -6,7 +6,7 @@ URL: http://cvs.planet-lab.org/cvs/myplc
 Summary: PlanetLab Central (PLC) Portable Installation
 Name: myplc
 Version: 0.5
-Release: 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Release: 5%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 License: PlanetLab
 Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
@@ -23,24 +23,12 @@ through a graphical interface. All PLC services are started up and
 shut down through a single System V init script installed in the host
 system.
 
-%package devel
-Summary: PlanetLab Central (PLC) Development Environment
-Group: Development/Tools
-AutoReqProv: no
-
-%description devel
-This package install a complete PlanetLab development environment
-contained within a chroot jail. The default installation consists of a
-local CVS repository bootstrapped with a snapshot of all PlanetLab
-source code, and all the tools necessary to compile it.
-
 %prep
 %setup -q
 
 %build
 pushd myplc
-./build_devel.sh %{?cvstag:-t %{cvstag}}
-./build.sh %{?cvstag:-t %{cvstag}}
+./build.sh
 popd
 
 %install
@@ -67,25 +55,6 @@ install -D -m 644 root.img $RPM_BUILD_ROOT/plc/root.img
 # Install data directory
 find data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
 
-#
-# myplc-devel
-#
-
-# Install host startup script and configuration file
-install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc-devel
-install -D -m 644 plc-devel.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc-devel
-
-# Install root filesystem
-install -d -m 755 $RPM_BUILD_ROOT/plc/devel/root
-install -D -m 644 devel/root.img $RPM_BUILD_ROOT/plc/devel/root.img
-
-# Install data directory
-find devel/data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
-
-# Make sure /cvs is never upgraded once installed by giving it a
-# unique name. A hard-linked copy is made in %post.
-mv $RPM_BUILD_ROOT/plc/devel/data/{cvs,cvs-%{version}-%{release}}
-
 popd
 
 %clean
@@ -94,12 +63,12 @@ rm -rf $RPM_BUILD_ROOT
 # If run under sudo
 if [ -n "$SUDO_USER" ] ; then
     # Allow user to delete the build directory
-    chown -R $SUDO_USER .
+    chown -h -R $SUDO_USER .
     # Some temporary cdroot files like /var/empty/sshd and
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -R $SUDO_USER %{_rpmdir}/%{_arch}
+    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
 %pre
@@ -124,9 +93,15 @@ fi
 # 0 = install, 1 = upgrade
 if [ $1 -gt 0 ] ; then
     for dir in /var/lib/pgsql/data /etc/planetlab ; do
-       if [ -d /plc/data/$dir -a ! -d /plc/data/$dir.rpmsave ] ; then
+       if [ -d /plc/data/$dir ] ; then
            echo "Preserving /plc/data/$dir"
-           cp -ra /plc/data/$dir{,.rpmsave}
+           mkdir -p /plc/data/$dir.rpmsave
+           tar -C /plc/data/$dir -cpf - . | \
+              tar -C /plc/data/$dir.rpmsave -xpf -
+
+           # Except for the default configuration file and DTD, which
+           # really should be considered for upgrade.
+           rm -f /plc/data/$dir.rpmsave/{default_config.xml,plc_config.dtd}
        fi
     done
 fi
@@ -137,19 +112,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig plc on
 fi
 
-for dir in /var/lib/pgsql/data /etc/planetlab ; do
-    if [ -d /plc/data/$dir.rpmsave -a -d /plc/data/$dir ] ; then
-       echo "Merging /plc/data/$dir"
-       if tar -C /plc/data/$dir.rpmsave -cpf - . | \
-           tar -C /plc/data/$dir -xpf - ; then
-           rm -rf /plc/data/$dir.rpmsave
-       fi
-    fi
-done
-
-# Force a regeneration to take into account new variables
-touch /plc/data/etc/planetlab/default_config.xml
-
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
 if [ $1 -gt 0 ] ; then
@@ -174,33 +136,6 @@ if [ $1 -eq 0 ] ; then
     fi
 fi
 
-%pre devel
-if [ -x %{_sysconfdir}/init.d/plc-devel ] ; then
-    %{_sysconfdir}/init.d/plc-devel stop
-fi
-
-%post devel
-if [ -x /sbin/chkconfig ] ; then
-    /sbin/chkconfig --add plc-devel
-    /sbin/chkconfig plc-devel on
-fi
-
-# If /cvs does not already exist, make a hard-linked copy of this
-# version's /cvs repository.
-if [ ! -d /plc/devel/data/cvs ] ; then
-    cp -rl /plc/devel/data/{cvs-%{version}-%{release},cvs}
-fi
-
-%preun devel
-# 0 = erase, 1 = upgrade
-if [ $1 -eq 0 ] ; then
-    %{_sysconfdir}/init.d/plc-devel stop
-    if [ -x /sbin/chkconfig ] ; then
-        /sbin/chkconfig plc-devel off
-       /sbin/chkconfig --del plc-devel
-    fi
-fi
-
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
@@ -218,21 +153,25 @@ fi
 %dir /plc/data
 %config(noreplace) /plc/data/*
 
-%files devel
-%defattr(-,root,root,-)
-# Host startup script and configuration file
-%{_sysconfdir}/init.d/plc-devel
-%{_sysconfdir}/sysconfig/plc-devel
-
-# Root filesystem
-/plc/devel/root.img
-/plc/devel/root
-
-# Data directory
-%dir /plc/devel/data
-%config(noreplace) /plc/devel/data/*
-
 %changelog
+* Fri Jan 19 2007 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.5-3
+- Split off myplc-devel into separate spec file, so that it can be
+  built standalone.
+
+* Tue Aug 22 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-3, 0.5-3
+- MyPLC 0.4 RC3.
+- Fix upgrade path from RC1.
+- Always regenerate plc_config.xml at first startup
+- Upgrade kernel, iptables, vnet to 2.6.17-1.2142_FC4-3.planetlab
+- Minor PlanetFlow fixes
+- pl_mom/swapmon: Minor fixes
+- bootcd: Added Supermicro IPMI support
+- bootmanager: Cleanup, fixed check for new disks
+
+* Wed Aug 09 2006 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr>
+- introduces variable %{build_devel} to allow custom sites to skip building
+  the myplc-devel package.
+
 * Thu Jul 13 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-2, 0.5-2
 - MyPLC 0.4 RC2.
 - Fix many spec files (License replaces Copyright).