spot duplicated accounts
[myplc.git] / myplc.spec
index 9b6d5dc..6b8e649 100644 (file)
@@ -1,11 +1,10 @@
 #
 # $Id$
-#
 %define url $URL$
 
 %define name myplc
 %define version 5.0
-%define taglevel 0
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -23,7 +22,7 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-
+%define nodefamily %{pldistro}-%{distroname}-%{_arch}
 
 ####################### myplc
 Summary: PlanetLab Central (PLC) Portable Installation
@@ -62,13 +61,14 @@ Requires: vixie-cron
 %endif
 # planetlab stuff
 Requires: bootmanager
-Requires: bootcd-%{pldistro}-%{_arch}
+Requires: bootcd-%{nodefamily}
 Requires: bootcd-initscripts
 Requires: PLCWWW
 Requires: www-register-wizard
 Requires: nodeconfig
+Requires: nodeyum
 Requires: PLCAPI
-Requires: bootstrapfs-%{pldistro}-%{_arch}
+Requires: bootstrapfs-%{nodefamily}
 Requires: myplc-docs
 Requires: myplc-release
 Requires: myplc-config
@@ -143,7 +143,7 @@ chmod 444 ${RPM_BUILD_ROOT}/etc/plc_sliceinitscripts/*
 # Install configuration file
 echo "* myplc: Installing configuration file"
 install -D -m 444 plc_config.dtd ${RPM_BUILD_ROOT}/etc/planetlab/plc_config.dtd
-sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{fcdistro},g" -e "s,@ARCH@,%{arch},g" \
+sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARCH@,%{_arch},g" \
     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
 
@@ -228,8 +228,20 @@ fi
 /etc/planetlab
 /etc/plc_sliceinitscripts
 /etc/support-scripts
-/usr/bin/
 /usr/share/myplc/bashrc
+# keep a detailed list, to avoid duplicate of plc-config,
+# that belongs to the myplc-config rpm
+/usr/bin/plc-config-tty
+/usr/bin/db-config
+/usr/bin/dns-config
+/usr/bin/refresh-peer.py*
+/usr/bin/partial-repo.sh
+/usr/bin/mtail.py*
+/usr/bin/plc-map.py*
+/usr/bin/plc-kml.py*
+/usr/bin/clean-empty-dirs.py*
+/usr/bin/plc-check-ssl-peering.py*
+/usr/bin/plc-orphan-accounts.py*
 
 %files config
 %defattr(-,root,root,-)
@@ -238,6 +250,43 @@ fi
 
 
 %changelog
+* Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
+- avoid duplication of the plc-config binary in both myplc and myplc-config rpms
+
+* Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
+- plc-config-tty now has a validator on booleans
+- e.g. entering 'True' now is rejected rather than silently recording 'false'
+
+* Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
+- disable mod_wsgi
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
+- module name changes
+- start wsgi support
+
+* Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
+- new setting PLC_RESERVATION_GRANULARITY
+
+* Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
+- * partial-repo.sh script
+- * preserve key along with certificates
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
+- set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
+
+* Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
+- legacy scripts gen-sites-xml & gen-static-content back in (sigh)
+- new OMF category in the config
+- create the drl system slice
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- nodefamily is 3-fold with pldistro-fcdistro-arch
+- new PLC_FLAVOUR config category
+- reviewed module layout
+- cleaned up old chroot-related build stuff (does not need the build module when building anymore)
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
 - support for fedora 12
 - new package myplc-config for use by sfa