this is the python3 branch, so always use python3-mod_wsgi
[myplc.git] / myplc.spec
index 425f53d..96e64ea 100644 (file)
@@ -70,11 +70,7 @@ Requires: plewww
 
 # this technically is a plcapi dependency
 # but it's simpler here for chosing which
-%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
 Requires: python3-mod_wsgi
-%else
-Requires: mod_wsgi
-%endif
 
 # this technically is a plewww dependency
 # starting with f27 we depend on this new rpm
@@ -139,7 +135,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # Install configuration scripts
 echo "* Installing plc_config.py in %{python3_sitelib}"
-install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}
+install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}/plc_config.py
 
 echo "* Installing scripts in /usr/bin"
 mkdir -p ${RPM_BUILD_ROOT}/usr/bin