egrep is obsolete
[myplc.git] / myplc.spec
index 22f8c34..aa03ab1 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
-%define version 5.3
-%define taglevel 4
+%define version 7.1
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -30,12 +30,13 @@ Requires: myplc-docs
 Requires: myplc-release
 Requires: myplc-core
 Requires: createrepo
-Requires: bootmanager
-Requires: bootcd-%{nodefamily}
-Requires: bootcd-initscripts
-Requires: nodeimage-%{nodefamily}
-Requires: nodeconfig
-Requires: nodeyum
+## serverside only
+#Requires: bootmanager
+#Requires: bootcd-%{nodefamily}
+#Requires: bootcd-initscripts
+#Requires: nodeimage-%{nodefamily}
+#Requires: nodeconfig
+#Requires: nodeyum
 Requires: www-register-wizard
 
 
@@ -70,11 +71,7 @@ Requires: plewww
 
 # this technically is a plcapi dependency
 # but it's simpler here for chosing which
-%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
 Requires: python3-mod_wsgi
-%else
-Requires: mod_wsgi
-%endif
 
 # this technically is a plewww dependency
 # starting with f27 we depend on this new rpm
@@ -181,8 +178,8 @@ sed -e "s,@PLDISTRO@,%{pldistro},g" -e "s,@FCDISTRO@,%{distroname},g" -e "s,@ARC
     default_config.xml > ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/default_config.xml
 
-echo "* Installing bashrc convenience"
-install -D -m 644 bashrc ${RPM_BUILD_ROOT}/usr/share/myplc/bashrc
+echo "* Installing systemd utilities"
+install -D -m 644 systemd/*.service systemd/*.timer ${RPM_BUILD_ROOT}/usr/lib/systemd/system/
 
 # yumgroups.xml and yum repo : let noderepo handle that
 
@@ -255,7 +252,7 @@ fi
 
 
 %files
-/usr/share/myplc/bashrc
+/usr/lib/systemd/system
 
 %files core
 %defattr(-,root,root,-)
@@ -288,9 +285,15 @@ fi
 %defattr(-,root,root,-)
 /usr/bin/plc-config
 %{python3_sitelib}/plc_config.py*
-
+%exclude %{python3_sitelib}/__pycache__/*.pyc
 
 %changelog
+* Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.1-0
+- ready on f35
+
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
+- suitable for python3 on both f27 and f29
+
 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
 - takes care of creating plcapi log file