explicitly enable and start php-fpm when the rpm is found
[myplc.git] / myplc.spec
index 1f00873..c2b696d 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
 %define version 5.3
-%define taglevel 0
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -38,7 +38,7 @@ Requires: curl
 Requires: rsync
 Requires: python-devel
 Requires: yum
-Requires: PyXML
+#Requires: PyXML
 Requires: createrepo
 Requires: cpio
 Requires: wget
@@ -201,6 +201,7 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
+rpm -q php-fpm >& /dev/null && { systemctl enable php-fpm; systemctl start php-fpm; }
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -261,6 +262,20 @@ fi
 
 
 %changelog
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
+- takes care of creating plcapi log file
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
+- tweaked renew_reminder for federation
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
+- tweaks in check-hrns.py
+- do not require PyXML any more
+
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
+- review check-hrns for plcapi-5.3
+- add PLC_HRN_ROOT in usual plc-config-tty's settings
+
 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
 - add an rpm-sign dependency on feedora>=16