explicitly enable and start php-fpm when the rpm is found
[myplc.git] / myplc.spec
index c33564b..c2b696d 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
 %define version 5.3
-%define taglevel 1
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -201,6 +201,7 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
+rpm -q php-fpm >& /dev/null && { systemctl enable php-fpm; systemctl start php-fpm; }
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -261,6 +262,16 @@ fi
 
 
 %changelog
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
+- takes care of creating plcapi log file
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
+- tweaked renew_reminder for federation
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
+- tweaks in check-hrns.py
+- do not require PyXML any more
+
 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
 - review check-hrns for plcapi-5.3
 - add PLC_HRN_ROOT in usual plc-config-tty's settings