fix resolv.conf issue on plc
[myplc.git] / myplc.spec
index 0c32e34..ed822cf 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc
 %define version 4.3
-%define taglevel 36
+%define taglevel 53
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -30,6 +30,7 @@ Summary: PlanetLab Central (PLC) Portable Installation
 Group: Applications/Systems
 
 # as much as possible, requires should go in the subpackages specfile
+Requires: redhat-lsb
 Requires: bzip2
 Requires: tar 
 Requires: less
@@ -64,7 +65,6 @@ Requires: vixie-cron
 Requires: bootmanager
 Requires: bootcd-%{pldistro}-%{_arch}
 Requires: PLCWWW
-Requires: www-register-wizard
 Requires: nodeconfig
 Requires: PLCAPI
 Requires: pcucontrol
@@ -107,6 +107,7 @@ This package provides the Python module to configure MyPLC.
 %build
 
 %install
+[ -d MyPLC] || ln -s myplc MyPLC
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build.sh %{pldistro} $RPM_BUILD_ROOT
@@ -147,7 +148,7 @@ fi
 
 # 0 = install, 1 = upgrade
 if [ $1 -gt 0 ] ; then
-    for dir in /var/lib/pgsql/data /etc/planetlab ; do
+    for dir in /var/lib/pgsql/data ; do
        if [ -d $dir ] ; then
            echo "Preserving $dir"
            mkdir -p $dir.rpmsave
@@ -170,7 +171,7 @@ fi
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
 if [ $1 -gt 0 ] ; then
-    for dir in /var/lib/pgsql/data /etc/planetlab ; do
+    for dir in /var/lib/pgsql/data ; do
        if [ -d $dir.rpmsave -a -d $dir ] ; then
            echo "Merging $dir"
            if tar -C $dir.rpmsave -cpf - . | \
@@ -220,6 +221,63 @@ fi
 
 
 %changelog
+* Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
+- VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
+- fix gpg update.
+- this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
+- https://bugs.g10code.com/gnupg/issue1122
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
+- use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
+
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
+- generate plc_config.rb via plc-config
+
+* Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
+- Do not preserve /etc/planetlab on upgrade operations
+
+* Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
+- Remove Monitor references from spec file
+
+* Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
+- Introduce staticroute tagtype
+
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
+- attempt to fix small glitches
+
+* Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
+- enable short_open_tag for backward compatibility
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
+- Cherry-pick PHP5 timezone fix form master
+
+* Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
+- pick the greatest version as a kernel
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
+- handle directory name changes for myplc-docs package as well
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
+- handle directory name changes
+
+* Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
+- Use correct resolv.conf file.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
+- Make dnsmasq usable.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
+- Allow dnsmasq configuration to be extended.
+
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
+- support for fedora 12
+- new package myplc-config for use by sfa
+- drupal user registration turned off
+
 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
 - - fix to make sure when API, BOOT, MONITOR are on the same
 - machine as WWW that the SSL key,cert for WWW takes precedence.