fix resolv.conf issue on plc
[myplc.git] / myplc.spec
index 2d5ab98..ed822cf 100644 (file)
@@ -4,26 +4,79 @@
 %define url $URL$
 
 %define name myplc
-%define version 4.2
-%define taglevel 2
+%define version 4.3
+%define taglevel 53
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
-Summary: PlanetLab Central (PLC) Portable Installation
 Name: %{name}
 Version: %{version}
 Release: %{release}
 License: PlanetLab
-Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Requires: tar
+
+
+####################### myplc
+Summary: PlanetLab Central (PLC) Portable Installation
+Group: Applications/Systems
+
+# as much as possible, requires should go in the subpackages specfile
+Requires: redhat-lsb
+Requires: bzip2
+Requires: tar 
+Requires: less
+Requires: sendmail
+Requires: sendmail-cf
+Requires: openssl
+Requires: expect
+Requires: php-pgsql
+Requires: curl
+Requires: rsync
+Requires: python-devel
+Requires: yum
+Requires: PyXML
+Requires: createrepo
+Requires: cpio
+Requires: wget
+Requires: php
+Requires: openssh
+Requires: dnsmasq
+Requires: diffutils
+Requires: gzip
+Requires: vim-minimal
+Requires: findutils
+Requires: xmlsec1
+Requires: xmlsec1-openssl
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 10
+Requires: cronie
+%else
+Requires: vixie-cron
+%endif
+# planetlab stuff
+Requires: bootmanager
+Requires: bootcd-%{pldistro}-%{_arch}
+Requires: PLCWWW
+Requires: nodeconfig
+Requires: PLCAPI
+Requires: pcucontrol
+Requires: bootstrapfs-%{pldistro}-%{_arch}
+Requires: myplc-docs
+Requires: myplc-release
+Requires: myplc-config
+
+# argh - ugly - we might wish to use something from build/config.%{pldistro} instead
+%if "%{pldistro}" == "onelab"
+Requires: dummynet_image
+%endif
 
 %define debug_package %{nil}
 
@@ -31,43 +84,33 @@ Requires: tar
 MyPLC is a complete PlanetLab Central (PLC) portable installation
 contained within a chroot jail. The default installation consists of a
 web server, an XML-RPC API server, a boot server, and a database
-server: the core components of PLC. All PLC services are started up and
+server: the core components of PLC. The installation may be customized
+through a graphical interface. All PLC services are started up and
 shut down through a single System V init script installed in the host
-system. The related Web Interface is now separately packaged
-in the PLCWWW component. 
+system.
 
-%prep
-%setup -q
+####################### myplc-config
 
-%build
-pushd MyPLC
-./build.sh %{pldistro}
-popd
-
-%install
-rm -rf $RPM_BUILD_ROOT
+%package config
 
-pushd MyPLC
-
-#
-# myplc
-#
+Summary: PlanetLab Central (PLC) configuration python module
+Group: Applications/Systems
+Requires: python
 
-# Install host startup script and configuration file
-install -D -m 755 host.init $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/plc
-install -D -m 644 plc.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/plc
+%description config
+This package provides the Python module to configure MyPLC.
 
-# Create convenient symlink
-install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}
-ln -sf /plc/data/etc/planetlab $RPM_BUILD_ROOT/%{_sysconfdir}/planetlab
 
-# Install root filesystem
-install -d -m 755 $RPM_BUILD_ROOT/plc/root
-install -D -m 644 root.img $RPM_BUILD_ROOT/plc/root.img
+%prep
+%setup -q
 
-# Install data directory
-find data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
+%build
 
+%install
+[ -d MyPLC] || ln -s myplc MyPLC
+pushd MyPLC
+rm -rf $RPM_BUILD_ROOT
+./build.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
 %clean
@@ -81,12 +124,12 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
 fi
 
 %pre
 if [ -x %{_sysconfdir}/init.d/plc ] ; then
-    %{_sysconfdir}/init.d/plc safestop
+    %{_sysconfdir}/init.d/plc stop
 fi
 
 # Old versions of myplc used to ship with a bootstrapped database and
@@ -105,16 +148,16 @@ fi
 
 # 0 = install, 1 = upgrade
 if [ $1 -gt 0 ] ; then
-    for dir in /var/lib/pgsql/data /etc/planetlab ; do
-       if [ -d /plc/data/$dir ] ; then
-           echo "Preserving /plc/data/$dir"
-           mkdir -p /plc/data/$dir.rpmsave
-           tar -C /plc/data/$dir -cpf - . | \
-              tar -C /plc/data/$dir.rpmsave -xpf -
+    for dir in /var/lib/pgsql/data ; do
+       if [ -d $dir ] ; then
+           echo "Preserving $dir"
+           mkdir -p $dir.rpmsave
+           tar -C $dir -cpf - . | \
+              tar -C $dir.rpmsave -xpf -
 
            # Except for the default configuration file and DTD, which
            # really should be considered for upgrade.
-           rm -f /plc/data/$dir.rpmsave/{default_config.xml,plc_config.dtd}
+           rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
        fi
     done
 fi
@@ -128,12 +171,12 @@ fi
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
 if [ $1 -gt 0 ] ; then
-    for dir in /var/lib/pgsql/data /etc/planetlab ; do
-       if [ -d /plc/data/$dir.rpmsave -a -d /plc/data/$dir ] ; then
-           echo "Merging /plc/data/$dir"
-           if tar -C /plc/data/$dir.rpmsave -cpf - . | \
-              tar -C /plc/data/$dir -xpf - ; then
-               rm -rf /plc/data/$dir.rpmsave
+    for dir in /var/lib/pgsql/data ; do
+       if [ -d $dir.rpmsave -a -d $dir ] ; then
+           echo "Merging $dir"
+           if tar -C $dir.rpmsave -cpf - . | \
+              tar -C $dir -xpf - ; then
+               rm -rf $dir.rpmsave
            fi
        fi
     done
@@ -142,7 +185,7 @@ fi
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
-    %{_sysconfdir}/init.d/plc safestop
+    %{_sysconfdir}/init.d/plc stop
     if [ -x /sbin/chkconfig ] ; then
         /sbin/chkconfig plc off
        /sbin/chkconfig --del plc
@@ -152,81 +195,307 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-%{_sysconfdir}/init.d/plc
-%{_sysconfdir}/sysconfig/plc
+/etc/init.d/plc
+/etc/plc.d
+/etc/planetlab
+/etc/plc_sliceinitscripts/sirius
+/etc/support-scripts/gen_aliases.py*
+/etc/support-scripts/renew_reminder.py*
+/etc/support-scripts/renew_reminder_logrotate
+/usr/bin/plc-config-tty
+/usr/bin/db-config
+/usr/bin/dns-config
+/usr/bin/plc-map.py*
+/usr/bin/plc-kml.py*
+/usr/bin/refresh-peer.py*
+/usr/bin/clean-empty-dirs.py*
+/usr/bin/mtail.py*
+/usr/bin/plc-check-ssl-peering.py*
+/usr/bin/plc-orphan-accounts.py*
+/usr/share/myplc/bashrc
+
+%files config
+%defattr(-,root,root,-)
+/usr/bin/plc-config
+%{python_sitearch}/plc_config.py*
 
-# Symlink to /etc/planetlab within data directory
-%{_sysconfdir}/planetlab
 
-# Root filesystem
-/plc/root.img
-/plc/root
+%changelog
+* Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
+- VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
+- fix gpg update.
+- this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
+- https://bugs.g10code.com/gnupg/issue1122
 
-# Data directory
-%dir /plc/data
-%config(noreplace) /plc/data/*
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
+- use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
 
-%changelog
-* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-1 myplc-4.2-2
-- knows how to checkpoint and restore
-- packages step more robust, in particular with empty node repository
-- miscell tweaks for native packaging
-
-* Wed Jan 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.0-15 myplc-4.2-0
-moving to 4.2 - no change
-
-* Fri Jan 19 2007 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.5-3
-- Split off myplc-devel into separate spec file, so that it can be
-  built standalone.
-
-* Tue Aug 22 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-3, 0.5-3
-- MyPLC 0.4 RC3.
-- Fix upgrade path from RC1.
-- Always regenerate plc_config.xml at first startup
-- Upgrade kernel, iptables, vnet to 2.6.17-1.2142_FC4-3.planetlab
-- Minor PlanetFlow fixes
-- pl_mom/swapmon: Minor fixes
-- bootcd: Added Supermicro IPMI support
-- bootmanager: Cleanup, fixed check for new disks
-
-* Wed Aug 09 2006 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr>
-- introduces variable %{build_devel} to allow custom sites to skip building
-  the myplc-devel package.
-
-* Thu Jul 13 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-2, 0.5-2
-- MyPLC 0.4 RC2.
-- Fix many spec files (License replaces Copyright).
-- Fix kernel build under gcc32 (module verification bug).
-- Fix vnet build under gcc32
-- Fix PlanetFlow. MySQL RPM postinstall script no longer starts the
-  server. Also, get hostnames list from PLC_WWW_HOST, not
-  www.planet-lab.org.
-- Fix pl_mom/bwmon to use cached values if NM is unresponsive
-- Fix pl_mom/swapmon reset logic to avoid endless loops
-- Remove ksymoops, add kernel-smp to standard PlanetLab package group
-- Add kernel-smp boot support to bootmanager
-- Add badblock search support to bootmanager
-- Build development environment (myplc-devel). Add support for
-  building myplc itself inside myplc-devel.
-- Move step-specific initialization to appropriate plc.d scripts
-- Fix postgresql startup failure when bootstrapping
-- Allow CA to be configured for each SSL certificate set. Stop doing
-  root CA stuff, this is outside the scope of MyPLC. MyPLC now only
-  generates self-signed certificates, but supports replacement of the
-  self-signed certificates with real certifcates signed by another CA,
-  as long as the CA is specified.
-- Self-sign the MA/SA SSL certificate (and by extension, the MA/SA API
-  certificate).
-- pl_mom: Workarounds for when NM queries time out.
-- plc_api: Honor PLC_MAIL_ENABLED.
-
-* Wed Jul  6 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-1, 0.5-1
-- First stable release of MyPLC 0.4 RC1.
-
-* Wed Apr  5 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.2-1
-- Basic functionality complete. Consolidate into a single package
-  installed in /plc.
-
-* Fri Mar 17 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.1-1
-- Initial build.
+* Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
+- generate plc_config.rb via plc-config
+
+* Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
+- Do not preserve /etc/planetlab on upgrade operations
+
+* Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
+- Remove Monitor references from spec file
+
+* Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
+- Introduce staticroute tagtype
+
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
+- attempt to fix small glitches
+
+* Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
+- enable short_open_tag for backward compatibility
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
+- Cherry-pick PHP5 timezone fix form master
+
+* Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
+- pick the greatest version as a kernel
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
+- handle directory name changes for myplc-docs package as well
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
+- handle directory name changes
+
+* Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
+- Use correct resolv.conf file.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
+- Make dnsmasq usable.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
+- Allow dnsmasq configuration to be extended.
+
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
+- support for fedora 12
+- new package myplc-config for use by sfa
+- drupal user registration turned off
+
+* Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
+- - fix to make sure when API, BOOT, MONITOR are on the same
+- machine as WWW that the SSL key,cert for WWW takes precedence.
+- - Do proper setup for SSL CA certficate to be used as the server
+- chain.
+
+* Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
+- - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
+
+* Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
+- depend on pcucontrol
+
+* Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
+- * validate input according to type in plc_config
+- * added the _genicw system slice
+- * add tag types for sites and persons
+- * add new tags for nodes and slices for exemption from myops
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
+- turn off drupal on a box that acts as BOOT server but not as WWW server
+- cleanup some obsolete code for old chroot-jail packaging in the process
+- new bootcd-kernel script for keeping bootcd variants up2date
+
+* Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
+- Make the /etc/hosts manipulation optional.
+
+* Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
+- Fix SetRole.
+
+* Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
+- - Added "SetRole()" so that db-config.d/ scriplets can insert roles
+- into the DB.
+- - Added the root ssh key handling support back into plc.d/ssh and the
+- default xml file.  This should be identical to the way it was in
+- rc12.
+- - Added support in the db-config.d/01-init script to register the root
+- ssh public key with the default administrator.  In this way the root
+- ssh key will make it into the root account on the nodes by means of
+- NodeManager's specialaccounts plugin.
+
+* Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
+- db-config ignores sliver tags
+- sirius's db-config script renamed (was sirious)
+
+* Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
+- fix for silverauth - missing tag types now created at plc startup time
+
+* Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
+- plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
+
+* Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
+- companion to NM's specialaccounts plugin
+- do not generate /etc/planetlab/root_ssh_key* anymore
+- remove related config. variables and conf_files
+
+* Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
+- clarified description text to refer only to plcrt and not other optional
+- packages.
+
+* Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
+- fixed a bug setting slice multiple attributes with the same tag name
 
+* Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
+- SSL setup for monitor box, and related new config variables
+- new conf_file for /etc/planetlab/extensions
+- various tweaks in db-config internals, about initscripts among others
+- also more messages defined in the db
+
+* Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
+- create node tags, like e.g. 'arch', that were not handled with 4.3-20
+
+* Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
+- bugfix in db-config, tag 4.3-19 would not fly
+
+* Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
+- Refactored db-config into snippets in db-config.d/.
+
+* Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
+- oops, tag 4.3-17 was broken and would not work
+
+* Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
+- bugfix - escape sequences inserted in xml configs
+
+* Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
+- Handle db-config.d files properly.
+
+* Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
+- - Fix /etc/init.d/plc to have command usage show up on the tty rather
+- than the log file
+- - Fix db-config to be a bit more cautious when
+- /etc/planetlab/db-config.d doesn't exist
+- - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
+- .orig files.
+- - Refactor generic plc-config-tty code into plc_config.py.
+- plc-config-tty now contains MyPLC specific paths, "usual" variables,
+- and the list of validated variables and the corresponding
+- validator() function. This refactoring lets one reuse plc_config.py
+- as a generic cmdline configuration tool for highly customer MyPLC
+- like software.
+
+* Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
+- update PCU Type descriptions.
+- updates to init scripts
+
+* Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
+- requires monitor-pcucontrol so register-wizard can work
+
+* Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
+- cleaned up plc-config-tty, no more need to configure plc-devel
+
+* Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
+- first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
+
+* Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
+- fix issue in db-config that prevented correct operation
+
+* Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
+- remove support for chroot-based packaging - no crond nor syslog step anymore
+- plc init script now named plc.init instead of former guest.init
+
+* Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
+- add Monitor to docs build
+
+* Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
+- plc_config.py and plc-config-tty: generalized to work for more diverse
+- MyPLC configurations.
+- plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
+- deployments and increase the memory limits in php.ini
+- plc.d/crond: add --full option to vacuumdb
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
+- avoid generating ssl certificates for disabled services among www api boot
+
+* Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
+- cleaned up old entries in db-config
+- mtail more robust
+
+* Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
+- php include path tweaked for plekit includes
+- reviewed myplc (fka native) packaging dependencies
+- renumbered 4.3
+
+* Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
+- rename myplc into myplc-chroot and myplc-native into myplc
+- new settings (shortname & hrn_root) for local peer
+
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
+- First iteration of new data model
+- Bunch of various fixes
+
+* Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
+- Removed proper ops from planetflow slice.
+
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
+- myplc-native requires myplc-docs
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
+- turn myplc-docs off for now
+
+* Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
+- figures in doc package
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
+- no more doc packaged outside of myplc-docs - doc/ cleaned up 
+- chroot packaging does not have docs anymore
+- 'cvs' and 'dev' not required from myplc-native anymore
+- cosmetic change in kml output
+
+* Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
+- defaults for *_IP conf vars now void, expect more accurate /etc/hosts
+- gethostbyname uses python rather than perl (hope this shrinks deps) 
+- doc: reviewed myplc doc - deprecated everything related to myplc-devel
+- doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
+- make sync now works towards vserver-based myplc only 
+
+* Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
+- 
+- added vsys 'pfmount' script to the default netflow slice attributes.
+- 
+
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
+- plc.d/bootcd step altered for handling legacy bootcd smooth migration
+- to new bootcd packaging
+
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
+- changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
+
+* Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
+- packaging of mplc-release in myplc-native
+- sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
+- resolv file in /etc/resolv.conf, not plc_resolv.conf
+- improved sirius script
+- remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
+- expires more properly set 
+
+* Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
+- 
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
+- renew_reminder script moved to support-scripts/
+- gen-aliases script added in support-scripts/
+- sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
+- plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
+- nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
+- new native slice attributes 'capabilities', 'vsys' and 'codemux'
+- new setting 'Mom list address' for sending emails to a separate destination
+- starts rsyslogd/syslogd as appropriate
+- expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
+- convenience generation of yum.conf in resulting image based on build/mirroring
+
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
+- refresh-peer.py removed (duplicate with PLCAPI)
+- plc.d/ scripts cleaned up
+- sirius initscript updated
+- slice auto renewal fixed
+
+* Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
+- initial build.
+
+%define module_current_branch 4.2