registrationview
[myslice.git] / myslice.spec
1 %define name myslice
2 %define version 0.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: MySlice Frontend
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: GPLv3
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 Vendor: OpenLab
16 Packager: OpenLab <thierry.parmentelat@inria.fr>
17 URL: %{SCMURL}
18
19 Requires: python >= 2.7
20 Requires: Django
21 Requires: httpd
22 Requires: mod_wsgi
23 BuildRequires: python-setuptools make
24
25 %description 
26 The MySlice frontend provides a django application that interacts with
27 a manifold backend to provide a User-Interface to a federation of
28 testbeds.
29
30 %prep
31 %setup -q
32
33 %build
34 %{__make} build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__make} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(-,root,root,-)
45 %dir %{_datadir}/myslice
46 %{_datadir}/myslice/*
47
48 %changelog
49 * Mon Apr 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-3
50 - a small number of representative plugins are available
51 - next step is to correlate a Get query with its corresponding Update like in slice.php
52
53 * Mon Mar 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-2
54 - new pluing 'hazelnut' which is a tmpname for the former datatables one
55 - querycode is syntaxhighlighter-enabled
56