packaging
[myslice.git] / myslice.spec
1 %define name myslice
2 %define version 0.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: MySlice Frontend
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: GPLv3
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 Vendor: OpenLab
16 Packager: OpenLab <thierry.parmentelat@inria.fr>
17 URL: %{SCMURL}
18
19 # We use set everywhere
20 Requires: python >= 2.7
21 Requires: Django
22 BuildRequires: python-setuptools make
23
24 %description 
25 The MySlice frontend provides a django application that interacts with
26 a manifold backend to provide a User-Interface to a federation of
27 testbeds.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__make} build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__make} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(-,root,root,-)
44 %dir %{_datadir}/myslice
45 %{_datadir}/myslice/*
46
47 %changelog