Setting tag myslice-django-0.1-3
[myslice.git] / myslice.spec
1 %define name myslice
2 %define version 0.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: MySlice Frontend
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: GPLv3
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 Vendor: OpenLab
16 Packager: OpenLab <thierry.parmentelat@inria.fr>
17 URL: %{SCMURL}
18
19 # We use set everywhere
20 Requires: python >= 2.7
21 Requires: Django
22 Requires: httpd
23 Requires: mod_wsgi
24 BuildRequires: python-setuptools make
25
26 %description 
27 The MySlice frontend provides a django application that interacts with
28 a manifold backend to provide a User-Interface to a federation of
29 testbeds.
30
31 %prep
32 %setup -q
33
34 %build
35 %{__make} build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %{__make} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(-,root,root,-)
46 %dir %{_datadir}/myslice
47 %{_datadir}/myslice/*
48
49 %changelog
50 * Mon Apr 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-3
51 - a small number of representative plugins are available
52 - next step is to correlate a Get query with its corresponding Update like in slice.php
53
54 * Mon Mar 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-2
55 - new pluing 'hazelnut' which is a tmpname for the former datatables one
56 - querycode is syntaxhighlighter-enabled
57