run enforced client-authentication ssl on port 443
[myslice.git] / myslice.spec
1 %define name myslice
2 %define version 0.2
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: MySlice Frontend
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: GPLv3
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15 Vendor: OpenLab
16 Packager: OpenLab <thierry.parmentelat@inria.fr>
17 URL: %{SCMURL}
18
19 Requires: python >= 2.7
20 # in f14 this used to be called Django
21 Requires: python-django
22 Requires: httpd
23 Requires: mod_wsgi
24 # for c_rehash
25 Requires: openssl-perl
26 BuildRequires: python-setuptools make
27
28 %description 
29 The MySlice frontend provides a django application that interacts with
30 a manifold backend to provide a User-Interface to a federation of
31 testbeds.
32
33 %prep
34 %setup -q
35
36 %build
37 %{__make} build
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(-,root,root,-)
48 %dir %{_datadir}/myslice
49 %{_datadir}/myslice/*
50
51 %changelog
52 * Wed Sep 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-4
53 - move to bootstrap v3 complete - hopefully
54 - static files directory is now plain static/
55 - templates files directory is now plain templates/
56 - packaging for debian should be working fine, using apache+wsgi
57
58 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-3
59 - checkpoint for deployment on test.myslice.info
60
61 * Mon Sep 09 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-2
62 - cleaner tag, using module-tag for consistent numbering
63
64 * Mon Apr 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-3
65 - a small number of representative plugins are available
66 - next step is to correlate a Get query with its corresponding Update like in slice.php
67
68 * Mon Mar 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-2
69 - new pluing 'hazelnut' which is a tmpname for the former datatables one
70 - querycode is syntaxhighlighter-enabled
71