Setting tag nodeconfig-4.3-8
[nodeconfig.git] / nodeconfig.spec
1 #
2 # $Id$
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
5
6 %define name nodeconfig
7 %define version 4.3
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 # cannot do this as of f12
21 #BuildArch: noarch
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # We use set everywhere
29 Requires: php >= 5.0
30 Requires: PLCAPI >= 4.3
31 # need the apache user at install-time
32 Requires: httpd 
33
34 %description
35
36 The nodeconfig package provides various php scripts that are used to
37 generate configuration files for nodes. It is taken out of the PLCWWW
38 module because it has crucial impact on nodes, while PLCWWW can and
39 does have several implementations at this moment. For historical
40 reasons these scripts get installed in /var/www/html/PlanetLabConf.
41
42 %prep
43 %setup -q
44
45 %build
46 pushd nodeconfig/yum
47
48 KEXCLUDE="exclude=$(../../build/getkexcludes.sh)"
49
50 # expand list of kexcludes
51 for filein in $(find . -name '*.in') ; do
52     file=$(echo $filein | sed -e "s,\.in$,,")
53     sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
54 done
55
56 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
57
58 for fcdistro in $(ls); do
59     [ -d $fcdistro ] || continue
60     pushd $fcdistro/yum.myplc.d
61     rm -f stock.repo
62     cat *.repo > stock.repo
63     popd
64 done
65
66 popd
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 pushd nodeconfig
72
73 echo "* nodeconfig: Installing PlanetLabConf pages"
74
75 for dir in boot PlanetLabConf PLCAPI ; do
76     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
77     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
78 done
79
80 # the yum area -- se db-config
81 # expose (fixed) myplc.repo.php as                                          https://<plc>/yum/myplc.repo.php
82 install -D -m 644 ./yum/myplc.repo.php                       $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
83 # expose the fcdistro-dependant yum.conf as                                 https://<plc>/yum/yum.conf
84 install -D -m 644 ./yum/%{distroname}/yum.conf               $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
85 # expose the (fcdistro-dependant) stock.repo as                             https://<plc>/yum/stock.repo
86 install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
87
88 popd
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 # the boot manager upload area
95 mkdir -p /var/log/bm
96 chown apache:apache /var/log/bm
97 chmod 700 /var/log/bm
98
99 %files
100 %defattr(-,root,root,-)
101 /var/www/html/boot
102 /var/www/html/PlanetLabConf
103 /var/www/html/PLCAPI
104 /var/www/html/yum
105
106 %changelog
107 * Fri Mar 11 2011 S.Çağlar Onur <caglar@verivue.com> - nodeconfig-4.3-8
108 - add sl6 support
109
110 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-7
111 - - decompose PlanetLabConf/sysctl.php into sysctl.conf and
112 - sysctl-ip_forward.php. This is in prep of phasing out the latter
113 - altogether, as enabling ip_forwarding should be something that is
114 - managed by NM.
115 - - PlanetLabConf/ntptickers.php migrated PlanetLabConf/ntp/step-tickers.php
116 - - Added sfa_config.php
117 - - updated ntp server set for .de (german) nodes.
118 - - f12 related changes from Thierry/Baris
119
120 * Sun Nov 22 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-6
121 - For all MyPLC nodes deployed at Polish Telecom (PLC, PLE and CoBlitz),
122 - use the TP local NTP servers.
123
124 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-5
125 - new script for updating the exentions set
126 - keys.php reviewed
127 - cleanup useless scripts
128
129 * Sat Jul 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - nodeconfig-4.3-4
130 - add two views to the PLC config data, limited and unlimited.
131 - unlimited view reports all values.  Requires the 'infrastructure=1' tag and
132 - that the call originates from the node.
133
134 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-3
135 - changes to sysctl.conf for co* relating to tcp window scaling
136
137 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-2
138 - renumbered 4.3
139 - new script upload-bmlog.php
140 - attempts to ship decent yum configs for stock repos to nodes
141 - cleanup old stuff
142 - attempts to be 4.2 compatible
143
144 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-1
145 - reflects new names from the data model
146
147 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
148 - keys.php know about monitor
149 - new sudoers.php script
150
151 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
152 - Added support for centralized PlanetFlow.
153
154 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
155 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
156 - former content has moved down into PlanetLabConf
157
158
159 %define module_current_branch 4.2