use site specific NTP servers
[nodeconfig.git] / nodeconfig.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name nodeconfig
7 %define version 4.2
8 %define taglevel 13
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # We use set everywhere
28 Requires: php >= 5.0
29 Requires: PLCAPI >= 4.0
30
31 %description
32
33 The nodeconfig package provides various php scripts that are used to
34 generate configuration files for nodes. It is taken out of the PLCWWW
35 module because it has crucial impact on nodes, while PLCWWW can and
36 does have several implementations at this moment. For historical
37 reasons these scripts get installed in /var/www/html/PlanetLabConf.
38
39 %prep
40 %setup -q
41
42 %build
43 EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
44 for filein in $(find . -name '*.in') ; do
45     file=$(echo $filein | sed -e "s,\.in$,,")
46     sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
47 done
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 echo "* nodeconfig: Installing PlanetLabConf pages"
53
54 for dir in boot PlanetLabConf PLCAPI ; do
55     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
56 done
57 # let's be conservative and exclude codebase files, though there should not be any
58 rsync -a --exclude \*.spec --exclude .svn --exclude \*.in ./ $RPM_BUILD_ROOT/var/www/html/
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(-,root,root,-)
65 /var/www/html/boot
66 /var/www/html/PlanetLabConf
67 /var/www/html/PLCAPI
68
69 %changelog
70 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-13
71 - This configuration file has a single line addition to the standard configuration and it's based on state maintained in the DB.  This has been deprecated in favor of maintaining it in NM.  The standard configuration is in the iptables module and the nodegroup specific addition is created when the ipset is created by NM.
72
73 * Mon Sep 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-12
74 - yum config for nodes needs to mention the additional 'newkey' repository
75
76 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - nodeconfig-4.2-11
77 - PlanetFlow/codemux fix
78 - Used "./module-tag -b 4.2 nodeconfig:4.2".
79
80 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-10
81 - syntax error. Fixed.
82
83 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-9
84 - Updated ntp conf files.
85 - I2 iptables for nodes on I2.
86
87 * Thu Jul 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-8
88 - iptables superceded by svn/iptables/planetlab-config
89
90 * Sat Jul 19 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-7
91 - svn keyword expansion fixed, no functional change
92
93 * Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-6
94 - yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
95
96 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-5
97 - yum.conf.php handles nodegroups and slicefamily
98 - svn keywords fixed
99
100 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
101 - keys.php know about monitor
102 - new sudoers.php script
103
104 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
105 - Added support for centralized PlanetFlow.
106
107 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
108 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
109 - former content has moved down into PlanetLabConf
110