a08241d72c238ecdcd1624eec70f2e460de9c333
[nodeconfig.git] / nodeconfig.spec
1 #
2 # $Id$
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
5
6 %define name nodeconfig
7 %define version 5.0
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # We use set everywhere
28 Requires: php >= 5.0
29 Requires: PLCAPI >= 5.0
30
31 %description
32
33 The nodeconfig package provides various php scripts that are used to
34 generate configuration files for nodes. It is taken out of the PLCWWW
35 module because it has crucial impact on nodes, while PLCWWW can and
36 does have several implementations at this moment. For historical
37 reasons these scripts get installed in /var/www/html/PlanetLabConf.
38
39 %prep
40 %setup -q
41
42 %build
43 EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
44 for filein in $(find . -name '*.in') ; do
45     file=$(echo $filein | sed -e "s,\.in$,,")
46     sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
47 done
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 echo "* nodeconfig: Installing PlanetLabConf pages"
53
54 for dir in boot PlanetLabConf PLCAPI ; do
55     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
56     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
57 done
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(-,root,root,-)
64 /var/www/html/boot
65 /var/www/html/PlanetLabConf
66 /var/www/html/PLCAPI
67
68 %changelog
69 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-1
70 - reflects new names from the data model
71
72 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
73 - keys.php know about monitor
74 - new sudoers.php script
75
76 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
77 - Added support for centralized PlanetFlow.
78
79 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
80 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
81 - former content has moved down into PlanetLabConf
82
83
84 %define module_current_branch 4.2