Setting tag nodeconfig-5.2-1
[nodeconfig.git] / nodeconfig.spec
1 #
2
3 %define name nodeconfig
4 %define version 5.2
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Central (PLC) nodes configuration files generator
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 # cannot do this as of f12
18 #BuildArch: noarch
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %{SCMURL}
24
25 # We use set everywhere
26 Requires: php >= 5.0
27 Requires: plcapi >= 5.2
28
29 %description
30
31 The nodeconfig package provides various php scripts that are used to
32 generate configuration files for nodes. It is taken out of the PLCWWW
33 module because it has crucial impact on nodes, while PLCWWW can and
34 does have several implementations at this moment. For historical
35 reasons these scripts get installed in /var/www/html/PlanetLabConf.
36
37 %prep
38 %setup -q
39
40 %build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 echo "* nodeconfig: Installing PlanetLabConf pages"
46
47 for dir in PlanetLabConf PLCAPI ; do
48     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
49     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
50 done
51
52 # Install db-config.d files
53 echo "* Installing db-config.d files"
54 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
55 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
56 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62
63 %files
64 %defattr(-,root,root,-)
65 /var/www/html/PlanetLabConf
66 /var/www/html/PLCAPI
67 /etc/planetlab/db-config.d
68
69 %changelog
70 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.2-1
71 - no-op, just bump to 5.2 to be in line with the rest of the system
72
73 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-7
74 - no change, just reworked make sync to cope with lxc-hosted tests
75
76 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-6
77 - support for hotfixes
78
79 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-5
80 - remove backward compat to GetNodeNetworks and the like
81
82 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-4
83 - trashed sfa_component_setup job & conf file
84
85 * Wed Sep 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodeconfig-5.0-3
86 - check file before reading the configuration.
87
88 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-2
89 - new php scripts for configuring sfa component cron
90
91 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-1
92 - first working version of 5.0:
93 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
94 - the yum/ and boot/ subdirs have moved away from here
95
96 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-7
97 - - decompose PlanetLabConf/sysctl.php into sysctl.conf and
98 - sysctl-ip_forward.php. This is in prep of phasing out the latter
99 - altogether, as enabling ip_forwarding should be something that is
100 - managed by NM.
101 - - PlanetLabConf/ntptickers.php migrated PlanetLabConf/ntp/step-tickers.php
102 - - Added sfa_config.php
103 - - updated ntp server set for .de (german) nodes.
104 - - f12 related changes from Thierry/Baris
105
106 * Sun Nov 22 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-6
107 - For all MyPLC nodes deployed at Polish Telecom (PLC, PLE and CoBlitz),
108 - use the TP local NTP servers.
109
110 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-5
111 - new script for updating the exentions set
112 - keys.php reviewed
113 - cleanup useless scripts
114
115 * Sat Jul 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - nodeconfig-4.3-4
116 - add two views to the PLC config data, limited and unlimited.
117 - unlimited view reports all values.  Requires the 'infrastructure=1' tag and
118 - that the call originates from the node.
119
120 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-3
121 - changes to sysctl.conf for co* relating to tcp window scaling
122
123 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-2
124 - renumbered 4.3
125 - new script upload-bmlog.php
126 - attempts to ship decent yum configs for stock repos to nodes
127 - cleanup old stuff
128 - attempts to be 4.2 compatible
129
130 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-1
131 - reflects new names from the data model
132
133 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
134 - keys.php know about monitor
135 - new sudoers.php script
136
137 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
138 - Added support for centralized PlanetFlow.
139
140 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
141 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
142 - former content has moved down into PlanetLabConf
143
144
145 %define module_current_branch 4.3