Setting tag nodeconfig-5.0-3
[nodeconfig.git] / nodeconfig.spec
1 #
2 # $Id$
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
5
6 %define name nodeconfig
7 %define version 5.0
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 # cannot do this as of f12
21 #BuildArch: noarch
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # We use set everywhere
29 Requires: php >= 5.0
30 Requires: PLCAPI >= 4.3
31
32 %description
33
34 The nodeconfig package provides various php scripts that are used to
35 generate configuration files for nodes. It is taken out of the PLCWWW
36 module because it has crucial impact on nodes, while PLCWWW can and
37 does have several implementations at this moment. For historical
38 reasons these scripts get installed in /var/www/html/PlanetLabConf.
39
40 %prep
41 %setup -q
42
43 %build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 echo "* nodeconfig: Installing PlanetLabConf pages"
49
50 for dir in PlanetLabConf PLCAPI ; do
51     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
52     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
53 done
54
55 # Install db-config.d files
56 echo "* Installing db-config.d files"
57 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
58 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
59 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65
66 %files
67 %defattr(-,root,root,-)
68 /var/www/html/PlanetLabConf
69 /var/www/html/PLCAPI
70 /etc/planetlab/db-config.d
71
72 %changelog
73 * Wed Sep 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodeconfig-5.0-3
74 - check file before reading the configuration.
75
76 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-2
77 - new php scripts for configuring sfa component cron
78
79 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-1
80 - first working version of 5.0:
81 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
82 - the yum/ and boot/ subdirs have moved away from here
83
84 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-7
85 - - decompose PlanetLabConf/sysctl.php into sysctl.conf and
86 - sysctl-ip_forward.php. This is in prep of phasing out the latter
87 - altogether, as enabling ip_forwarding should be something that is
88 - managed by NM.
89 - - PlanetLabConf/ntptickers.php migrated PlanetLabConf/ntp/step-tickers.php
90 - - Added sfa_config.php
91 - - updated ntp server set for .de (german) nodes.
92 - - f12 related changes from Thierry/Baris
93
94 * Sun Nov 22 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-6
95 - For all MyPLC nodes deployed at Polish Telecom (PLC, PLE and CoBlitz),
96 - use the TP local NTP servers.
97
98 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-5
99 - new script for updating the exentions set
100 - keys.php reviewed
101 - cleanup useless scripts
102
103 * Sat Jul 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - nodeconfig-4.3-4
104 - add two views to the PLC config data, limited and unlimited.
105 - unlimited view reports all values.  Requires the 'infrastructure=1' tag and
106 - that the call originates from the node.
107
108 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-3
109 - changes to sysctl.conf for co* relating to tcp window scaling
110
111 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-2
112 - renumbered 4.3
113 - new script upload-bmlog.php
114 - attempts to ship decent yum configs for stock repos to nodes
115 - cleanup old stuff
116 - attempts to be 4.2 compatible
117
118 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.3-1
119 - reflects new names from the data model
120
121 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
122 - keys.php know about monitor
123 - new sudoers.php script
124
125 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
126 - Added support for centralized PlanetFlow.
127
128 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
129 - integrated /var/www/html/{boot,PLCAPI} from PLCWWW
130 - former content has moved down into PlanetLabConf
131
132
133 %define module_current_branch 4.3