creation
[nodeconfig.git] / nodeconfig.spec
1 #
2 # $Id: PLCWWW.spec 7881 2008-01-22 14:45:22Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
5
6 %define name nodeconfig
7 %define version 4.2
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) nodes configuration files generator
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # We use set everywhere
28 Requires: php >= 5.0
29 Requires: PLCAPI >= 4.0
30
31 %description
32
33 The nodeconfig package provides various php scripts that are used to
34 generate configuration files for nodes. It is taken out of the PLCWWW
35 module because it has crucial impact on nodes, while PLCWWW can and
36 does have several implementations at this moment. For historical
37 reasons these scripts get installed in /var/www/html/PlanetLabConf.
38
39 %prep
40 %setup -q
41
42 %build
43 echo "There is no build stage for this component."
44 echo "All files just need to be installed as is from the codebase."
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 echo "* nodeconfig: Installing PlanetLabConf pages"
50
51 mkdir -p $RPM_BUILD_ROOT/var/www/html/PlanetLabConf
52 # let's be conservative and exclude codebase files, though there should not be any
53 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/PlanetLabConf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 /var/www/html/PlanetLabConf
61