1 %define name bootstrapfs
3 %define release 0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 Packager: PlanetLab Central <support@planet-lab.org>
7 Distribution: PlanetLab 4.2
8 URL: http://svn.planet-lab.org/svn/BootStrapFS/
10 Summary: The PlanetLab Bootstrap Filesystems
15 Group: System Environment/Base
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 Requires: tar, gnupg, sharutils, bzip2
22 %define debug_package %{nil}
26 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
27 BootManager to instantiate a node with a new filesystem.
36 rm -rf $RPM_BUILD_ROOT
38 install -D -m 644 PlanetLab-Bootstrap.tar.bz2 \
39 $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap.tar.bz2
41 for bootstrapfs in $(ls bootstrap-filesystems/*.lst) ; do
42 NAME=$(basename $bootstrapfs .lst)
43 install -D -m 644 bootstrap-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
44 $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap-${NAME}.tar.bz2
48 rm -rf $RPM_BUILD_ROOT
51 if [ -n "$SUDO_USER" ] ; then
52 # Allow user to delete the build directory
53 chown -h -R $SUDO_USER .
54 # Some temporary cdroot files like /var/empty/sshd and
55 # /usr/bin/sudo get created with non-readable permissions.
56 find . -not -perm +0600 -exec chmod u+rw {} \;
57 # Allow user to delete the built RPM(s)
58 chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
65 %defattr(-,root,root,-)
67 /var/www/html/boot/PlanetLab-Bootstrap*.tar.bz2
70 * Fri Sep 2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -