bugfix, wrong command name
[nodeimage.git] / bootstrapfs.spec
index 2bd608b..083edf1 100644 (file)
@@ -1,23 +1,26 @@
 #
-# $Id$
-#
-%define url $URL$
 
 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
 %define extensionfamily %{distroname}-%{_arch}
 
 %define name bootstrapfs-%{nodefamily}
 %define version 2.0
-%define taglevel 3
+%define taglevel 13
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
+# we don't really need the standard postinstall process from rpm that
+# strips files and byte-compiles python files. all files in this
+# package are comming from other rpm files and they've already went
+# through this post install processing. - baris
+%define __os_install_post %{nil}
+
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
 Name: %{name}
@@ -31,6 +34,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2
+# this is for plc.d/packages that uses ed for hacking yumgroups.xml
+Requires: ed
 
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
@@ -63,23 +68,29 @@ for the MyPLC side.
 %build
 
 ############################## node-side
-pushd BootstrapFS
+[ -d bootstrapfs ] || ln -s BootstrapFS bootstrapfs
+pushd bootstrapfs
 ./build.sh %{pldistro} 
+for tar in *.tar *.tar.bz2; do 
+   echo "* Computing SHA1 checksum for $tar"
+   sha1sum $tar > $tar.sha1sum
+   chmod 444 $tar.sha1sum
+done
 popd
 
 ############################## server-side
 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
-pushd BootstrapFS/nodeconfig/yum
+pushd bootstrapfs/nodeconfig/yum
 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
 for fcdistro in $(ls); do
     [ -d $fcdistro ] || continue
-    # get kexcludes for that distro
-    KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
+    # get packages to exclude on nodes for that fcdistro/pldistro
+    NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro $pldistro)"
     pushd $fcdistro/yum.myplc.d
-    echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
+    echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
     for filein in $(find . -name '*.in') ; do
        file=$(echo $filein | sed -e "s,\.in$,,")
-       sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
+       sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
     done
     rm -f stock.repo
     cat *.repo > stock.repo
@@ -91,25 +102,20 @@ popd
 rm -rf $RPM_BUILD_ROOT
 
 ############################## node-side
-pushd BootstrapFS
-
-install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
-       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
-install -D -m 644 bootstrapfs-%{nodefamily}.tar \
-       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
-
-for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
-    NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
-    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
-               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
-    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
-               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
+pushd bootstrapfs
+for out in *.tar *.tar.bz2 ; do
+    echo "* Installing $out"
+    install -D -m 644 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
+done
+for out in *.sha1sum; do
+    echo "* Installing $out"
+    install -D -m 444 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
 done
 popd
 
 ############################## server-side
 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
-pushd BootstrapFS
+pushd bootstrapfs
 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
 rsync -av ./nodeconfig/yum/    $RPM_BUILD_ROOT/var/www/html/yum/
@@ -132,10 +138,12 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 /var/www/html/boot/bootstrapfs*.tar.bz2
+/var/www/html/boot/bootstrapfs*.tar.bz2.sha1sum
 
 %files plain
 %defattr(-,root,root,-)
 /var/www/html/boot/bootstrapfs*.tar
+/var/www/html/boot/bootstrapfs*.tar.sha1sum
 
 %files -n nodeyum
 %defattr(-,root,root,-)
@@ -144,6 +152,39 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
+- plc.d/packages: rewrote comments about some corner cases where it fails
+- plc.d/packages: marginally more robust
+
+* Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
+- minor tweak in plc.d/packages
+
+* Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
+- sl6 templates
+
+* Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
+- bugfix for multi-flavour deployments
+
+* Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
+- for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
+
+* Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
+- no semantic change - attempt to speed up build
+
+* Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
+- yum repo template for f14 nodes
+- tweaks the way /etc/plc.d/packages works
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
+- add sha1sum
+- module name changes
+
+* Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
+- support different flavours of vservers on nodes
+
+* Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
+- fix unmatched $ in URL svn keywords
+
 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
 - choice between various pldistros is not made at build time, but at run time
 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5